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REAL-TIME REPORTS
CHAPTER 1 MITEL CONNECT AGENT MANAGER HELP

Mitel Connect Agent Manager Help

Mitel Connect Agent Manager is used by managers and supervisors to obtain real-time statistical infor-
mation concerning contact center activities. The information can be displayed in tables, forms, and 
graphic formats, providing a clear picture of what is going on in your contact center.Agent Manager also 
enables supervisors to adjust their resources by adding or removing agents from groups.Real Time 
reports are used to perform the following functions:
• Present statistical data on call center activity in real time.
• Manage agents.
• React to changing situations.

Real-time Reports
This type of report includes:
• Real-time information — Real-time information is what is currently happening in the contact center. 

(This may include the number of calls in the queue, the average and maximum waiting time for queued 
calls, etc.)

• Statistics on the current interval — each group is assigned an "Interval Time." The real-time statistic 
is calculated over this interval. (This interval may also be called "Slide Time Interval".) The data is 
continually updated so that the latest information for the current time interval is always displayed. For 
example, if the time interval defined is one hour and the time is currently 10:30, the data presented will 
be for the time period 9:30 - 10:30. At 9:35, for example, the data presented will be for the time period 
8:35 - 9:35.

• Statistics on the previous interval — Statistical information that was calculated during the real-time 
interval previous to the current interval. For example, at 10:35, the previous interval would be the time 
period between 8:35 to 9:35.

Refer to Mitel Connect Agent Manager Field Reference for reference information for the fields you can 
add to real-time reports.

Daily Summary Reports
This type of report includes:
• Real-time information — That is, what is currently happening in the call center, (This may include the 

number of calls in the queue, the average and maximum waiting time for queued calls, and so forth.)
• Statistics since last midnight — The real-time statistic collected during the current day starting at 

midnight.

The data continually updated so that the latest information for today is always displayed. For example, at 
10:30, the data presented summarizes the information since last midnight until the current time.
Refer to Mitel Connect Agent Manager Field Reference for reference information for the fields you can 
add to real-time reports.

https://oneview.mitel.com/s/article/Mitel-Connect-Agent-Manager-Field-Reference
https://oneview.mitel.com/s/article/Mitel-Connect-Agent-Manager-Field-Reference
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Hourly Summary Reports
 Hourly reports do not accumulate statistics in real-time, but display reports based on hourly intervals (i.e., 
the number of times, within a twenty-four hour period, that a supervisor' hourly reports are updated). An 
hourly report is a tabular report in which each line displays the data for a specific hourly interval. The last 
line of the report displays the totals. Each time an hourly interval is completed, a new line is added to the 
report. All hourly reports are re-started at midnight.Real-time data is presented in Report Windows.Agent 
Manager is implemented using dynamic reports that reflect actual contact center activity.To work with 
reports in the system, it is important to understand the difference between a report window, and a report 
template.Refer to Mitel Connect Agent Manager Field Reference for reference information for the fields 
you can add to real-time reports.

Report Windows
 The requested information is displayed in a report window. The displayed information is dynamic in 
real-time reports, constantly changing according to actual contact center activity.The format and content 
of information displayed in report windows is based on predefined templates, described in the following 
section. The report name, as well as the name of the template it based on are appearing in the report 
title.There are two types of report windows: public and private. Public reports are available to all the super-
visors who are allowed to access Agent Manager.Private reports are available only to the supervisor who 
created the report.Supervisors must be authorized to save public report windows. With the proper autho-
rization, supervisors can select the public or private option, or both.

Report Templates
 A report template is the "blueprint" for the information displayed in the report window.The application 
includes a set of predefined real-time report templates (default templates). The parameters of each 
template can be configured according to what information is desired in the generated report window.This 
section includes descriptions of all templates as well as step-by-step instructions for creating all types of 
real-time reports and converting them to a window are also presented.By default, Agent Manager speci-
fies thresholds for real-time group activity. Information on this activity is displayed by running specific 
reports. When the activity, such as number of calls in queue, reaches or exceeds a threshold, you receive 
an alert. The data in the report is usually highlighted in either yellow or red when a threshold is reached. 
Thresholds are defined using the Mitel Connect Contact Center Director 
> Groupings > Groups > Thresholds tab.In addition to a color indicator, an audible alert is available. 
This alert can either be a system beep or a sound from a WAV file, and it can be configured to play once 
or continuously for a specified period of time. Alerts are configured using Mitel Connect Contact Center 
Director > Supervisors > Alerts.Agent Manager provides two default files used as the audible alerts, 
warning.wav and alarm.wav. When data meets or exceeds the "yellow" threshold level, the sound in the 
warning.wav file is used. The alarm.wav file sounds when the data meets or exceeds the "red" threshold 
level. You can use custom alerts by recording or using an existing WAV file. Save your custom sounds in 
the Supervisor\Bin folder of your Contact Center directory with the filename custom_warning.wav and 
custom_alarm.wav.Contact your system administrator to implement or change threshold levels for 
specific group activities. In order to use audible alerts, your system must be configured for this feature. 
Check with your system administrator if you have questions about using or implementing audible alerts.

https://oneview.mitel.com/s/article/Mitel-Connect-Agent-Manager-Help
https://oneview.mitel.com/s/article/Mitel-Connect-Agent-Manager-Field-Reference
https://oneview.mitel.com/s/article/Mitel-Connect-Agent-Manager-Help
https://oneview.mitel.com/s/article/Mitel-Connect-Agent-Manager-Help
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CHANGING AGENT GROUP ASSIGNMENTS
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Changing Agent Group Assignments
 Agent Manager's Login Manager enables you to change the group assignment of agents currently 
working in the call center. The Login Manager has two optional views: Agent Login Status and Group 
Login Status. In the Agent Login Status view, you can see an agent's current group assignment. You can 
then add or remove groups to and from the agent. The Group Login Status view allows you to see the 
agents currently logged into a specific group. You can then add or remove agents to and from the 
group.To open the Login Manager, do one of the following:
1. Click the Login Manager icon on the Agent Manager Toolbar.
2. Right-click a report based on the Group Agents Report or Brief Agent Report templates, and then 

select Login Manager from the popup menu.

The Agents Login Status tab contains the following items:
• Agents - Lists all agents currently logged into the system.
• Name - The name of the agent
• Number - The ID number of the agent
• Logged-in Groups - Lists the groups that the selected agent is currently logged into.
• Available Groups - Lists the groups that the agent is currently not logged into.

The Groups Login Status tab includes the following items:
• Groups - Lists all groups defined in the system.
• Logged-in Agents - Lists the agents currently logged into the selected group.
• Available Agents - Lists the agents currently not logged into the selected group, but logged into at 

least one other group.

You can create a new real-time report for current information on your call center.If you want to generate 
reports on call activity in an IVR Application, you first need to specify the associated DNIS. Refer to DNIS 
Information for Voice Call Activity for more information.

Creating a Real-Time Report
 To create a new report:
1. From the File menu, click New. You can also click the New icon on the Toolbar. The New dialog box 

appears.
2. From the Report Type drop-down list, click the report type you want.

3. Select the template from the Template Name list, and click OK. The appropriate New Entity dialog 
box appears.

4. You can change the sort order of the entities in the list to more easily find the entity you want. To do 
so, click the entity title. Entities listed alphabetically are displayed in reverse alphabetical order; enti-
ties listed by number are displayed in reverse numerical order.

5. Select the required entity, and click OK.The selected Report window appears. The window title bar 
indicates that the report is untitled, and displays the name of the template on which the report is based.

Any current activity in the ACD is immediately reflected in the report.

https://oneview.mitel.com/s/article/Mitel-Connect-Agent-Manager-Help
https://oneview.mitel.com/s/article/Mitel-Connect-Agent-Manager-Help
https://oneview.mitel.com/s/article/Mitel-Connect-Agent-Manager-Help
https://oneview.mitel.com/s/article/Mitel-Connect-Agent-Manager-Help
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OPENING AN EXISTING REAL-TIME REPORT
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Opening an Existing Real-Time Report
 To open an existing real-time report:
1. From the File menu, click Open. You can also click the Open icon on the Toolbar. The Open dialog 

box appears.
2. To narrow the list of reports displayed, select Public or Private (both options can be selected), and 

from the Report Type drop-down list, select the report type.

3. Select the report to open, and click OK.

Modifying Real-Time Reports
 Once you have create a real-time report, you can modify the report to reflect the data you want to see. 
Refer to the following pages for additional information.
• Generating Reports Based on One Entity
• Generating Reports for Multiple Entities
• Reordering the Items in a Report

A report can be saved in both the public and private report lists. All authorized supervisors can view public 
reports, but private reports are viewable only by the supervisor that created them.

Saving a Real-Time Report
 To save a real-time report:
1. To save a report with its current properties, from the File menu, click Save. You can also click the 

Save icon on the Toolbar. If the current report has not yet been saved, the Save button is disabled.
2. To save a report under a different name, or to save a private report as public (or the reverse), from 

the File menu, click Save As.

You can also click the Save As icon on the Toolbar. The Save As window opens. Use the Save As dialog 
box to specify the name and location of the report.

Setting the Refresh Rate
 The refresh rate defines how often Agent Manager requests an update from the server. By default, the 
refresh rate is one second. You can instead set a refresh rate that is automatically determined based on 
the network load, or set a specific rate.If an activity begins and ends before the next update of information, 
this activity is not reported in the report. For example, if the refresh rate is 5 seconds and an agent speaks 
on a call for 3 seconds, this call is counted as a call but there will be no change in the agent state.To set 
the refresh rate:
1. From the Tools menu, click Refresh Rate.
• If you want the system to automatically set the refresh rate depending on the load of the network, 

choose Automode.

https://oneview.mitel.com/s/article/Mitel-Connect-Agent-Manager-Help
https://oneview.mitel.com/s/article/Mitel-Connect-Agent-Manager-Help
https://oneview.mitel.com/s/article/Mitel-Connect-Agent-Manager-Help
https://oneview.mitel.com/s/article/Mitel-Connect-Agent-Manager-Help
https://oneview.mitel.com/s/article/Mitel-Connect-Agent-Manager-Help
https://oneview.mitel.com/s/article/Mitel-Connect-Agent-Manager-Help
https://oneview.mitel.com/s/article/Mitel-Connect-Agent-Manager-Help
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SAVING A WORKSPACE
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• If you want to set a specific refresh rate, choose Manual Mode. The Refresh Rate dialog box opens.

1. Select the refresh rate in seconds, and click OK. If the manually set refresh rate is determined by the 
system to be insufficient for the current network load, the system automatically increases the rate to 
a more efficient number (e.g., 5 seconds to 7 seconds).

Saving a Workspace
 You can create a personal workspace such that, each time you start Agent Manager, the reports you are 
most interested in are automatically displayed and updated.To create a workspace:
1. Open, create, modify, and place the reports you want to automatically see each time you start Agent 

Manager. You can use the commands from the Windows menu to place and order the reports in a 
layout you want.

2. Click File > Workspace > Save As Default. The layout is saved as your default workspace.

3. You can always revert to your default workspace by clicking File > Workspace > Restore Default.

Generating Reports
 If you want to generate reports on voice call or email activity in an IVR Application, you first need to 
specify the associated DNIS.A DNIS number is a series of digits that identifies to Contact Center the 
number that was dialed by the caller. The DNIS number is used to collect statistics on the Contact Center 
activity that is routed through specific entry points that a customer dials.

Generating Reports for Voice Calls

 For voice calls, to specify a DNIS for an IVR application:
1. In Contact Center Director, select Routing > DNIS.
2. To create a new DNIS, click New and enter the appropriate DNIS information. Refer to DNIS Informa-

tion for Voice Call Activity for more information.

3. Click Create.To edit an existing DNIS, from the List View select the DNIS enter the appropriate infor-
mation. Click Save.

Generating Reports for Emails

 For emails, to specify a DNIS for an IVR application:
1. From Contact Center Director, select Email > Email DNIS.
2. To create a new email DNIS, click New and enter the appropriate DNIS information. Refer to DNIS 

Information for Email Activity for more information.

3. Click Create.

To edit an existing DNIS, select the DNIS record you want to modify in the List View, enter the appropriate 
information, and click Save.

https://oneview.mitel.com/s/article/Mitel-Connect-Agent-Manager-Help
https://oneview.mitel.com/s/article/Mitel-Connect-Agent-Manager-Help
https://oneview.mitel.com/s/article/Mitel-Connect-Agent-Manager-Help
https://oneview.mitel.com/s/article/Mitel-Connect-Agent-Manager-Help
https://oneview.mitel.com/s/article/Mitel-Connect-Agent-Manager-Help
https://oneview.mitel.com/s/article/Mitel-Connect-Agent-Manager-Help
https://oneview.mitel.com/s/article/Mitel-Connect-Agent-Manager-Help
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CHAPTER 1 MITEL CONNECT AGENT MANAGER HELP

Generating Reports Based on One Entity

 For reports based on only one entity, you can change the entity without having to create a new report.To 
change the report entity:
1. In an open report, click Contents > Change. You can also click the Change icon on the Toolbar. The 

Change Entity dialog box appears, listing the entities not included in the report.
2. To change the sort order of the entities in the list to more easily find the entity you want, click the entity 

title. Entities listed alphabetically are displayed in reverse alphabetical order; entities listed by number 
are displayed in reverse numerical order.

3. Select the entity that you want the report to now be based on, and then click OK.

Generating Reports for Multiple Entities

 For reports based on more than one entity, you can add entities without having to create a new report.For 
DNIS reports, you can select up to 1,500 DNIS entities per report. However, note that reports with more 
than 20 DNIS entities will take additional time to generate.To add an entity to a report:
1. In an open report, click Contents > Add. You can also click the Add icon on the Toolbar. The Add 

Entity dialog box appears listing the entities not in the report.
2. To change the sort order of the entities in the list to more easily find the entity you want, click the entity 

title. Entities listed alphabetically are displayed in reverse alphabetical order; entities listed by number 
are displayed in reverse numerical order.

3. Select the entity to add to the report, and then click OK.

Removing Entities from Reports
 For reports based on more than one entity, you can remove entities without having to create a new 
report.To remove an entity from a report:
1. In an open report, click Contents > Remove. You can also click the Remove icon on the Toolbar. 

The Remove Entity dialog box appears, listing the entities in the report.
2. To change the sort order of the entities in the list to more easily find the entity you want, click the entity 

title. Entities listed alphabetically are displayed in reverse alphabetical order; entities listed by number 
are displayed in reverse numerical order.

3. Select the entity to removed from the report, and then click OK.

Reordering the Items in a Report
 For tabular reports, you can change the order of the items in the report to be sorted by name, number, 
or extension number (if applicable).To reorder the items in a report:
1. In an open report, click Contents > Reorder. You can also click the Reorder icon on the Toolbar. 

The Reorder dialog box appears.
2. Select the desired sort criteria, and then click OK. The report entries are reordered according to your 

selection.

https://oneview.mitel.com/s/article/Mitel-Connect-Agent-Manager-Help
https://oneview.mitel.com/s/article/Mitel-Connect-Agent-Manager-Help
https://oneview.mitel.com/s/article/Mitel-Connect-Agent-Manager-Help
https://oneview.mitel.com/s/article/Mitel-Connect-Agent-Manager-Help
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Reordering Fields in a Report
 You can change the order of the fields in a tabular report by clicking the header of the field you want 
move, and then dragging the field to its new location in the report.You can add and remove fields in a 
tabular report.

Adding or Removing Fields in a Report
 To add or remove fields in a report:
1. In an open report, click the Add/Remove Columns icon on the Toolbar. The Add/Remove Columns 

dialog box appears.
2. To add a field, select the field(s) in the Available Columns list, and click Add.

3. To remove a field, select the field(s) in the Visible Columns list, and click Remove.

4. Click OK.

DNIS Information for Voice Call Activity
 If you want to generate reports on voice call activity in an IVR Application, you first need to specify the 
associated DNIS.The DNIS options are:
• Name. A unique name for the DNIS.
• Number. The IRN number represented by the DNIS as an entry point for voice or chat contacts.
• Target ASA. Target Average Speed of Answer. The amount of time (in seconds, in case of a Voice or 

Chat DNIS, or in hh:mm in case of an email DNIS) during which the call should be answered from the 
time it is received. This parameter is used to calculate the DNIS Target Service Factor (TSF).

• Short Calls Threshold. The amount of time (in seconds, in case of a Voice or Chat DNIS, or in hh:mm 
in case of an email DNIS) in which a call must end to be counted as a too short call in the Contact 
Center Reports.

• Max ACD Talk Time. The amount of time (in seconds, in case of a Voice or Chat DNIS, or in hh:mm 
in case of an email DNIS) that a call must exceed to be counted as a too long call in the Contact Center 
Reports.

• Interval Time. Determines the time period that will be monitored in the real-time reports for the DNIS. 
If this field is set to ten minutes, for example, the real-time report for that DNIS will show statistical infor-
mation relevant to the last ten minutes.

• Service Time Intervals. This parameter determines the time intervals in which calls are monitored. 
The calls can be viewed in STI histogram reports that show the number of calls answered, abandoned, 
and waiting in each given interval.

DNIS Information for Email Activity
 If you want to generate reports on email activity in an IVR Application, you first need to specify the asso-
ciated DNIS.The DNIS options are:
• Name. A unique name for the DNIS.

https://oneview.mitel.com/s/article/Mitel-Connect-Agent-Manager-Help
https://oneview.mitel.com/s/article/Mitel-Connect-Agent-Manager-Help
https://oneview.mitel.com/s/article/Mitel-Connect-Agent-Manager-Help
https://oneview.mitel.com/s/article/Mitel-Connect-Agent-Manager-Help
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• Email Account. The email account represented by the DNIS.
• Target ASA. The amount of time in which the email should be answered from the time it is received, 

and is used to calculate the DNIS Target Service Factor (TSF).
• Short Calls Threshold. The amount of time in which interaction with an email must end to be counted 

as "too short" in historical reports.
• Max ACD Talk Time. The amount of time that interaction with an email must exceed to be counted as 

"too long" in historical reports.
• Interval Time. The time period that will be monitored for realtime reports for the email DNIS
• Service Time Intervals. The time intervals in which emails are monitored. Statistics on the emails can 

be viewed in STI histogram reports that show the number of emails waiting in each given interval.
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