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INTRODUCTION 

This document describes the following Open Application Server (OAS) service tools: 

• OAS Media Port Activity Monitor (MPAM) 

• OAS Trace Viewer 

• OAS Log Zipper 

• OAS Log Unzipper 

WHAT YOU WILL LEARN 

The following are discussed in detail: 

• How to launch the Media Port Activity Monitor, Trace Viewer, OAS Log Zipper and OAS Log Unzipper. 

• How to interpret the Media Port Activity Monitor results. 

• How to create Trace Viewer databases. 

• How to query Trace Viewer databases using simple and two stage filters. 

• How to query Trace Viewer databases using SQL statements. 

• How to save queries. 

• How to save results to a database. 

• How to interpret the result of your queries. 

• How to open an existing Trace Viewer database. 
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MEDIA PORT ACTIVITY MONITOR 

The Media Port Activity Monitor (MPAM) captures media service events (for example ASR, TTS and Sound 

player) allowing you to view and track these activities as they occur. 

OVERVIEW 

The OAS Media Server provides media services using the resources that exist on the host system. It has a 

CSTA interface and communicates with MX-ONE over IP extension lines. Each Media Server contains a 

number of call channels (that is, media ports), connected to an MX-ONE through H.323 or SIP lines. The 

media ports are mapped to directory numbers configured within that Media Server. 

The Media Port Activity Monitor connects to the OAS Trace Service, through which it captures the media 

service events, and displays these events on the Media Port Viewer window. This enables you to 

dynamically track activities as they occur on the ports. 

HOW TO LAUNCH THIS APPLICATION 

1. From the Start menu click Programs. 

2. Point to Service Tools, then Media Port Monitor. 
 

 
Note:   The OAS Trace function must be set to On for the Media Servers that are to be 

monitored in order for the Media Port Activity Monitor to work. 

The Media Port monitor tool will not work if local IPMS logging is enabled.  For 

additional information, please consult the document OPEN APPLICATION SERVER 

SOFTWARE CONFIGURATION, item ENABLING IP MEDIA SERVER LOCAL 

TRACE. 

MEDIA PORT ACTIVITY MONITOR WINDOW 

The Media Port Activity Monitor Window is shown in Figure 1: 
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Figure 1: Media Port Activity Monitor Window 

See the table below below for a description of the default column names. 

Table 1 Column Name description 

COLUMN NAME DESCRIPTION 

Event Time Displays time when the last event occurred on that port. 

Media Server Host Displays the Media Server Host name. 

Port Displays the number of the Media port. 

Channel ID Displays the Call Channel ID. 

Call ID Displays the Network Resource Manager Call ID. 

Event Displays the occurring event. 

Additional Information Displays resource information. 

  

Each row in the Media Port Activity Monitor window corresponds to a media port. The information in the rows 

changes when events through the media port changes. This mean you can dynamically monitor events as 

they occur. 

 
Note:   Only applicable information is shown. That is, there can be fields for ports that 

don't show any information. A row, or specific port information, is updated only if a 

new event occurs on that particular port. This update results in modification only of 

those fields that are present in the item. The rest are left as is. 

When a call is cleared on a port, all columns for it are cleared except: 
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• Event Time 

• Media Server Host 

• Event 

• Port 

If no events are received on a port for 120 seconds, and the last event received is not a Connection cleared 

event, the contents of the port are shown in red. This indicates the possibility of an error. When no new calls 

on a port for a predefined duration of 240 seconds, the port is shown as inactive. 

MENU OVERVIEW 

There are three main menus associated with the Media Port Activity Monitor: 

• File 

• View 

• Help 

FILE MENU 

The File menu only have one command; Exit, which is used to close the application.  

VIEW MENU 

The Clear command in the View menu is used to refresh the Media Port Activity Monitor window. 

The View Summary command launches Media port Summary Infor- mation dialog, see Figure 2 below. 

 

Figure 2: Media Port Summary Information 

Each row in the Media port Summary Information dialog corresponds to a media port. The values in this 

dialog are not updated dynamically. Click Refresh to update this dialog, and to have the current values 

displayed. To see all columns, scroll the horizontal scroll bar. 
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The column names in the Media Port Summary Information dialog are described in Table 2 Media Port 

Summary Information Dialog Description below: 

Table 2  Media Port Summary Information Dialog Description 

COLUMN NAME DESCRIPTION 

PORT Displays the number of the Media port. 

ARRQ Displays the number of Allocate Resource Request in a port. 

ARCF Displays the number of Allocate Resource Confirmation in a port. 

ARFE Displays the number of Allocate Resource Failed Event in a port. 

ACRQ Displays the number of Answer Call Request in a port. 

ACCF Displays the number of Answer Call Confirmation in a port. 

ACFE Displays the number of Answer Call Failed Event in a port. 

ESTE Displays the number of Established Event in a port. 

PLRQ Displays the number of Play Request in a port. 

PLCF Displays the number of Play Confirmation in a port. 

PLSE Displays the number of Play Started Event in a port. 

PLEE Displays the number of Play Ended Event in a port. 

PLFE Displays the number of Play Failed Event in a port. 

CCRQ Displays the number of Clear Connection Request in a port. 

CCCF Displays the number of Clear Connection Confirmation in a port. 

CCLE Displays the number of Connection Cleared Event in a port. 

HELP MENU 

The About MediaPortMonitor command displays current version and copyright information. 
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TRACE VIEWER 

OAS Trace Viewer Service Tool enables users to search and view specific OAS trace file information 

pertaining to calls and system events. 

OVERVIEW 

OAS creates trace files that document call and event information. The Trace Viewer utility allows you to 

search one or multiple trace files in order to create an Access database. When a database file is created, the 

Trace Viewer dialog boxes can be used to create queries into the database to quickly find and view 

information. 

 
Note:   Trace function must be turned On for the trace files to be created. 

HOW TO LAUNCH THIS APPLICATION 

1. From the Start menu click Programs. 

2. Point to Mitel OAS, Service Tools and Trace Viewer. 

MENU OVERVIEW 

There are three main menus associated with the Trace Viewer: 

• File 

• View 

• Help 

FILE MENU 

From the File menu users can perform operations related to trace files and databases. See Table 3 File 

Menu commands below for a description of the commands. 

Table 3  File Menu commands 

COMMAND SHORTCUT TOOLBAR ICON DESCRIPTION 

New Ctrl+N OR ALT+F+N  

 

Launches a wizard that allows you to 
specify a list of trace files to be parsed 
as well as indicate the name and 
location of a new Access database to 
store the results of the parsing. 

Open ALT+F+O OR 

Ctrl+O 

 

 

 

Opens the File Open dialog box that 
allows you to select an existing 
database associated with a previous 
parsing. 

Save Query 

Result 

ALT+F+S OR 

Ctrl+S 

 

 

Opens a Save As dialog box that 
allows you to save the results of your 
query as a new Access database. 

This option is only available after you 
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COMMAND SHORTCUT TOOLBAR ICON DESCRIPTION 

 have executed a query on an existing 
database. 

Close ALT+F+C  Closes the current database. 

Exit ALT+F+X OR ALT+F4  Exits the Trace Viewer. 

    

VIEW MENU 

From the View menu, the user can create queries and view event and call results obtained from the current 

database. See Table 4 View Menu commands below for a description of the commands. 

Table 4  View Menu commands 

COMMAND SHORTCUT DESCRIPTION 

Trace Filter ALT+V+T OR 

Ctrl+T 

Opens the Trace Filter dialog box that 
is used to search for the occurrence of 
a particular event in the trace entries 
that are stored in the database table. 
This command is only available if a 
database is open. 

Free Format Query ALT+V+Q OR 

Ctrl+ Q 

Opens the Free Format Query dialog 
box  that is used to search for the 
occurrence of a particular event using 
an SQLquery. 

This command is only available if a 
database is open. 

Media Port Viewer ALT+V+M OR 

Ctrl+ M 

Opens the Media Port Viewer where 
you can dynamically monitor events as 
they occur through the media ports. 

Toolbar  Displays or hides the toolbar. 

Status Bar  Displays or hides the status bar. 

HELP MENU 

The Help menu only contains one command, see description in Table 5 Help Menu command below. 

Table 5  Help Menu command 

COMMAND SHORTCUT TOOLBAR ICON DESCRIPTION 

About ServiceTools ALT+H+A OR 

Ctrl+A 

 

 

 

Displays Service Tool version 
information. 
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HOW TO CREATE TRACE DATABASES 

From the OAS Trace Viewer it is possible to: 

• Create a new Trace database. 

• Search an existing database using Simple and Free Format query filters. 

• Save queries. 

• Retrieve queries. 

CREATE A NEW DATABASE 

The Trace File Wizard allows you to create a database table from OAS trace files, based on the following 

criteria: 

• All Trace files located in the selected folder 

• All Trace files located in the selected folder, which contain a specified text string 

• All Trace files located in the selected folder which were created within a certain time interval 

1. From the File menu, select New. The first page of the wizard appears. 

 

2. Enter information according to Table 6 Description of the information input below. 

Table 6  Description of the information input 

OBJECT DESCRIPTION 

Save results of parsing Enter a name for your new database. 

Click Browse next to Save results of parsing field to select a location 
for your new database, or to select an existing database. 

If you select an existing name, you will be asked to confirm if you wish to 
overwrite the existing file. 
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OBJECT DESCRIPTION 

Trace Folder Path Displays the folder path that contains the trace files to be parsed. 

Click Browse next to the Trace Folder Path field to select another 
folder path location. 

Config Folder Path Displays the folder path that contains the OAS grammar files. These 
files contain the Grammar used to parse the Trace files. 

By default this field will show the path where the default grammars are 
installed by OAS installation. Click Browse next to Config Folder Path 
field to select another location. 

Selection of Trace Files Section 

Select a search mode to determine the list of files to be parsed. You can search based on traces files 
containing a specified text string, trace files created within a specified time interval or all trace files. 

Search Mode:  

All Files Default option. 

Click to search all files in the indicated folder. 

Search on a String Select and input your search string in the Search String field to search 
for specific text. Search String is only enabled if the Search on a 
String radio button is ticked. 

Enter a search string you wish to find. You can use wild cards (for 
example allocate*) within your string. 

Date & Time Interval Select and input Start and End dates as well as time ranges. Start Date, 
End Date, From and To are enabled only if Date & Time Interval option 
is selected. 

  

3. Click Next. 

The Proceed and parse dialog box appears with a list of files that match your search criteria. 

 

4. Click the option you wish to perform, see Table 7 Proceed and Parse options below. 

Table 7  Proceed and Parse options 

OBJECT DESCRIPTION 

Parse Searches all displayed files. The result is stored in the database table that you 
indicated in the Database Table Name field. The result will appear in the Trace 
Viewer window, shown in Figure 
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OBJECT DESCRIPTION 

3  on page 16. 

Cancel Cancels the parsing activity. 

Back Returns to the previous wizard page where you can modify your search 
information. 

  

 

Figure 3: Trace Viewer Window Results 

OPEN AN EXISTING DATABASE 

View and perform searches on an existing database by performing the following: 

1. Select File and Open. 

2. Locate the trace database (.mdb) file you wish to open. 

3. Click Open. 

The Table List dialog box appears. Trace Viewer databases in general have one table in them named as 

trace_db. 
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4. Select the trace_db table, and click OK. 

The selected database data appears in the Trace Viewer window, and the view shall be similar to one 

created by parsing the trace files, (Figure 3 above). 

QUERYING THE TRACE VIEWER DATABASE 

Trace Viewer databases can be queried using two different methods: 

Trace Filter 

Creates an SQL query from the selection made by the user. 

Free Format Query 

Filter the user manually inputs the query using SQL syntax. 

The result of these Queries is a table that matches the information you have entered. 

DIALOG BOX OVERVIEW 

There are two main dialog boxes associated with the Trace Viewer that are used to perform searches. 

1. Trace Filter dialog box 

2. Free Format Query dialog box 

Trace Filter dialog box 

The Trace Filter dialog box, see  Figure 4 below, is accessed from the View menu by selecting Trace Filter. 

See Table 8 Trace Filter Description below for a description of the fields in the dialog box. 

 
Note:   The Trace Filter command can only be accessed once a database is opened. 

The Trace Filter dialog is used to search for a particular event in the trace entries that 

are stored in the data- base table. 
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Figure 4: Trace Filter dialog box 

Table 8  Trace Filter Description 

OPTION DESCRIPTION 

Group Field Lists available database fields. Selecting a field causes your query results 
to be displayed using the selected field as the primary display filter. Leave 
this option blank if you wish to perform a simple trace. 

Trace Filter Description Enter a one-line description that describes the purpose of the current 
query. This field is optional. 

Table Fields Select a database field to perform your search on. 

Relates Select a relational operation for your search. Options include <,<=, = >, 
>= and Like. 

Field Criteria Enter your specific search criteria. This can be a string or a numeric 
value. 

Load Select a previously saved query that is stored as a .stq file. 

Search Performs a search based on the provided information. 

Save Saves the current query in a (.stq) file. 

If you wish to save a query, be sure to click Save before initiating the 
search. 

Cancel Closes the dialog box with no action taken. 

  

If you previously created a query in this session, by default this query appears when you return to this dialog 

box. 

Free Format Query dialog box 

The Free Format Query dialog, see Figure 5  below, is accessed from the View menu by selecting Free 

Format Query. It is used to search for a particular event in the trace entries by entering a SQL query. For a 

description of the dialog box, see table 9 Free Format Query Description below. 
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Figure 5: Free Format Query dialog box 

Table 9  Free Format Query Description 

OPTION DESCRIPTION 

Group Field Lists available database fields. Selecting a field causes your query results to be 
displayed using the selected field as the primary display filter. 

Query Description Enter a one-line description that describes the purpose of the current query. This 
field is optional. 

Query Definition Enter an SQL query. If you previously created a query, by default this query 
appears in the field. 

Note: The Tool does not check for correct syntax. 

Load Retrieve a previously saved query that is stored as a .stq file. 

Search Perform a search based on the provided information. The syntax of the entered 
SQL query is not checked before execution.  If an error is detected a message 
box appears. 

Save Save the current query in a (.stq) file. 

Cancel Closes the dialog box with no action taken. 

CREATE A SIMPLE QUERY USING THE TRACE FILTER 

Simple filters allow you to use up to five table fields to query an existing trace database. The result is a table 

that matches the information you have entered. 

1. From the View menu select Trace Filter. The Trace Filter dialog box appears. Do not select a Group 
Field option. 

2. Select a Table Field. 

3. Select how the field relates to the Field Criteria. 

4. Enter the value you wish to find in the Field Criteria field. 

5. Repeat steps 2-4 for up to five table fields (if needed). 

6. Click Search. Your selected filters translate into a SQL query. The result appears in a single pane 
window that displays all the records that match your search criteria. 

 
Note:   If you perform an additional query, your results will not be based on the data 

that is currently on the screen but on the database that is currently open. If you wish 

to perform a query on the results on the screen, you must first save your screen 
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results to a data- base and then perform a query on the new database. 

Example: 

1. Leave the Group Filter blank. 

2. Select the following for the first Filter (see Figure 6  below) 

• Table Fields: Event. 

• Relates: = 

• Field Criteria: AllocateResourceConf 

3. Click Search. The entered information translates to the following SQL query:Select * from <table 
name> where Event = ‘Alloca- teResource Conf’ 

The result displays all records which contains the AllocateResourceConf event from all Calls. 

 

Figure 6: A Simple Query using Trace Filter 

CREATE A TWO STAGE QUERY USING TRACE FILTER 

By selecting a database field from Group Field a more complex query can be created. The results display in 

a two-pane view. 

1. Select Trace Filter from the View menu. The Trace Filter dialog box appears, as shown in Figure 7 
below. 

2. Select a Group Filter. 

3. Select options for each desired filter. 

4. Click Search. A two-pane window appears that displays your search results. 
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Figure 7: A Two Stage Query using Trace Filter. 

The following is an example of a two-stage filter: 

1. User selects “NrmCallID” in the Group Filter. 

2. User selects the following for the first filter: 

• Table Fields: Event 

• Relates: LIKE 

• Field Criteria: *Play* 

3. User clicks Search. When the search is complete, the results in Table 10 Result below appear. 

Table 10 Result 

LEFT PANE RIGHT PANE 

Displays the call ID:s resulting from the following: 

Select NrmCallID from <table name> where Event 
LIKE ‘*Play*’ 

Blank. 

  

If the user selects one of the call ID:s from the left pane, then the right pane will be refreshed with all the 

records for the selected Call ID. Each time the user selects a different call ID, the right pane refreshes with 

the new call ID records. That is, each time the user selects a different call ID, the right pane window will be 

populated with the result of the following query, see Figure 8 below. 

Select * from <table name> where NrmCallID = <call id selected by the user> 
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Figure 8: Result of a two stage Query 

CREATE A SIMPLE QUERY USING FREE FORMAT FILTER 

1. Select Free Format Filter from the View menu. The Free Format Filter dialog box appears, see Figure 9 
below. 

2. Enter your SQL query in the Query Definition field. 

 
Note:   Do not select a database filed from the Group Field List. 

3. Click Search. The result of your query appears. 
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Figure 9: A Simple Query using Free Format Filter. 

CREATE A TWO STAGE QUERY USING FREE FORMAT FILTER 

1. Select Free Format Filter from the View Menu . The Free Format Filter dialog box appears. 

2. a database field from the Group Field List on which you wish to perform a query, see Figure 10  below. 

3. Enter your Query in the Query Definition Field. 

4. Click Search. The Result of the Query appears. 

The two-stage translates the input into a query as follows: 

Select <Database Field from Group Field List> from <User’s Query in Query Definition Field>. 

An example of a two-stage query is shown in Figure 10 below.  

 

 

Figure 10:A Two Stage Query using Free Format Filter. 

 
Note:   If you perform an additional query, your results will not be based on the data 

that is currently on the screen but on the database that is currently open. If you wish 

to perform a query on the results on the screen, you must first save your screen 

results to a data- base and then perform a query on the new database. 

SAVE A QUERY 

A query can be saved once a search from either the Trace Filter or Free Format Query dialog box has been 

performed. Do the following: 

1. After you have selected your search criteria, optionally enter a description in the associated Description 
field to describe the query. 

2. Click Save. The Save as dialog appears. 

3. Name the query. Do not modify the .stq extension. 

4. Click Save. A confirmation dialog appears that indicates the query was saved. 

5. Click OK to return to the search dialog box. 



Open Application Server – Service Tools User Guide 

20 

 

LOAD AN EXISTING QUERY 

A saved query can be retrieved from either the Trace Filter or Free Format Query dialog box by doing the 

following: 

1. Select Trace Filter or Free Format Query from the View menu. The associated dialog box appears. 

2. Click Load. The Open dialog box appears. 

3. Select the .stq file that contains the desired search query. 

4. Click Open. The selected query appears. 

SAVE THE RESULTS OF YOUR QUERY TO A DATABASE 

1. When having performed a query and the results appear in the Trace Viewer window, go to File and 
select Save Query. The Save As dialog box appears. 

2. Enter a name for your database or select an existing database. 

3. Click Save. A database is created with your query results. 

4. Open Application Server Log Zipper 

The OAS Log Zipper is a general-purpose tool used to compress all files matching a user specified name 

filter in a specified folder. 

While the tool is running, it will periodically check for new files being created in this folder and will also 

compress those files 

HOW TO LAUNCH THIS APPLICATION 

1. From the Start menu click Programs. 
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2. Click Mitel OAS, Service Tools and OAS Log Zipper. The OAS Log Zipper window appears, see 
Figure 11 below. 

 

Figure 11: OAS Log Zipper Window 

See Table 11 Log Zipper Fields below for a description of the fields in the OAS Log Zipper window. 

Table 11 Log Zipper Fields 

OPTION DESCRIPTION 

Directory to monitor Enter the path of the folder which contains the files that are to be 
compressed. Alternatively, click the “…”  button and navigate to the 
required folder. 

Wait Select the time period after which to start compressing the files. This is 
also the interval when the tool will check for new files created in that folder 

Files zipped Display the number of files which have been compressed 

Zip files like List of file name filters used to select files to be compressed. 

 

Use the    button to remove selected filers from list. 

 

Button & Edit Field  

Enter file name filter in edit field then press button to add filter to filters list. 

Last Attempt Displays the last time the tool checked for and compressed new files. 

Run at Priority Values: “Realtime”, “High”, “Normal” or “Low” It is recommended to select 
the “Low” priority if there are other real time processes or services running 
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OPTION DESCRIPTION 

on this server. 

Only log errors Check Box When this check box is selected, the tool will only write errors it 
encounters in a log file. Otherwise the log file will also contain a list of 
successful operations. 

Output messages Contains a list of operation results (compressed files and encountered 
errors). If the list grows to over 60 entries, the list will be truncated by 
removing older entries. The removed entries will be copied to the log file 
(depending on the Check box selection) 

Zip Now! Starts compressing files immediately, and will not wait for the specified 
Wait interval. 

Save Stores the current tool setting (filter, folder, Wait time, etc) so that when 
the tool is restarted again, it will remember the saved settings. 

Also copies the entries in Output messages field to the log file and clear 
the list. 

Close Exits the application and stops compressing files after the operation in 
progress is completed. 
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OAS LOG UNZIPPER 

The OAS Log Unzipper is a general-purpose tool used to unzip all zip files in a specified folder. 

HOW TO LAUNCH THIS APPLICATION 

1. From the Start menu click Programs. 

2. Click Mitel OAS, Service Tools and OAS Log Unzipper. The OAS Log Unzipper window appears, see 
Figure 12 below. 

 

Figure 12:OAS Log Unzipper Window 

See Table 12 Log Unzipper Fields below for a description of the fields in OAS Log Unzipper window. 

Table 12 Log Unzipper Fields 

OPTION DESCRIPTION 

Select Directory with zip 
files: 

Enter the path of the folder which contains the files that are to be unzipped. 
Alternatively, click the 

 button and navigate to the required folder. 

Check files to unzip Select the files to be unzipped, or alternatively press the Select All or Clear All 
buttons to select all files or to clear all check marks. 

Select All and Clear All Marks all files that are to be unzipped, or to clear the check mark on all files. 

Now unzipping Displays the file being presently unzipped. 
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OPTION DESCRIPTION 

Progress bar Displays the percentage completion for the unzipping operation. 

Cancel Cancels the operation in progress. 

Unzip Starts the unzipping operation. 

Close Exits the application. 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 


