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1 INTRODUCTION 
Historical reports are used to obtain information about past call center activity. The powerful, yet easy to use, Mitel 
MiVoice Connect (formerly known as Connect ONSITE) Contact Center Historical Reports application provides 
activity summaries and statistical data that can help you analyze system behavior and aid in the assessment of 
resources required to meet target service levels. 

Historical reports are generated from predefined or blank templates that can be configured to include specific data 
fields and entities. Templates can also be customized for a unique look. Some templates can be generated in either 
a tabular or graphical format. 

Additional powerful tools, such as sorting and filtering, are provided to support a comprehensive and flexible 
environment for generating sophisticated reports that do not require you to know about database tables, SQL 
queries, or programming languages. 
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2 CREATING REPORTS USING PREDEFINED TEMPLATES 
Templates are used to create reports. By default, predefined templates contain commonly used data fields. 
Predefined templates can also be customized to generate other information or to have a unique look. 
 
The process of creating a report using a predefined template is: 

1. Click File > Open. 
2. Filter the list of available templates by viewing only Public and/or Private templates. 
3. Choose the predefined template you want to base your report on. If you want to customize the template, 

refer to Customizing a Template. 
4. Specify the template parameters: 

a. Define the report's entities by clicking the ellipses button. In the Choose <Entity> window, add the 
entities that you want the report to be based on by moving them from the Available field to the 
Selected field, and then clicking OK. You can click Quick Search to find a specific entity. 

b. Define the template's date range by clicking on a Date field. Refer to Defining Date Ranges. 
c. Identify the template's time range by clicking on a Time field. Refer to Defining Time Ranges. 
d. If applicable, specify the template's interval by clicking on the Interval field in the Parameters 

window. 
e. Click OK in the Parameters window. The specified parameters are shown in the template. 

5. If you want to reuse the template, save it with a new name: 

a. Click File > Save As. You can also click the Save Template Definition with New Name icon on the 
toolbar. 

b. In the Save As window, enter the Template Name. 
c. Identify the template as either public or private, and then click OK. 

6. Generate the report. Refer to Generating a Report for information about generation options. 



 

 

 
 Workgroup Monitor User and Installation Guide 

3 SPECIFYING TEMPLATE PARAMETERS 
Templates are made up of parameters and data fields. You must specify a template's parameters before the report 
can be generated. 
Complete the following steps to specify a template's parameters: 

1. Define the report's entities by clicking the Ellipses button. In the Choose <Entity> window, add the entities 
that you want the report to be based on by moving them from the Available field to the Selected field, and 
then clicking OK. You can click Quick Search to find a specific entity. 

2. Define the template's date range by clicking on a Date field. Refer to Defining Date Ranges. 
3. Identify the template's time range by clicking on a Time field. Refer to Defining Time Ranges. 
4. If applicable, specify the template's interval by clicking on the Interval field in the Parameters window. 
5. Click OK. 
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4 VIEWING FIELD DESCRIPTIONS 
Before deleting a field, or adding a field you may not need, check the description the field. Field descriptions are 
available from both an open template and when adding a field from the Add New Column window. 
 
To view field descriptions in an open template, hover the cursor on the field title. A tool tip appears with information 
about the field. This information may include the related formula, if applicable. 
 
To view field descriptions from the Add New Column window, select a field in the Add New Column window. A 
description of the selected field is shown in the Description area of the window. 
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5 DEVELOPING FORMULA FIELDS 
If the default formula fields available for a template or report do not provide the information you need, you can create 
additional formula fields. These fields can then be edited and deleted. 

5.1 CREATING A FORMULA FIELD 

Complete the following steps to create a formula field: 

1. In an open template or report, click Tools > Formulas Editor. 
2. Click New. 
3. Use the Specify Formula window to define the formula: 

a. Enter the Name of the new field. 
b. Add a Description of the field. This description is displayed when you select the field in the Add 

New Field window, and it is displayed in the field's tool tip. 
c. Select the Entity for the formula. The list of available data fields is based on the selected entity. 
d. In the Formula field, define the data field's formula. A formula is a combination of predefined 

statistical data that appear in existing fields. The Specify Formula window provides options to make 
it easy for you to define a formula. Select the field data for the formula from the Column list. Use the 
mathematical operators to specify the action to be taken. 

e. Specify the Formula Type. This ensures that the correct internal operators are used to format the 
formula, so that you get the expected result. 

f. Click Verify to test that the formula is valid. 
g. Click Save to save the formula field under its current name. If you want to same the formula field 

under a different name, click Save As. To include the new formula field in a template or report, you 
must add the field. Refer to Working with Fields. 

 

5.2 EDITING A FORMULA FIELD 

To edit a formula field, click Edit in the Formula Editor window and use the Specify Formula window to edit the 
formula. 

 

5.3 DELETING A FORMULA FIELD 

To delete a formula field, select the field you want to delete in the Formula Editor window and click Delete. 
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6 CUSTOMIZING A TEMPLATE 
From an open template you can make the following customizations: 

• Modifying the Text in a Template 
• Modifying the Color and Font in a Template 
• Modifying Header Rows in a Template 
• Developing Formula Fields 
• Working with Fields 

o Add and delete fields 
o Rearranging fields 
o Changing field width 
o Filtering the fields displayed in the template. 
o Sorting fields. 

• Displaying Data in Tabular or Graphic Form 
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7 MODIFYING HEADER ROWS IN A TEMPLATE 
Complete the following steps to identify the number of rows for titles in a template: 

1. In an open template, right-click a data field title and choose Number Header Row. 
2. In the Number of Rows window, select the number of rows the data field titles are to be displayed across, 

and then click OK. 
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8 MODIFYING THE TEXT IN A TEMPLATE 
Complete the following steps to modify text in a template: 

1. In an open template, right-click the text you want to change and click Text. 
2. In the Text Modification window, highlight the text you want to change, and then type the new text. 
3. Click OK. 
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9 MODIFYING THE COLOR AND FONT IN A TEMPLATE 
 

Refer to the following sections for information about changing the color and font in a template. 

 

9.1 CHANGE TEXT COLOR 

Complete the following steps to change the color of the text in a template: 

1. In an open template, right-click the text you want to change and choose Color. 
2. In the Color Modification window, use the sliders to select the amount of red, green, and blue you want in 

your color. The Color Modification window uses the RGB color model, and the RGB value for each color is 
displayed in the associated color box. The X shows the actual color. 

3. Click OK. 

9.2 CHANGE TEMPLATE FONT 

Complete the following steps to change the font in a template: 

1. In an open template, right-click the text you want to change and choose Font. 
2. In the Font Modification window, specify the font size and style, and then click OK. 
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10  DISPLAYING DATA IN TABULAR OR GRAPHIC FORM 
Some templates can display data in either a tabular or graphic form. If you want the data to be shown as a graph, the 
template cannot include more than six data fields. 

To specify a tabular or graphic display, in an open template, select the type of display from the Report Type area. 
When generated, the report is displayed in the type specified. 
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11  SAVING A TEMPLATE 
If you have customized a template or specified the parameters and want to use the template again, you can save it 
under a new name. Templates saved in this manner are then considered to be predefined templates. You can 
access them from by clicking File > Open. 
 
Once you have created a new template, you can save any additional changes you make by choosing Save from the 
File menu, or clicking on the Save Template icon on the toolbar. 
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12  EXPORTING REPORT DATA 
Report data can be exported to various supported file formats. There are three ways to export report data: from the 
Open window, manually, or by scheduling the report to be automatically generated and exported at a later time. 
 

 Note! If you export data that contains time to a *.csv file and open the *.csv file in Microsoft Excel, the time 
data may display hours, minutes, and seconds where the seconds data is appended by Excel even though it was not 
exported. If necessary, you can modify the appearance of the data in Excel to show only the hours and minutes data 
that was exported. 

12.1 EXPORTING REPORT DATA FROM THE OPEN WINDOW 

Exporting report data from the Open window allows you to export a report without having to open the template. This 
method is useful when you have a template in which you have already specified the parameters, and if required, 
customized it with the data fields and look that you want. 
 
Complete the following steps to export report data from the Open window: 

1. From the Contact Center Reports File menu, click Open. You can also click the Open Existing Template 
icon on the toolbar. 

2. In the Open window, select the appropriate template and click Export. The report is automatically generated 
and then the data is exported to the file format specified. 

 

12.2 MANUALLY EXPORTING REPORT DATA 

Manually export report data if you are interested in seeing and using the data immediately. 
Complete the following steps to manually export a report: 

1. In an open report, click File > Export or click the Export Report Content icon. 
2. In the resulting window, specify the filename, file type, and location for the export file, and then click Save. 
3. If you want to change the filename, file type, or location for the export file, click Browse to specify the new 

information. 
4. Select the appropriate append option: 

• Append Report Parameters 
• Append Total Rows 
• Append Subtotals 

5. Click Export Data. 

12.3 AUTOMATICALLY EXPORTING REPORT DATA 

Automatically exporting report data is useful when you want to generate and export a report periodically. Refer to 
Automatically Generating a Report for details. 
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13  SCHEDULING A REPORT 
Scheduling a report is useful when you want to generate and print, export, or email a report periodically. 
 
You must specify the template's parameters before you can automatically email a report. If you have scheduled a 
generated report to be automatically emailed, and the report is not sent, contact your administrator. The 
administrator must create a printer account with local administrative privileges on the Contact Center server to 
ensure that scheduled reports are emailed successfully. 
 
You can schedule up to 30 reports per specified 15 minute interval. If more reports are scheduled, the 31st report 
and any additional reports are generated in the following interval. 
 
Once you have scheduled a report to be automatically generated, you can manage the scheduled report. Refer to 
Managing Scheduled Reports. 
 
Complete the following steps to schedule a report: 

1. In an open template, click Report > Schedule, or click on the Define an Automatic Report icon. The 
Automatic Reports window opens. 

2. In the Schedule tab, specify the Schedule Name. 
3. To keep the new schedule up-to-date with any changes made to the template on which it is based, select the 

Synchronize with the source template (parameters, design) check box. 
4. Use the options in the Date and Time areas to schedule when the report is to be generated. 

The following list includes the Date options: 

• Clear — Click to clear the previously selected Date option. 
• Now Days — Generate the report today, and every number of specified days. 
• Now Months — Generate the report today, and every number of specified months. 
• Specific — Generate the report on this specific day only. 

The following list includes the Time options: 

• Every Hour — Generate the report every number of specified hours. 
• Specific — Generate the report at this specific hour only. 

5. If you want to generate the report to a printer, select Printer in the Destination tab, and then select the 
appropriate printer options. 

6. If you want to generate the report to a file, select File in the Destination tab, and then select the appropriate 
file options. 

7. Click OK. 
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14  MANAGING SCHEDULED REPORTS 
To manage scheduled reports, click File > Schedule List, and then click the appropriate button to edit or delete the 
schedule. To view information about a schedule, select the schedule and click Log. 
 

 Note! Deleting a schedule does not remove the template the schedule is based on. 
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15  GENERATING A REPORT 
There are three ways to generate a report: 

• Click File > Open. 
• Generating a Report from a Template 
• Automatically Generating a Report 
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16  AUTOMATICALLY EMAILING A REPORT 
As part of the process of automatic Automatically Generating a Report, you can indicate that the destination of the 
file is an email address. 

You must specify the template's parameters before you can automatically email a report. 

Complete the following steps to automatically email a report: 

1. In an open template, click Report > Schedule, or click the Define an Automatic Report icon. The 
Automatic Reports window opens. 

2. In the Schedule tab, specify the schedule name and options. The schedule name appears in File > 
Schedule List. 

3. In the Destination tab, check File. 
4. In the Email area, select the appropriate options: 

• Email Report — Select to send the report as an email attachment. 
• Delete File After Sending — If selected, after the email is sent, the report file is automatically deleted 

from your machine. 
• To — The address(es) the report is to be sent to. 
• From — The address the report will be sent from. 
• Subject — The subject of the email. 
• Append Date/Time — Appends the date and time of the email to the subject line. 
• Format — If the Append Date/Time option is selected, you can specify the date and time format you 

want to use. 
• Append Report Name — Appends the report name to the email subject line. 
• Resulting Subject Text — Displays the subject line of the email based on the specified options. 

5. Click OK. 
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17  WORKING WITH REPORTS 
Once a report has been generated, you can perform the following functions on the report: 

• Working with Fields 
o Filtered 
o Sorted 

• Developing Formula Fields 
• Magnifying a Report 
• Printing a Report 
• Automatically Emailing a Report 
• Exporting Report Data 
• Scheduling a Report 

 

 



 

 

 
 Workgroup Monitor User and Installation Guide 

18  GENERATING A REPORT FROM A TEMPLATE 
To generate a report from an open template, click Report > Generate or click the Generate Report from Template 
icon. The report is generated and opens in a new window. 
 
If you generated a graphical report, you can choose how the graphical data is displayed. 
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19  AUTOMATICALLY GENERATING A REPORT 
Complete the following steps to automatically generate a report: 

1. In an open template, click Report > Schedule or click the Define an Automatic Report icon. 
2. Use the options in the Schedule tab in the Automatic Reports window to identify when the report should be 

generated. 
3. To generate the report to a printer, click the Destination tab, select Printer, and select the appropriate 

printer options. The report is sent to your default printer. To select a different printer from the list defined in 
the Contact Center server, click Browse. 

Note: Make sure the printer does not require that you specify a filename before printing. Devices that require 
you to specify a filename before printing will cause the Contact Center Scheduler to stall because user input is 
required. 

4. To generate the report to a file, click the Destination tab, select File, and then select the appropriate File 
options. 

5. Click OK. 
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20  REPORT MAGNIFYING A REPORT 
Complete the following steps to magnify a report: 

1. In an open report, click Tool > Zoom. 
2. In the Zoom window, select the level of magnification you want, and click OK. The report is refreshed at the 

level of magnification selected. 
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21  PRINTING A REPORT 
There are three ways to print a report from a template: from the Open window, manually from a template, or by 
scheduling the report to be automatically generated and printed later. 
 
Before printing a report, identify your printer by clicking File > Printer Setup. 

21.1 PRINTING A REPORT FROM THE OPEN WINDOW 

Printing a report from the Open window allows you to print a report without having to open the template. This method 
is useful when you have a template in which you have already specified the parameters, and if required, customized 
it with the data fields and look that you want. 
 
Complete the following steps to print a report from the Open window: 

1. Click File > Open. You can also click the Open Existing Template icon on the toolbar. The Open window 
appears. 

2. Click Print. The report is automatically generated and then sent to the default printer. 

 

21.2 MANUALLY PRINTING A REPORT FROM A TEMPLATE 

Manually print a report from at template if you are interested in seeing and using the data immediately. To manually 
print a report from an open template, click File > Print, or click on the Print Report icon. 

21.3 AUTOMATICALLY PRINTING A REPORT 

Automatically printing a report is useful when you want to generate and print a report periodically. Refer to 
Automatically Generating a Report for information. 
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22  DEFINING DATE RANGES 
Complete the following steps to define a date range: 

1. In an open template, right-click in the parameters area and click Parameters. You can also click the 
Report Parameters icon. 

2. Click a Date field in the Parameters window. 
3. In the Date window, specify the From and To dates using the following options: 

• Now Minus Days — Period of past days relative to the current date. 
• Now Minus Months — Period of past months relative to the current date. 
• Specific — A specific start and/or end date. 
• Advanced — If you have defined a Specific date range, and want the template to be based on 

dates within the date range, click this button. Use the Date Ranges window to choose dates 
within the range for the template. 

4. Click OK. 
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23  WORKING WITH FIELDS 
Predefined templates contain commonly used data fields. However, you may want to change the data fields 
used in a predefined template by adding and deleting fields. If you are using a blank template, you must 
add the data fields you want to use. 
 

 Note! You can select up to 1,500 DNIS entities per report. However, note that reports with more 
than 20 DNIS entities will take additional time to generate. 
 
If you generate a historical report on a large number of agents, the report may show the entire list of agents 
in the Agent Name field, but no data is displayed. In this instance, contact your system administrator. The 
administrator must add the value reduce_header_size=1 to the [Admin Configuration] section of the 
wecc.ini file on your PC. 
 
Before adding or deleting a field, view the description of the fields. 

 

23.1 ADD A FIELD 

1. In an open template, right-click in the data field title area and click Add Column. 
2. Select the field you want to add, and then click Add Column. 

You can use Quick Search to find a specific field. 

 

23.2 DELETE A FIELD 

To delete a data field in an open template, right-click the data field title you want to remove from the template and 
click Delete Column. 

23.3 REARRANGE FIELDS 

In an open template, select the title of the field you want to move, and then drag the field to a new position. 

 

23.4 CHANGE FIELD WIDTH 

In an open template, select the title of the field you want to narrow or widen. When the cross-arrow cursor appears, 
drag the field line to the required width. 

 

23.5 FILTER FIELDS 

Complete the following steps to filter fields in a template: 

1. Click Tools > Filter > Change. 
2. In Column, choose the data field for the filter criteria. 
3. Use the appropriate fields to select the operator and value to complete the condition. If more conditions are 

required, add an additional condition line to the filter by clicking Add. In this case, a logical operator must be 
chosen from the first condition's Logical drop-down menu. 
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To delete one of the conditions, click the condition and click Delete. 

4. Click OK. 

To remove a filter from a template or report, click Tools > Filter > Clear. 

 

23.6 SORT FIELDS 

Complete the following steps to sort fields in a template: 

1. Click Tools > Sort > Change. 
2. Specify the fields to be part of the sort criteria by dragging and dropping the appropriate fields from and to 

the Columns Available for Sorting and Sort Columns lists. 
3. If you want the field order to be ascending, select the Ascending check box associated with the field. 
4. Click OK. 

To remove a sort criteria from a template or report, click Tools > Sort > Clear. 
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24  DEFINING TIME RANGES 
Complete the following steps to define a time range: 

1. In an open template, right-click in the parameters area and click Parameters. You can also click the Report 
Parameters icon. 

2. Click on a Time field in the Parameters window. 
3. In the Time window, specify the From and To time using the following options: 

• Now Minus - Period of past time relative to the current time. 
• Specific - A specific start and/or end time. 
• Advanced - If you have defined a Specific time range, and want the template to be based on a time 

within the time range, click this button. Use the Time Ranges window to choose a time within the range 
for the template. 

4. Click OK. 
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