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Introduction

About this Manual
1  Introduction

1.1  About this Manual

This manual is designed for the AC-Win system administrator. It describes how 
to configure AC-Win IP. The separate Operating Instructions describe how to 
operate AC-Win IP.

1.1.1  Explanation of symbols

NOTE:  This symbol is used for tips and comments.

1. Texts which follow this symbol describe the steps you have to follow.

• Texts which follow this symbol indicate listed points.

Keyboard keys, for example, <Enter> are displayed in bold and enclosed in 
brackets. 

Buttons in screen windows, for example, Delete are displayed in bold.
A31003-G4030-M100-2-76A9, 06/2020
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System requirements
1.2  System requirements

1.2.1  Hardware 

Windows operating systems, suitable PC, with:

– Processor: Pentium 4 or equivalent >=1.7 GHz,

– Memory: >= 2 GByte RAM,

– Hard disk: 256 MByte free hard disk space,

– CD-ROM or DVD drive;

– Monitor: CRT or LCD monitor, >= 19",

– Sound card with multimedia keyboard or PC speakers.

USB handset or headset certified for AC-Win IP. 
(see https://netinfo.unify.de/es/products/product_optipoint_handset_v10/
sales_marketing_support)

NOTE:  System resources must be extended if AC-Win is used parallel with other 
software applications.

1.2.2  Software

Please see the Release Notes for the current supported Windows versions.

1.2.3  Communication system

AC-Win 2Q SL V3 and AC-Win MQ SL V3 are supported starting with 
OpenScape 4000 V8R0 communication platform and ONLY with:

• SoftGate virtual gateways vHG3500 (Q2330-X)

• STMIX Gateway Board (Q2343-X)
 A31003-G4030-M100-2-76A9, 06/2020
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AC-Win configuration options
2  AC-Win configuration options

AC-Win can be configured in a number of ways. This allows you to set the 
program for the individual application and user.

Workspaces

Workspaces consist of one or more objects or dialog boxes. The user can define 
specific settings for workspaces (e.g. the language) independent of the given 
application settings. This allows workspaces to be individually defined for each 
user. You can also select one of several default workspaces.

Objects (dialog boxes)

Objects (dialog boxes) are the “working windows” of AC-Win. Various settings 
can be defined using different objects (e.g. layout of buttons). Objects can be 
saved separately with the given workspace or as templates.

The illustration below depicts a typical AC-Win workspace. In this example, the 
Call Control, Buttons and Name Keys objects are integrated in one workspace.

Application settings

Application settings are valid for the entire AC-Win program. Important working 
directories for the entire program can be defined here.
A31003-G4030-M100-2-76A9, 06/2020
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A typical AC-Win workspace consists of the following objects:

• Call Control

• Name Keys and

• Buttons 

Typical AC-Win objects
 A31003-G4030-M100-2-76A9, 06/2020
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AC-Win configuration options

Setting up workspaces
2.1  Setting up workspaces 

AC-Win allows you to set up and save individual workspaces. Specific objects can 
be displayed in the workspaces according to the given requirements. The 
individual
objects can be adapted to your specific requirements (e.g. you can label the 
Name Keys as you wish). You can save changed objects under a new name and 
integrate them into workspaces (see section “AC-Win objects”). This allows AC-
Win to be configured for use in specific cases. It is also possible to configure a 
workspace for each user.

AC-Win provides two different objects/workspaces:

• Object/workspace templates

• Object/workspace documents

When working with AC-Win, use object/workspace documents. An object/
workspace template is used to create documents. You can then format these 
documents as required and make them available as templates or documents. 

To ensure that users do not inadvertently overwrite workspace and object 
templates, templates can only be saved by administrators with the "Admin" ID. 
You can also assign a password to a workspace. Objects of this kind can only be 
opened by entering this password.
A31003-G4030-M100-2-76A9, 06/2020
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Setting up workspaces
2.1.1  New Workspace

1. Start AC-Win by double clicking the program icon. 

A predefined workspace is automatically opened the first time the program is 
started. You can supplement and change this workspace and then save it 
under a new name. You can also set up a new workspace by proceeding as 
follows:

2. Select New Object from the File menu.

3. Select the required object and click on OK.

The selected object is added to the workspace.

4. To add additional objects, select New Object from the File menu.
Select Open Object from the File menu to add objects you have defined and 
saved yourself (see section “AC-Win objects”).

5. To remove objects which have been added to the workspace, select Close 
Object from the File menu.

6. Position the individual objects where you wish within the workspace.
 A31003-G4030-M100-2-76A9, 06/2020
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AC-Win configuration options

Setting up workspaces
2.1.2  Switching workspaces

You want to change the current workspace in order to select another display. You 
can also select one of several default workspaces.

• Use "Default Workspace Wide" for screen resolutions of up to 1024 x 768 
pixel: 

– under File, Open Workspace, select the file DefaultWide.cnw  or 

– under File, New Workspace, select the file DefaultWide.acw.

• Select "Default Workspace" for higher screen resolution:

– under File, Open Workspace, select the file Default.cnw or

– under File, New Workspace, select the file Default.acw.

Proceed as follows to change the workspace:

1. Select New Workspace from the File menu.

2. Select the required workspace and click on OK.
The selected workspace is added.

3. Select Open Workspace from the File menu to add workspaces you have 
defined and saved yourself.

4. Select Close Workspace from the File menu to close the current workspace.
A31003-G4030-M100-2-76A9, 06/2020
AC-Win 2Q IP V3, Administrator Manual 11

         



AC-Win configuration options

AC_Win2Q_ch2.fm

Saving the current workspace
2.2  Saving the current workspace

When you have modified a workspace to suit your specific requirements, you can 
save it. 

1. Select Save Workspace As from the File menu. 

2. Select whether you want to save the workspace as a 

– document (*.acw) or 

– template (*.cnw).

Saving a workspace as a template is recommended if you want to use the 
current settings for other workspaces. The AC-Win user class “Administrator” 
is required to save templates.

3. Enter the name you have chosen for your workspace and its path. 

4. Click on OK. The current workspace is saved.

2.2.1  Loading a workspace

1. Select Open Workspace from the File menu. 

2. Select the workspace you wish to open from the list. 

3. Click on OK. The current workspace is loaded.

NOTE:  It is possible load a specific workspace automatically at startup. For infor-
mation on this operation, see section “Application Settings“.
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2.3  Workspace settings

1. Select Workspace Settings from the Options menu.

2. Enter the required settings.

– Workspace objects: The objects included in the current workspace are 
listed in this window.

– Save Workspace automatically: Select this check box if you wish to 
save the workspace automatically when you close AC-Win or when you 
close the workspace.

– Current language: This window shows the current used language for 
that program. You may set the language with the AC-Win IP configuration 
program.

– User Name: This window contains the owner of the workspace.

– Use predefined title: Mark this check box to enter a title for the 
workspace in the Title field. The title is entered automatically if this check 
box is not marked. 

– Description: In this field you can enter a description, e.g. special settings 
for this workspace.

3. Close the window by clicking on OK. All settings are saved. To close the 
window without saving the changes you have made, click on
Cancel.
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2.3.1  Setting or changing a workspace password 

1. Click on the Password button in the Workspace Settings window to define a 
password for the current workspace or to change the existing password.

Setting a password:

• Enter the desired password in the New password field. The Old password 
field remains empty.

• Enter the new password again in the Retype password field.

• Complete your entries by clicking on OK.

The new valid password must now be entered when opening the workspace.

Changing a password:

• Enter the previously valid password in the Old password field.

• Enter the desired password in the New password field. 

• Enter the new password again in the Retype password field.

• Complete your entries by clicking on OK.

The valid password must now be entered when opening the workspace.

2. To close the Workspace Settings window, click on OK. All settings are saved. 
To close the window without saving the changes you have made, click on 
Cancel.
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2.4  Application settings

The “Application Settings” window allows you to define global settings for AC-
Win. Certain settings, such as the language, can also be defined separately for 
individual workspaces (see section “Setting Up Workspaces”).

1. Start AC-Win by double clicking on the program icon. 

A predefined workspace is automatically opened the first time you start up the 
program.

2. Select Application Settings from the Options menu.

3. Enter the required settings:

• Workspaces: Use this field to specify the directory in which you wish to 
save workspaces and objects. Click on  if you wish to change the 
predefined directory.

• Templates: Use this field to specify the directory in which you wish to 
save your templates for objects (see section “Saving objects as 
templates”). Click on  if you wish to change the predefined directory.

• Languages: This window shows the current used language for that 
program. You may set the language with the AC-Win IP configuration 
program.
A31003-G4030-M100-2-76A9, 06/2020
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General settings:

• Open Workspace Automatically: Use this option to set the workspace 
you wish to be opened when AC-Win is started (see section “Setting up 
workspaces”).

• Use Wallpaper: If this check box is marked (selected), you can use the 
 button to set the “wallpaper” (background) that is loaded when the 

program is started. The wallpaper must be available in BMP format.

• Start Maximized: If this check box is marked, AC-Win will be displayed 
in maximum size, filling out the entire screen instead of just one window.

• Use Greeter: If this check box is marked, you can use the  button to 
select the greeter to be displayed when the program is started. The 
greeter must be available in BMP format.

4. Click on OK to complete your entries. All settings are saved. To close the 
window without saving the changes you have made, click on Cancel.
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2.4.1  Adding OLE objects to the workspace

This function allows you to add objects from other Windows applications to the 
workspace, e.g. AC-Voice. Please note that only applications certified with AC-
Win can be integrated in an AC-Win workspace.

NOTE:  Only administrators or superusers can open the dialog for integrating 
applications. 

To integrate objects from other Windows applications in the AC-Win workspace:

1. Select Application Settings from the Options menu.

2. Click on the Objects button.

3. Enter the name of the application which you wish to integrate in the “New 
Object Name” field. The name must be identical to the registered Windows 
name of the application.

4. Click on Add. The object will be added to the list of “Currently Supported 
Objects” and can now be added to your workspace.

5. Close the”Supported Object“ window by clicking on OK. To close the window 
without saving the changes you have made, click on Cancel.
A31003-G4030-M100-2-76A9, 06/2020
AC-Win 2Q IP V3, Administrator Manual 17

         



AC-Win configuration options

AC_Win2Q_ch2.fm

Application settings
2.4.2  User management

AC-Win allows you to use a password to protect the program from unauthorized 
access. AC-Win distinguishes between the following different user classes:

• User (uses the functions available on the user interface)

• Super user (uses some simple configuration functions in addition to the user 
functions)

• Administrator (uses all configuration functions).

3 3 3

3 3

3

3 3

3 3

3

3

3 3

3

3 3

3 3

The restrictions of the individual user classes have been kept to a minimum. 

The following table indicates the access rights for U (user), SU (super user) and 
A (administrator):

* The "Admin" password is required to delete administrators.

Activity U SU A 

Change own password

Change password of other user 

Change password of other super user 

Add, change, delete user

Add super user 

Change, delete super user

Add, change* administrator

Make application settings 

Configure application

Change, save document templates

Change traffic restrictions 
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2.4.3  Adding a user

To set up or change users, proceed as follows:

1. Select Application Settings from the Options menu.

2. Click on the Users button.

Create new user:

1. Click on the New button.

2. Enter a name for the new user. 

3. Complete your entries by clicking on OK.

Setting a password:

1. From the Users selection list, select the user for whom you want to 
specify a password.

2. Specify the user class.
You have the choice of user, superuser or administrator. 

3. Enter the desired password in the New password field. 
The password is case-sensitive. 
The Password field will remain empty.

4. Enter the new password again in the Retype password field.

5. Complete your entries by clicking on OK.
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Entering the private number for AC-Win

1. Enter the private number for AC-Win in the Phone number field. This number 
is used with the AMO ACSU.

2. To close the User management window, click on OK. All settings are saved. 
To close the window without saving the changes you have made, click on 
Cancel.

2Changing a user password

NOTE:  A new user can only be added by an administrator or super user.

2.4.4  Changing User Password

As an administrator or super user, you can use this function to change user 
passwords.

1. Select Application Settings from the Options menu.

2. Click on the Users button.

3. Select the user whose password you want to change in the Users field.

4. Overwrite the entry in the New password field with the desired password.

5. Enter the new password again in the Retype password field.

6. Complete your entries by clicking on OK.
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3  AC-Win Configuration Settings

After the installation, or with
Start->Programs->AC-Win [2Q|MQ] IP->AC-Win IP Configuration
the configuration interface is displayed. The first window displayed is the "Main 
connections" window. 

Every window includes the following buttons:

– Save settings: The changes are adopted and written to the registry.

– Undo changes: The last changes made are rolled back. 

– Restore defaults: The values from the registry are displayed and the 
changes discarded.

3.1  The "OpenScape provider" Tables

3.1.1  Settings for the Main Connection

– Registration address: the IP address of the OpenScape 4000 IP 
gateway (STMI2 module).

– Admin number: AC-Win number which is used with the Admin user ID.

– Admin password/Retype admin password: If a password is assigned 
when setting up the AC-Win number in the OpenScape 4000, enter it 
here. Otherwise, an arbbitrary password can be assigned for use when 
logging on to AC-Win.
Note: The password is case-sensitive. 
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– Emergency call number: has no use at present.

– Security mode, Gatekeeper ID, Time Window(Sec.): Enter the same 
values in these fields that were set in the OpenScape 4000.

– Signalling and Payload encryption (SPE):

Type of connection: select TCP, if no encryption is required or TLS for 
SPE-encryption

Cornet TLS Port: this port is used for the signalling. 

TLS H.225 Port: this port is used for the voice connection to the common 
gateway. The values entered here must correspond with the values at the 
common gateway.

– Mixer, Microphone, Speaker: Specify the audio I/O device (headset) to 
be used with AC-Win here. 
Note: Before these values are specified, the headset must be connected. 
Only then can the corresponding I/O devices be selected. If these values 
are not set, AC-Win will not operate. 
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3.1.2  Port Restrictions

This dialog is for specifying the port numbers used by AC-Win and the IP 
gateway.

– Gatekeeper CornetIP port: By default, the OpenScape 4000 IP gateway 
uses port number 4060 for communication with the IP terminals. If a 
different port number has been configured in the IP gateway, enter it here.

– Use Cornet port range/ PC-Cornet IP port area: A specific Cornet IP 
port range can be used for the AC-Win PC. The preset port numbers are 
7000 to 7010. If you want to use a different range, enter it here. 

– RTP Port range: Change the port number range for the voice connection 
here.

– H.225 Signaling: For VoIP signaling, port number 11723 is used by 
default. If conflicts with other applications (e.g. NetMeeting) arise, you 
can change this port number here. 
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3.1.3  Licensing

This dialog is for configuring the access to the CLA (Common Licensing Agent).

– Server IP Address: Enter the IP address of the computer on which the 
CLA (Common License Agent) application is installed. 

– HFA server port: the port number (default 61740) over which access to 
the CLA application occurs.

– Timeout (ms): maximum time per connection attempt to the CLA 
application.

– Retry attempts: maximum number of connection attempts to the CLA 
application.

– Password: If a password has been configured for access to the CLA 
application, enter it here. 
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3.1.4  Bandwidth Reduction

This dialog is for making settings to reduce the bandwidth needed by the IP 
connection.

7 WARNING

DMC is NOT supported on AC-Win SL V3!

– Teleworking: deactivates the cyclical monitoring message between the 
IP gateway and AC-Win, resulting in reduced data volume. 

– Codec sequence: Specify the preferred compression algorithm (G.711, 
G.723, G.729) or an alternate.

– Codec packet lengths: For each codec, you can specify the voice 
packet length in milliseconds here.

– Jitter buffer (ms): To minimize delay losses, enter the jitter buffer size in 
milliseconds here. The better the network connection is, the lower the 
buffer size can be. 
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3.1.5  Failover / Small Side Redundancy (SSR)

With the failover (small side redundancy) feature, AC-Win can switch 
automatically to an alternate connection (another OpenScape 4000 node or 
another IPDA shelf) if its main connection fails.

– Registration address: Enter here the IP address of the alternate 
gateway to be used if the main connection fails. 

– Registration number: the number to be used by AC-Win when logging 
on to an alternate IP gateway. 

– Registration password: If a password is assigned when setting up the 
AC-Win number in the alternate system, enter it here.
Note: The password is case-sensitive. 

– Emergency call number: has no use at present.

– Security mode, Gatekeeper ID, Time Window: Enter the same values 
in these fields that were set in the alternate IP gateway.

– Signalling and Payload encryption (SPE):

Type of connection: select TCP, if no encryption is required or TLS for 
SPE-encryption

Cornet TLS Port: this port is used for the signalling. 

TLS H.225 Port: this port is used for the voice connection to the common 
gateway. The values entered here must correspond with the values at the 
common gateway.

– Failover: Enter settings here for switching back to the main connection. 
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– Minimum of successful connection/Waiting time between 
connection (s): This value specifies the minimum number of 
connection attempts to the main system before switching back to the 
main connection. You can also specify the interval between these 
connection attempts. 

– No automated switchback: This setting determines whether or not 
automatic switchback is possible. 

3.1.6  Quality of Service

This dialog is for making Quality of Service (QoS) settings for the IP connection. 

– Mark packets: This setting specifies whether the packets should be 
marked to improve quality of service in Layer 2 and/or Layer 3.

– Call signaling/Voice payload: Specify the values for marking the packets 
here.
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3.2  The "General" Tables

3.2.1  DLS/DLC Configuration

Set parameters for Deployment Service (DLS or central configuration) here.

– DLS deployment enabled: specifies whether or not the central 
configuration is to be used. 

– Server (DLS): Specify here whether all DLS services are to be used, or 
only the encryption of voice packets. 

– Client (DLC)

– Address: IP address or DNS name of the DLS.

– Port: port number of the DLS

– Connection

– Address: AC-Win IP address to be used for communication with the 
DLS. 

– Port: port number of the DLS connection on the AC-Win PC.

– Network card: MAC address at which the data will be stored on the 
DLS.
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3.2.2  General Settings

– Program type: shows which attendant console (2Q/MQ) is installed.

– Software version: software version of the installed AC-Win application.

– Selected language: from this list, you can select one of the AC-Win 
languages.
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3.2.3  Voice Recording

Use this dialog to make settings for digital voice recording at the attendant 
console. 

– Voice recording active: This setting activates voice recording in AC-
Win.
Note: In the OpenScape 4000, use AMO ZAND to set the parameter 
TAPALOW =YES in the ATND branch.

– Automatic tape recording: If this setting is activated, voice recording 
starts automatically (without pressing the record button) after a call is 
taken.

– Voice recording directory: This is the directory where the digital speech 
files (.wav files) are stored.
Note: We recommend that you use a local directory. With network drives, 
delays can result.
Please do not store files in the C:\Program Files directory or any 
subdirectories.

– Voice recording beeps: When this setting is active, a beep is played at 
intervals while a conversation is being recorded. 

– Beep wave file location: here you can select the *.wav file with the voice 
recording beeps.
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4  AC-Win settings

This function allows you to configure:

• the Call Control object,

• the Redial, Call Journal, Alarms and Call Charges objects,

• the accelerators,

• the colours.

4.1  Call control settings

1. Select AC-Win Settings from the Options menu.
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2. Enter the required settings:

• Warning Levels: The colour of the corresponding gauge changes if the 
number of waiting calls exceeds the number in this field.

• External Line Prefix: Enter the trunk code used in your switch system.

• Automatic tape recording: Calls are recorded automatically according 
to the settings.

• General Settings: Define the following AC-Win settings on the basis of 
your requirements:
“Focus in Buttons Object”: If you work with the object “Call Control No 
Buttons”, when this box is activated, the focus is automatically placed on 
the “Function Keys” object.
“Show Info Indicator”: This option is provided for functions which will be 
available in future versions of the program, e.g. mail box. This function is 
not supported at present.

• Feature codes: Enter your switch system codes for paging and switching 
to dual-tone multifrequency signalling here. These codes are selected by 
clicking on the corresponding button (see Chapter “Buttons”).

• Alerting tone on call queue changes: You can specify here how waiting 
calls are to be signalled at the attendant console.

• Focus priorities in alerting status: You can specify here the type of call 
on which the focus should be laid when incoming calls arrive 
simulataneously. Select the call type which you wish to shift. To shift the 
call type, click on the Up or Down button.

3. Save your entries by clicking on Save.

4. Complete your entries by clicking on OK.
 A31003-G4030-M100-2-76A9, 06/2020
32 AC-Win 2Q IP V3, Administrator Manual

        



AC_Win2Q_ch4.fm

AC-Win settings

Object settings
4.2  Object settings

1. Select AC-Win Settings from the Options menu.

2. Click on Objects.

3. Enter the required settings:

• Redial: Define here whether the dialled/displayed number should be 
added to the redial list automatically or on the request of the user.

NOTE:  If you selected Addition according to user request, you must add the 
Add to Redial key in the Buttons object! Otherwise, the user cannot save any 
number for redial.

• Call Journal: Define here which calls are to be recorded in the Call 
Journal. Specify a limit for the maximum number of entries in the list/file. 
Click on if you wish to change the predefined directory.

• Alarm: Click on “Save to File” if you wish to save the alarm reports. Enter 
the maximum size and click on if you wish to change the predefined 
directory.
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• Call Charges: Click on “Save to File” if you wish to save the call charges. 
Enter the maximum size and click on if you wish to change the 
predefined directory.

• Notebook Object: Click on “Save to File“if you wish to save the notebook 
entries. Click on if you wish to change the predefined directory.

• Printing: Specify the font and number of lines per page for printing.

4. Save your entries by clicking on Save.

5. Complete your entries by clicking on OK.
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4.3  Accelerator settings

1. Select AC-Win Settings in the Options menu.

2. Click on the Accelerators tab.

3. Select the function, to which you wish to assign an accelerator from the 
“Accelerator” column.

4. Now press the key(s), to which you wish to assign this function.

5. Repeat steps 3 and 4 to assign other accelerators.

Exporting and importing accelerator settings:
If you wish to use the same accelerators at each attendant console, click in 
the Export or Import button.

6. Save your entries by clicking on Save.

7. Complete your entries by clicking on OK.
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4.4  Colour settings

1. Select AC-Win Settings from the Options menu.

2. Click on the Colors tab.

3. Select the colours for the following elements:

• Call Display Fields

• First and Second Status fields

• Warning levels (gauge)

• Buttons

• Toggled Night Mode Background Color

• Enabled Line Key Buttons

Exporting and importing colour settings:
If you wish to use the same colour settings at each attendant console, click 
on the Export or Import button.

4. Save your entries by clicking on Save.

5. Complete your entries by clicking on OK.
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4.5  TAPI Dialing Function Settings

The TAPI dialing function enables AC-Win software-based connections to third-
party applications, such as

• Telephone book CD’s

• Directory service applications

• Specific Internet/Intranet pages

TAPI dialing enables third-party applications to transfer a phone number to AC-
Win and consequently the PABX by simply pressing a button.  In this way, 
operations such as call processing can be easily started from the third-party 
application and thus significantly shortened.

NOTE:  This function can only be used by a third-party application if the appli-
cation supports the standardized TAPI (Telephony Application Programming 
Interface) dialing function.

Parameter Settings:

1. Select AC-Win Settings from the Options menu .

NOTE:  The TAPI window for parameter settings is not linked to the AC-Win 
language settings. Hence it is only available in English.
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Generally, the third-party application’s phone numbers are saved in a specific 
format. For this reason, many applications currently support the ITU-T 
(International Telecommunication Union) E.164 numbering plan.

Example: 00 49 (89) 722-4711

SN = Subscriber Number

NDC = National Destination Code

CC = Country Code

IP = International Prefix

The TAPI dial setting parameters provide conformity between the phone number 
format in the third-party application and that used in the PABX.

Automatic Prefix Dialing of External Access Codes:

2. In the Outgoing Line Identifier field, enter the access code for an external 
number in such a way that the PABX recognizes it as a number that has been 
saved in a third-party application. 

3. In the Outgoing Line Number field, enter the external access code of the 
PABX.

By doing this, the access code entered in the Outgoing Line Number field will 
automatically be dialed when transferring the phone number to AC-Win.

Example: The phone number 089-4711815 is selected in a third-party 
application (e.g. a telephone book CD) and transferred to AC-Win. The 
number "0" is saved in the Outgoing Line Identifier field, i.e. AC-Win 
recognizes an external number for the PABX. The access code "9" is 
configured for an external line in the PABX. This access code must also be 
entered as an outgoing line number. AC-Win takes the number 9-089-
4711815 and sends it to the PABX.

All phone numbers saved in the third-party application that do not begin with 
"0" are interpreted by AC-Win as internal numbers. In this case, the Outgoing 
Line Number is not sent to the PABX.
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Setting up the Symbol for an International Prefix

4. In the International Prefix field, enter the international prefix access code 
(e.g. 00).

5. In the Prefix Symbol field, enter a symbol that is often used to indicate the 
international prefix, such as "+" (e.g. +49 89 722-4711 instead of 0049 89 
722-4711).

On TAPI dialing, AC-Win replaces the number sequence that is saved as the 
international prefix with the symbol saved in the Prefix Symbol field and 
transfers this to the PABX.

Filtering Your Own Country Code 

In the case of international phone numbers that are saved in the third-party 
application according to the E.164 numbering plan, one’s own local country 
code rarely needs to be transferred to the PABX.

The AC-Win TAPI dialing function automatically filters the local country code 
out of the phone number transferred from the third-party application and 
inserts a "0" before the national target code.

By default, the local country code is taken from the MS-Windows system 
settings (see System Settings -> Phone and Modem Options -> Edit -> 
Country/Region). By clearing the Use predefined local Country Code 
checkbox, you have the option to enter the local country code manually.
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5  The AC-Win objects

AC-Win provides a number of predefined dialog boxes or objects. Objects are the 
“working windows” of AC-Win. Objects can be integrated in workspaces and 
saved with them. They can be changed and saved under a new name. Objects 
can also be saved as templates.

This chapter describes the various objects provided by AC-Win and how they can 
be configured.

5.1  Overview of objects

AC-Win provides the objects listed below. For more information about the 
individual objects, refer to the section “Configuring objects“.

• Alarms

• Call Control

• Buttons

• Call Charges

• Name Keys

• Call Journal

• Numpad

• Notebook

• Redial
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5.2  Opening predefined objects

1. Select New Object from the File menu.

The “New Object” window appears.

2. Select the required object and click on OK.

You can now adapt the selected object to your individual requirements and 
save it under a new name.

5.3  Opening user-defined objects

1. Select Open Object from the File menu.

The file selection window appears.

2. Select the required object and click on OK.

You can modify the selected object and save it under the same name or a 
new name.

5.4  Saving objects

Modified objects can be saved under new names and in this way you can build 
up a library of objects which you can use when setting up workspaces. To save 
objects:

1. Select Save Object As from the File menu.

2. Enter the file type (template or document) you have chosen and click on OK. 
Administrator or super user authorisation is required for saving templates. 
Saving an object as a template is useful if you want to use the current settings 
for other objects of the same type.

The standard directory defined under “Application Settings” is “Workspaces“.

5.5  Closing objects

Previously opened objects can be removed from the current workspace by 
closing them. To close objects:

1. Select the object which you wish to close.

2. Select Close Object from the File menu.
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5.6  Object settings

Specific settings can be defined for each object in the “Object Settings” window. 
To define object settings:

1. Insert the desired object in the workspace.

2. Mark the object.

3. Select Dialog Settings from the Options menu or click with the right mouse 
button in the corresponding object window and select Dialog Settings.

4. Enter the required settings:

• Title: Enter the title displayed in the object header bar.

• Description: You can enter more information about the object here.

5. Complete your entries by clicking on OK. All settings are saved. To close the 
window without saving the changes you have made, click on Cancel.

5.7  Configuring objects

In addition to object settings which are the same for all AC-Win objects, it is 
possible to define individual properties for certain objects. All of the AC-Win 
predefined objects and their specific setting options are described below.

NOTE:  The operation of the individual objects is described in the AC-Win 
Operating Instructions.
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5.8  Call control

The “Call Control” window is the main object window in AC-Win. All important call-
processing procedures are executed from this window.

NOTE:  Information on how to configure the “Call Control Window” can be found 
in the section “Call control settings”.
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5.9  Buttons

This object window shows the assignment of the buttons in AC-Win. In addition 
to defining the object settings, you can also define the layout and assignment of 
these buttons. You can save the modified objects individually or with the entire 
workspace. An example of this window is shown below.

5.9.1  Buttons layout

To set the layout of the buttons:

1. Select the “Buttons” window.

2. Click with the right mouse button in the buttons window and select Layout.

3. Set the required button grid and size.

4. Complete your entries by clicking on OK.

The changes you have made take effect immediately. The new layout of the 
“Buttons” window appears.
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5.9.2  Buttons Order

To set the order of the buttons in the “Buttons” window:

1. Select the “Buttons” window.

2. Click with the right mouse button in the “Buttons” window and select Buttons 
Order.

3. Select a function and click on the Up and Down buttons to change the order 
of the buttons.

4. Complete your entries by clicking on OK.
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5.9.3  Button Properties

To set the button properties:

1. Select the “Buttons” window.

2. Click with the right mouse button in the “Buttons” window and select Button 
Properties.

The Button Properties window appears showing the current settings.

3. You can now enter your settings:

• Button: You can assign a different/new function to the selected button 
here. (The button can be free or already have a function assigned to it.).

• Label: Enter the button label and its position or select the predefined 
settings.

4. Complete your entries by clicking on OK.

The changes you have made take effect immediately. The new layout of the 
“Buttons” window is displayed.
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5.10  Name keys

This object shows the name keys. In addition to the object settings, you can also 
define the layout and assignment of the name keys. You can save the changed 
object individually or with the entire workspace.

5.10.1  Name key layout

To set the layout for a name key:

1. Select the “Name Keys” object. 

2. Click with the right mouse button in the “Name Keys” window and select 
Name Key Layout from the pop-up menu.

3. Select the required key grid and size.

4. Complete your entries by clicking on OK.

The entries you have made take effect immediately. The new layout of the 
“Name Key” window is displayed.
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5.10.2  Name key order

To set the order of the name keys as they appear in the “Name Keys” window:

1. Select the “Name Keys” window.

2. Click with the right mouse button in the “Name Keys” window and select 
Name Key Order.

3. Select a name key and click on the Up and Down buttons to rearrange the 
order as required.

4. Complete your entries by clicking on OK.
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5.10.3  Name key properties

To set the name key properties:

1. Select the name key whose properties you wish to set in the “Name Keys” 
window. If the name keys are not assigned, the “Name Key Layout” window 
opens immediately.

2. Click with the right mouse button in the “Name Keys” window and select 
Name Key Properties.

3. Enter the label text and telephone number to be assigned to the name key(s).

4. If you select the “Make New Call” box, a new line will be seized each time you 
click on this name key. If this box remains deactivated, it is possible to set up 
a chain of name keys, i.e. these predefined digits are added to a dialled 
number.

NOTE:  The operation of the individual objects is explained in the AC-Win 
Operating Instructions.
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5.11  Call journal

This object records the calls which have been processed using AC-Win. This 
object has no other settings.

NOTE:  The settings for this object are made under Objects in the AC-Win 
Settings window.

In accordance with the settings made under AC-Win Settings, the current calls 
are displayed when you start AC-Win (basic setting).

• Click on Load File to display call data saved in the log file. Saving call data 
may take a little time. The call data is recorded in the log file, at the latest, 
when you quit AC-Win.

• Click on Show Current to display the current call data.

5.12  Number pad

The Numpad (number pad) object is used to dial numbers using the mouse. This 
object has no other settings.
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5.13  Call charges

This object window contains information about call charges. This object has no 
other settings.

NOTE:  The settings for this object are made under Objects in the AC-Win 
Settings window.

5.14  Alarms

This object window lists alarm causes. This object has no other settings.

NOTE:  The settings for this object are made under Objects in the AC-Win 
Settings window.
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5.15  Notebook

This window can be used to note and retrieve previously noted telephone 
numbers. This object has no other settings.

NOTE:  The settings for this object are made under Objects in the AC-Win 
Settings window.

5.16  Redial

Numbers can be stored and retrieved for redial in this window. This object has no 
other settings.

NOTE:  The settings for this object are made under Objects in the AC-Win 
Settings window.
A31003-G4030-M100-2-76A9, 06/2020
AC-Win 2Q IP V3, Administrator Manual 53

         



The AC-Win objects

AC_Win2Q_ch5.fm

Redial
 A31003-G4030-M100-2-76A9, 06/2020
54 AC-Win 2Q IP V3, Administrator Manual

        



AC_Win2Q_ch6.fm

AC-Voice
6  AC-Voice

AC-Voice is a supplementary software module that is used together with AC-Win 
Call Control. AC-Voice gives a possibility to attach voice files for inincoming calls, 
and play them automatically when calls occur. The announcement can be heard 
by the calling party and by the attendant her/himself.

Different voice files can be attached for each call type. The following call types 
are supported:

• External,

• Internal,

• Personal,

• Returned busy,

• Returned free,

• Diverted,

• Redirected.

In addition, if several companies have been configured in one OpenScape 4000 
PBX, unique voice files can be added for each company.
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6.1  Getting Started

Before using AC-Voice, AC-Win must be configured so, that AC-Voice objects 
can be added to the application. Normally AC-Voice does this automatically 
during installation, but if AC-Voice is not included in the supported objects list in 
AC-Win this configuration has to be done manually. To do this, apply the following 
steps:

1. Start Enhanced Attendant Console AC-Win

2. From menu, select  Options - Application settings…

3. In the Object name field, write AC-Voice

4. Press Add button

5. Press OK button

Now you are able to add AC-Voice object to the AC-Win application. 

Do the following:

1. From menu, select File - New… 

2. From the object list, select AC-Voice Voice

3. Press OK button.
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6.2  User Interface

The Voice list shows all responses that the user has already added  to the AC-
Voice object. Right after the AC-Voice installation the list is empty, because it is 
the user her/himself who has to provide her/his individual sound files for AC-
Voice. For each response, the call type and sound file is shown. If company name 
is attached to the voice, then the row is indented, and company name is shown 
instead of call type.

• New voices can be added by pressing Add… button. 

• Voice can be removed from the document by pressing Remove… button.

• Voice can be modified by pressing Modify… button.

• The selected sound can be played using Sound Preview tools. 

• AC-Voice can be temporarily activated/deactivated. See Activating AC-Voice.
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6.3  Creating Voice Files

AC-Voice voice response files are wav files with recommended 8,000KHz, 16Bit, 
Mono format. The files are stored in a wav-directory which is created during the 
AC-Voice installation under the AC-Voice installation main directory.

The new files must be stored to the AC-Voice wav-directory because the available 
voice file list is created from this directory. 

When AC-Voice is included to the user workspace all the AC-Voice configuration 
info (e.g. what wav-files are used) is stored to that workspace. This means that 
each user can use their own wav-files for their own workspaces.

NOTE:  A microphone has to be connected to the sound card.

6.4  Adding Voice

To add a new voice to the AC-Win document, carry out the following steps:

1. Press Add… button. The following dialog box appears:

2. Select call type from Call type list

3. Write company name to the Company name field. This step is optional. Give 
the company name only if voice is going to be added for some specific 
company. There is no limit given by the AC-Voice application that restricts the 
number of company names that can be configured in AC-Voice.

4. Give sound file by writing its name to the Sound File field, or by pressing 
Browse… button.

5. Press OK button.
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6.5  Removing Voice

The voice is removed from AC-Win application by applying the following:

1. Select the voice to be removed from the voice list

2. Press Remove… button

3. AC-Voice asks for confirmation by showing the following dialog:

4. Press Yes button.

6.6  Modifying Voice

To modify an existing voice, carry out the following steps:

1. Select the voice to be modified from the voice list

2. Press Modify… button. 
The following dialog box appears:

3. Change call type, company name or sound file.

4. Press OK button.
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6.7  Sound Preview

Voice files can be played using the controls in the Sound Preview group. First 
select the voice in the voice in the voice list. In the Sound preview group, the 
selected voice file and its length in seconds is shown

To play the voice, press  button.

To pause playing the voice, press   button.

To resume playing the voice, press again button.

To stop playing the voice, press button.

6.8  Activating AC-Voice

By default, AC-Voice is activated immediately, when AC-Voice object is inserted 
to the AC-Win application. If you temporarily want to deactivate AC-Voice so that 
it will not play voices any longer, press In Use button. When pressed, AC-Voice 
is deactivated and the text in the button is changed to Not in use. To activate AC-
Voice again, press the In use button a second time.
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6.9  Mapping between call types

The following table shows the mapping between 

– Call Types as they are displayed in AC-Win when an incoming call is 
alerting and

– Call Types as they are defined in AC-Voice.

Call Type System Call Type (English) AC Voice Call Type
Initial external call on line 1 
(trunk line)

Direct Call external External

Initial internal call on line 2 
(attendant line) 

Direct Call internal Internal

Initial call on personal line Direct Call personal Personal
Recall on line 1, party free Recall external, no answer Returned free
Recall on line 2, party free Recall internal, no answer Returned free
Recall on personal line, party free Recall personal, no answer Returned free
Recall on line 1, party busyt Recall external, busy Returned busy
Recall on line 2, party busy Recall internal, busy Returned busy
Recall on personal line, party busy Recall personal, busy Returned busy
Intercept (external) Diverted Call external Diverted
Intercept (internal Diverted Call internal Diverted
Consultation request line 1 Consultation Call external Internal (!)
Consultation request line 2 Consultation Call internal Internal
Consultation request personal line Consultation Call personal Personal
On-hook, line 1 On Hook Call external Internal (!)
On-hook, line 2 On Hook Call internal Internal
On-hook, personal line On Hook Call personal Personal
Serial call Serial call External
Emergency call (only internal) Hotline Call (only internal) Internal
Redirected call to attendant Redirected Call to Attendant Redirected

In case no sound track is provided in AC-Voice for a given Call Type, no 
announcement is applied for these calls. Some System Call Types are mapped 
to the same AC Voice Call Types (see table above). In that case you will hear the 
same sound track for different System Call Types.
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