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Introduction

About this manual
1  Introduction

1.1   About this manual

This manual is designed for the system administrator. It describes how to 
configure AC-Win MQ SL. Using AC-Win MQ SL is described in the operating 
instructions.

1.2  Explanation of symbols

NOTE:  This symbol is used for warnings, tips and comments.

1. Texts which follow this symbol describe the steps you have to follow.

• Texts which follow this symbol indicate listed points.

Keyboard keys, for example, <Enter> are displayed in bold and enclosed in 
brackets.

Buttons in screen windows, for example, Delete are displayed in bold.
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System requirements
1.3  System requirements

1.3.1  Hardware 

• Windows operating systems, suitable PC, with:

– Processor: Pentium 4 or equivalent >=1.7 GHz,

– Memory: >= 2 GByte RAM,

– Hard disk: 256 MByte free hard disk space,

– CD-ROM or DVD drive;

– Monitor: CRT or LCD monitor, >= 19",

– Sound card with multimedia keyboard or PC speakers.

– USB handset or headset certified for AC-Win IP,
see Netinfo

NOTE:  System resources must be extended if AC-Win MQ is used parallel with 
other software applications.

1.3.2  Software

• Please see the Release Notes for the current supported Windows versions.

1.3.3  Communication system

AC-Win 2Q SL V3 and AC-Win MQ SL V3 are supported starting with 
OpenScape 4000 V8R0 communication platform and ONLY with:

• SoftGate virtual gateways vHG3500 (Q2330-X)

• STMIX Gateway Board (Q2343-X)
 A31003-G4030-M101-2-76A9, 06/2020
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Configuration options

Workspaces
2  Configuration options

AC-Win MQ can be configured in a number of ways. This allows you to set the 
program for the individual application and user. 

2.1  Workspaces

Workspaces consist of one or more objects or dialog boxes. The user can define 
specific settings for workspaces independent of the given application settings. 
This allows workspaces to be individually defined for each user. You can also 
select one of two default workspaces.

2.2  Objects (dialog boxes)

Objects (dialog boxes) are the "working windows" of AC-Win MQ. Various 
settings can be defined using different objects (e.g. layout of buttons). Objects 
can be saved separately with the given workspace or as templates.

The illustration below depicts a typical AC-Win MQ workspace. This example 
shows the AC-Win Call Control, Buttons and Name Keys objects in one 
workspace.
A31003-G4030-M101-2-76A9, 06/2020
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Application settings
2.3  Application settings

Application settings are valid for the entire AC-Win MQ program. Important 
working directories for the entire program can be defined here.

A typical AC-Win MQ workspace consists of the following objects

• Call Control,

• Name Keys and

• Buttons.

Call Control 

Buttons 

Status bar

Name Keys 

object

object

object
 A31003-G4030-M101-2-76A9, 06/2020
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Configuration options

Initial administration steps
2.4  Initial administration steps

The following steps must be performed once AC-Win MQ has been installed:

Basic application settings:

1. Make the global settings for directory structure, preset language, wallpaper 
etc. The procedure is described in "Application settings".

2. Create the user (see "User management").

Label source buttons:

The source buttons in the Call Control object represent the incoming call queues. 
Depending on the configuration of the communication system, different call types 
are assigned to separate queues. When AC-Win MQ is installed, wildcards (Q1 
to Q12) are entered in the name fields under the source buttons:

1. Change the label based on the current communication system settings 
(select AC-Win Settings, Queues in the Options menu). 

2. Save the settings. You have the following options:

– Save the source queue label (Save button). The labels stored apply to 
all workspaces.

– Export a label to a file.

Use the document template or the file in which the labels are saved for setting up 
additional workspaces.
A31003-G4030-M101-2-76A9, 06/2020
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Setting up workspaces
3  Setting up workspaces 

AC-Win MQ allows you to set up and save individual workspaces. Specific 
objects can be displayed in the workspaces according to the given requirements. 
The individual objects can be adapted to your specific requirements (e.g. you can 
label the name keys as you wish). You can save changed objects under a new 
name and integrate them into workspaces (see section "The AC-Win MQ objects" 
auf Seite 47). This allows AC-Win MQ to be configured for use in specific cases. 
It is also possible to configure a workspace for each user.

AC-Win MQ provides two different objects/workspaces:

• Object/workspace templates

• Object/workspace documents

When working with AC-Win MQ, use object/workspace documents. An object/
workspace template is used to create documents. You can then format these 
documents as required and make them available as templates or documents. 

To ensure that users do not inadvertently overwrite workspace and object 
templates, templates can only be saved by administrators with the "Admin" ID. 
You can also assign a password to a workspace. Objects of this kind can only be 
opened by entering this password.
A31003-G4030-M101-2-76A9, 06/2020
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New workspace
3.1  New workspace

A predefined workspace with Call Control, Buttons and Name Keys objects is 
automatically opened the first time you start up the program. You can supplement 
and change this workspace and then save it under a new name. You can also set 
up a new workspace by proceeding as follows: 

1. Start AC-Win MQ by double-clicking the program icon. 

2. Select New Object from the File menu.

3. Select the required object and click on OK.

The selected object is added to the workspace.

4. To add additional objects, select New Object once more from the File menu.
Select Open Object from the File menu to add objects you have defined and 
saved yourself (see "The AC-Win MQ objects" auf Seite 47).

5. To remove objects which have been added to the workspace, select Close 
Object from the File menu.

6. Position the individual objects where you wish within the workspace.
 A31003-G4030-M101-2-76A9, 06/2020
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Setting up workspaces

Switching workspaces
3.2  Switching workspaces

You want to change the current workspace in order to select another display. You 
can also select one of several default workspaces.

• Use "Default Workspace Wide" for screen resolutions of up to 1024 x 768 
pixel: 

– Under File, Open Workspace, select the file DefaultWide.cnw  or 

– under File, New Workspace, select the file DefaultWide.acw.

• Select "Default Workspace" for higher screen resolution:

– Under File, Open Workspace, select the file Default.cnw or

– Under File, New Workspace, select the file Default.acw.

Proceed as follows to change the workspace:

1. Select New Workspace from the File menu.

2. Select the required workspace and click on OK.
The selected workspace is added.

3. Select Open Workspace from the File menu to add workspaces you have 
defined and saved yourself.

4. Select Close Workspace from the File menu to close the current workspace.
A31003-G4030-M101-2-76A9, 06/2020
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Saving the current workspace
3.3  Saving the current workspace

When you have modified a workspace to suit your specific requirements, you can 
save it. 

1. Select Save Workspace As from the File menu.

2. Select whether you want to save the workspace as a 

– document (*.acw) or 

– template (*.cnw).

Saving a workspace as a template is recommended if you want to use the 
current settings for other workspaces. The AC-Win user class “Administrator” 
is required to save templates.

3. Enter the name you have chosen for your workspace and its path. 

4. Click on OK.

3.4  Loading a workspace

1. Select Open Workspace from the File menu. 

2. Select the workspace you wish to open from the list. 

3. Click on OK. The current workspace is loaded.

NOTE:  It is possible load a specific workspace automatically at startup. For infor-
mation on this operation, see "Application settings".
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4  Workspace settings

You can now enter your settings for the workspace:

1. Select Workspace Settings from the Options menu.

2. Enter the required settings.

– Workspace objects: The objects included in the current workspace are 
listed in this window.

– Save Workspace automatically: Select this check box if you wish to 
save the workspace automatically when you close AC-Win or when you 
close the workspace.

– Current language: In this window the current language used for that 
program is displayed. You may change the language with the AC-Win IP 
configuration program.

– User Name: This window contains the owner of the workspace.

– Use predefined title: Mark this check box to enter a title for the 
workspace in the Title field. The title is entered automatically if this check 
box is not marked. 

– Description: In this field you can enter a description, e.g. special settings 
for this workspace.

3. Close the window by clicking on OK. All settings are saved. To close the 
window without saving the changes you have made, click on
Cancel.
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Setting or changing a workspace password
4.1  Setting or changing a workspace password 

1. Click on the Password button in the Workspace Settings window to define a 
password for the current workspace or to change the existing password.

Setting a password:

– Enter the desired password in the New password field. The Old password 
field remains empty.

– Enter the new password again in the Retype password field.

– Complete your entries by clicking on OK.

The new valid password must now be entered when opening the workspace.

Changing a password:

– Enter the previously valid password in the Old password field.

– Enter the desired password in the New password field. 

– Enter the new password again in the Retype password field.

– Complete your entries by clicking on OK.

The valid password must now be entered when opening the workspace.

2. To close the Workspace Settings window, click on OK. All settings are saved. 
To close the window without saving the changes you have made, click on 
Cancel.
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5  Application settings

The AC-Win Application Settings window allows you to define global settings for 
AC-Win MQ. Certain settings, such as the language, can also be defined 
separately for individual workspaces (see "Setting up workspaces").

1. Start AC-Win MQ by double-clicking the program icon. 

A predefined workspace is automatically opened the first time the program is 
started. 

2. Select Application Settings from the Options menu.

Only 
administrators 
or super users 
can activate 
these buttons 
and define the 
associated 
settings.

3. Enter the required settings:

– Workspaces: Use this field to specify the directory in which you wish to 
save workspaces and objects. Click on  if you wish to change the 
predefined directory.

– Templates: Use this field to specify the directory in which you wish to 
save your templates for objects (see "Saving objects as templates"). Click 
on  if you wish to change the predefined directory.

– Open Workspace automatically: Use this option to set the workspace 
you wish to be opened when AC-Win MQ is started (see also "Setting up 
workspaces").

– Use wallpaper: If this check box is marked (selected), you can use the 
 button to set the "wallpaper" (background) that is loaded when the 

program is started. The wallpaper must be available in BMP format.
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– Default language: In this window the current language used for that 
program is displayed. You may change the language with the AC-Win IP 
configuration program.

– Start maximised: If this check box is marked, AC-Win MQ will be 
displayed in maximum size, filling out the entire screen instead of just one 
window.

– Prompt to save changed Workspace: If this check box is marked, a 
Save prompt appears when you quit AC-Win MQ if the workspace was 
modified.

– Use Greeter: If this check box is marked, you can use the  button to 
select the greeter to be displayed when the program is started. The 
greeter must be available in BMP format.

4. Click on OK to complete your entries. All settings are saved. 
To close the window without saving the changes you have made, click on 
Cancel.
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5.1  Adding OLE objects to the workspace

This function allows you to add objects from other Windows applications to the 
workspace. Please note that only applications certified for integration with AC-
Win MQ can be integrated in an AC-Win workspace (default).

NOTE:  Only administrators or super users can open the document for 
integrating applications.

Proceed as follows:

1. Select Application Settings from the Options menu.

2. Click on the Objects button.

3. Enter the name of the application which you wish to integrate in the New 
object name field. The name must be identical to the registered Windows 
name of the application.

4. Click on Add. The object will be added to the list of Currently supported 
objects and can now be added to your workspace.

5. To close the Supported objects window, click on OK. 
To close the window without saving the changes you have made, click on 
Cancel.
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5.2  User management

AC-Win MQ allows you to use a password to protect the program from 
unauthorized access. AC-Win MQ distinguishes between the following different 
user classes:

• User (uses the functions available on the user interface)

• Super user (uses some simple configuration functions in addition to the user 
functions)

• Administrator (uses all configuration functions).

3 3 3

3 3

3

3 3

3 3

3

3

3 3

3

3 3

3 3

The restrictions of the individual user classes have been kept to a minimum. 

The following table indicates the access rights for U (user), SU (super user) and 
A (administrator):

* The "Admin" password is required to delete administrators.

Activity U SU A 

Change own password

Change password of other user 

Change password of other super user 

Add, change, delete user

Add super user 

Change, delete super user

Add, change* administrator

Make application settings 

Configure application

Change, save document templates

Change traffic restrictions 
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5.3  Adding a user

To set up or change users, proceed as follows:

1. Select Application Settings from the Options menu.

2. Click on the Users button.

If you wish to create a new user:

3. Click on the New button.

4. Enter a name for the new user. 

5. Complete your entries by clicking on OK.

Set up a password:

1. Select from the dropdown list User the user for whom the password is 
being set up.

2. Define the user class.
You can choose between User, Super User and Administrator.

3. Enter the desired password in the New password field. Please note that the 
password is case sensitive.The Password field will remain empty.

4. Enter the new password again in the Retype password field.

5. Complete your entries by clicking on OK.
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Enter private number for AC-Win

1. Enter the private number for AC-Win in the Attendant number field. This 
number is used with the AMO ACSU.

2. To close the User management window, click on OK. All settings are saved. 
To close the window without saving the changes you have made, click on 
Cancel.

NOTE:  A new user can only be added by an administrator or super user.

5.4  Changing a user password

As an administrator or super user, you can use this function to change user 
passwords.

1. Select Application Settings from the Options menu.

2. Click on the Users button.

3. Select the user whose password you want to change in the Users field.

4. Overwrite the entry in the New password field with the desired password.

5. Enter the new password again in the Retype password field.

6. Complete your entries by clicking on OK.
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6  AC-Win Configuration Settings

After the installation, or with
Start->Programs->AC-Win [2Q|MQ] IP->AC-Win IP Configuration
the configuration interface is displayed. The first window displayed is the "Main 
connections" window. 

Every window includes the following buttons:

– Save settings: The changes are adopted and written to the registry.

– Undo changes: The last changes made are rolled back. 

– Restore defaults: The values from the registry are displayed and the 
changes discarded. 

6.1  The "OpenScape provider" Tables

6.1.1  Settings for the Main Connection

– Registration address: the IP address of the OpenScape 4000 IP 
gateway (STMI2 module).

– Admin number: AC-Win number which is used with the Admin user ID.

– Admin password/Retype admin password: If a password is assigned 
when setting up the AC-Win number in the OpenScape 4000, enter it 
here. Otherwise, an arbbitrary password can be assigned for use when 
logging on to AC-Win.
Note: The password is case-sensitive. 
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– Emergency call number: has no use at present.

– Security mode, Gatekeeper ID, Time Window(Sec.): Enter the same 
values in these fields that were set in the OpenScape 4000.

Signalling and Payload encryption (SPE):

Type of connection: select TCP, if no encryption is required or TLS for 
SPE-encryption

Cornet TLS Port: this port is used for the signalling. 

TLS H.225 Port: this port is used for the voice connection to the common 
gateway. The values entered here must correspond with the values at the 
common gateway.

– Mixer, Microphone, Speaker: Specify the audio I/O device (headset) to 
be used with AC-Win here. 
Note: Before these values are specified, the headset must be connected. 
Only then can the corresponding I/O devices be selected. If these values 
are not set, AC-Win will not operate. 
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6.1.2  Port Restrictions

This dialog is for specifying the port numbers used by AC-Win and the IP 
gateway.

– Gatekeeper CornetIP port: By default, the OpenScape 4000 IP gateway 
uses port number 4060 for communication with the  IP terminals. If a 
different port number has been configured in the IP gateway, enter it here.

– Use Cornet port range/ PC-Cornet IP port area: A specific Cornet IP 
port range can be used for the AC-Win PC. The preset port numbers are 
7000 to 7010. If you want to use a different range, enter it here. 

– RTP Port range: Change the port number range for the voice connection 
here.

– H.225 Signaling: For VoIP signaling, port number 11723 is used by 
default. If conflicts with other applications (e.g. NetMeeting) arise, you 
can change this port number here. 
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6.1.3  Licensing

This dialog is for configuring the access to the CLA (Common Licensing Agent).

– Server IP Address: Enter the IP address of the computer on which the 
CLA (Common License Agent) application is installed. 

– HFA server port: the port number (default 61740) over which access to 
the CLA application occurs.

– Timeout (ms): maximum time per connection attempt to the CLA 
application.

– Retry attempts: maximum number of connection attempts to the CLA 
application.

– Password: If a password has been configured for access to the CLA 
application, enter it here. 
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6.1.4  Bandwidth Reduction

This dialog is for making settings to reduce the bandwidth needed by the IP 
connection.

7 WARNING

DMC is NOT supported on AC-Win SL V3!

– Teleworking: deactivates the cyclical monitoring message between the 
IP gateway and AC-Win, resulting in reduced data volume. 

– Codec sequence: Specify the preferred compression algorithm (G.711, 
G.723, G.729) or an alternate.

– Codec packet lengths: For each codec, you can specify the voice 
packet length in milliseconds here.

– Jitter buffer (ms): To minimize delay losses, enter the jitter buffer size in 
milliseconds here. The better the network connection is, the lower the 
buffer size can be. 
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6.1.5  Failover / Small Side Redundancy (SSR)

With the failover (small side redundancy) feature, AC-Win can switch 
automatically to an alternate connection (another OpenScape 4000 node or 
another IPDA shelf) if its main connection fails.

– Registration address: Enter here the IP address of the alternate 
gateway to be used if the main connection fails. 

– Registration number: the number to be used by AC-Win when logging 
on to an alternate IP gateway. 

– Registration password: If a password is assigned when setting up the 
AC-Win number in the alternate system, enter it here.
Note: The password is case-sensitive. 

– Emergency call number: has no use at present.

– Security mode, Gatekeeper ID, Time Window: Enter the same values 
in these fields that were set in the alternate IP gateway.

Signalling and Payload encryption (SPE):

Type of connection: select TCP, if no encryption is required or TLS for 
SPE-encryption

Cornet TLS Port: this port is used for the signalling. 

TLS H.225 Port: this port is used for the voice connection to the common 
gateway. The values entered here must correspond with the values at the 
common gateway.

– Failover: Enter settings here for switching back to the main connection. 
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– Minimum of successful connection/Waiting time between 
connection (s): This value specifies the minimum number of 
connection attempts to the main system before switching back to the 
main connection. You can also specify the interval between these 
connection attempts. 

– No automated switchback: This setting determines whether or not 
automatic switchback is possible. 

6.1.6  Quality of Service

This dialog is for making Quality of Service (QoS) settings for the IP connection. 

– Mark packets: This setting specifies whether the packets should be 
marked to improve quality of service in Layer 2 and/or Layer 3.

– Call signaling/Voice payload: Specify the values for marking the packets 
here. 
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6.2  The "General" Tables

6.2.1  DLS/DLC Configuration

Set parameters for Deployment Service (DLS or central configuration) here.

– DLS deployment enabled: specifies whether or not the central 
configuration is to be used. 

– Server (DLS): Specify here whether all DLS services are to be used, or 
only the encryption of voice packets. 

– Client (DLC)

– Address: IP address or DNS name of the DLS.

– Port: port number of the DLS

– Connection

– Address: AC-Win IP address to be used for communication with the 
DLS. 

– Port: port number of the DLS connection on the AC-Win PC.

– Network card: MAC address at which the data will be stored on the 
DLS.
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6.2.2  General Settings

– Program type: shows which attendant console (2Q/MQ) is installed.

– Software version: software version of the installed AC-Win application.

– Selected language: from this list, you can select one of the AC-Win 
languages.
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6.2.3  Voice Recording

Use this dialog to make settings for digital voice recording at the attendant 
console. 

– Voice recording active: This setting activates voice recording in AC-
Win.
Note: In the OpenScape 4000, use AMO ZAND to set the parameter 
TAPALOW =YES in the ATND branch.

– Automatic tape recording: If this setting is activated, voice recording 
starts automatically (without pressing the record button) after a call is 
taken.

– Voice recording directory: This is the directory where the digital speech 
files (.wav files) are stored.
Note: We recommend that you use a local directory. With network drives, 
delays can result. 

– Voice recording beeps: When this setting is active, a beep is played at 
intervals while a conversation is being recorded. 

– Beep wave file location: here you can select the *.wav file with the voice 
recording beeps.
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7  AC-Win settings

This function allows you to configure: 

• the Call Control object,

• the Redial, Call Journal, Alarm and Call Charging objects,

• the accelerators,

• the colours.

• the appearance and behaviour of the queues

7.1  Call control settings

1. In the Options menu, select AC-Win Settings.

2. Enter the required settings:

– Calls on hold show time instead of "On Hold": The hold time for held 
calls is displayed and updated on the basis of the entry in the field Update 
every # seconds.

– Calls on hold change colour after # seconds: enter the time allowed to 
elapse before the held call beside the line key changes colour. 

– Limit Silence Timer: The acoustic call signal is automatically activated 
on expiry of the time entered in the Silence Timer in minutes field.
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– Startup in Plug-In mode: Calls can be answered immediately once AC-
Win has been started.

– Get focus on first incoming call: AC-Win becomes the active 
application when an initial incoming call is signalled.

– Automatic retrieve for call charges: Signalled call charge records are 
automatically retrieved.

– Automatic tape recording: Calls are recorded automatically according 
to the call queue settings.

– Enable external name retrieval: In the case of external calls, the name 
of the user is displayed if this information is available in a directory service 
application (e.g. DS-Win).

– automatic answer: Calls are automatically answered according to the 
queue settings.

– alerting tone on callqueue changes:
- off: no alerting tone
- single tone on increase: alerting tone  for each new call
- Periodical: periodical alerting tone with given interval

Access codes: 
Enter your communication system codes here for: 

– external line (the trunk code used in your communication system),

– paging, 

– switching to dual-tone multifrequency (DTMF) signalling, 

– mailbox retrieval,

– emergency override,

– emergency disconnect

3. Saving the settings with Save.

4. Complete your entries by clicking on OK.
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7.2  Object settings

1. Select AC-Win Settings from the Options menu.

2. Click on the Objects tab.

3. Enter the required settings:

– Redial: Define here whether the dialled/displayed number should be 
added to the redial list automatically or on the request of the user. 

NOTE:  If you selected Addition according to user request, you must add the 
To Redial key in the Buttons object! Otherwise, the user cannot save any number 
for redial.

– Call Journal: Define here which calls are to be recorded in the Call 
Journal. Specify a limit for the maximum number of entries in the list/file. 
Click on  if you wish to change the predefined directory or the file 
name.

– Alarm: Click on Save to file if you wish to save the alarm reports. Enter 
the maximum size. Click on  if you wish to change the predefined 
directory or the file name. 

– Call Charging: Click on Save to file if you wish to save the call charges. 
Enter the maximum size. Click on  if you wish to change the predefined 
directory or the file name. 
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– Notebook: Click on Save to file if you wish to save the notebook entries. 
Click on  if you wish to change the predefined directory or the file 
name.

– Printing: Specify the font and number of lines per page for printing.

4. Saving the settings with Save. 

5. Complete your entries by clicking on OK.
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7.3  Accelerator settings

The following rules apply to the definition of accelerators:

• Only the keys <1>, <2>, <3>, <4>, <5>, <6> on the alphanumeric keyboard 
can be used without the modifiers <Alt> and/or <Shift> and/or <Ctrl>. All 
other alphanumeric keys can only be assigned using these modifiers.

• All alphanumeric keys can be used, with the exception of country-specific 
letters such as <ä>, <ö>, <ü>, <ß>.

Proceed as follows to assign an accelerator:

1. Select AC-Win Settings from the Options menu.

2. Click on the Accelerators tab.

3. The Configuration list contains the AC-Win functions in the first list and the 
assigned key combinations in the second column. Select the function for 
which you wish to assign or change an accelerator from the first column.

4. Click on Reset to remove an existing assignment or click on Reset All to 
assign the default accelerators.

5. Select a new key combination from the Choices list or under Type (letter 
key) and, where applicable, a key under Modifier to be pressed 
simultaneously.

6. Click on Set to assign a single accelerator.

7. Repeat steps 3 until 6 to assign other accelerators.
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8. Click on Cancel to discard definitions. Changes can always be reversed 
unless you have pressed OK or Save.

Exporting and importing accelerator settings:
If you wish to use the same accelerators at each attendant console, you can 
export the current assignment as a file with the extension "acf". Click on the 
Export button. You can load a saved assignment by clicking Import. A 
window for entering/selecting the file name opens.

9. To save changes to the windows registry click on Save, to save changes and 
close the AC-Win Settings dialog click OK. The accelerators are stored for 
use in the application. 
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7.4  Colour settings

1. Select AC-Win Settings from the Options menu.

2. Click on the Call Control Colours tab.

3. Select the colours for the following elements:

– Call display fields,

– First status fields,

– Second status fields,

– Source Queue labels,

– Source Queues,

– Calls in progress fields.

Defining colors: 

– Click on the button assigned to the element to be modified. The Colours 
window opens.

– Click on the desired colour. Use the Define Colours to set new colours.

– Click on OK in the Colours window to assign the colour of the selected 
element.

– Repeat steps for additional elements.

4. Complete your entries by clicking on OK.

5. Click on the Button Colours tab.
A31003-G4030-M101-2-76A9, 06/2020
AC-Win MQ SL V3, Administrator Manual 39

         



AC-Win settings

AC_WinMQ_ch7.fm

Colour settings
6. Select the colours for the following elements:

– Buttons 

– Toggle background colour 

– Button groups 

Defining colors: 

– Click on the button assigned to the element to be modified. The Colours 
window opens.

– Click on the desired colour. Use the Define Colours to set new colours.

– Click on OK in the Colours window to assign the colour of the selected 
element.

– Repeat steps for additional elements.

7. Click on Cancel to discard definitions. Changes can always be reversed 
unless you have pressed OK or Save.

Exporting and importing colour settings:
If you wish to use the same colour settings at each attendant console, you can 
export the current assignment as a file with the extension "ccf". Click on the 
Export button. You can load an assignment already saved by clicking on 
Import. A window for entering/selecting the file name opens.

8. To save changes to the windows registry click on Save, to save changes and 
close the AC-Win Settings dialog click OK. 
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7.5  Queue settings 

You can label the fields under the source buttons. The label informs the user 
about the type of calls in the assigned queue. The assignment of the individual 
call types and calls based on their origin to the 12 queues is system-specific and 
is performed by OpenScape 4000 administration. Additionally, you can specify 
the queue priorities for automatic answering and enable automatic tape 
recording.

1. In the Options menu, select AC-Win Settings.

2. Click on the Queues tab.

Configure queues 

Labels of the source key name fields

3. Click on the desired name field and enter a text.

Queue priorities for automatic answering

4. Click on the desired field for the queue and set up a priority value between 
0 and 12.

A value of 0 disables automatic answering for the queue. 1 is the highest 
priority. For equal priorities, the calls from the queue with the lowest number 
will be answered first.

To come into operation, automatic answering must be enabled in the call 
control settings. 
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Automatic tape recording

5. Select "Automatic tape recording" for generally enabling the feature.

Then select the queues for which you want to enable automatic tape 
recording.

Exporting and importing settings:

If you wish to use the same labels and settings at each attendant console, you 
can export the current setting as a file with the extension "qcf". Click on the 
Export button. You can load labels and settings that have already been saved 
by clicking Import. A window for entering/selecting the file name opens.

6. Click on Cancel to discard definitions. Changes can always be reversed 
unless you have pressed OK or Save.

7. To save changes to the windows registry click on Save, to save changes and 
close the AC-Win Settings dialog click OK. 

The following table shows default source button configuration. 

Key Label Call Type 

F1 CO External calls (central office trunk calls)

F2 Tie Tie trunk calls

F3 - Unassigned

F4 - Unassigned

F5 - Unassigned

F6 - Unassigned

F7 Hot/Ov Hotline calls,
Overflow CO first calls,
Overflow tie first calls, 
Overflow local first calls

F8 Re/Se CO recalls,
CO serial calls,
Tie recalls,
Tie serial calls,
Local recalls

F9 Cons CO in consult,
CO on hook in consult,
Tie in consult,
Tie on hook in consult

F10 Loc/Int Local prio calls,
Local first calls

F11 Per/Op Attendant loop transfer,
Personal calls

F12 Undef Undefined calls
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Queue settings
NOTE:  Source button labelling depends on the configuration of the Communi-
cation system. Your current display may differ from this.
For further information about call types, refer to the service manual for the 
communication system.
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7.6  TAPI Dialing Function Settings

The TAPI dialing function enables AC-Win software-based connections to third-
party applications, such as

• Telephone book CD’s

• Directory service applications

• Specific Internet/Intranet pages

TAPI dialing enables third-party applications to transfer a phone number to AC-
Win and consequently the PABX by simply pressing a button.  In this way, 
operations such as call processing can be easily started from the third-party 
application and thus significantly shortened.

NOTE:  This function can only be used by a third-party application if the appli-
cation supports the standardized TAPI (Telephony Application Programming 
Interface) dialing function.

Parameter Settings:

1. Select AC-Win Settings from the Options menu .

NOTE:  The TAPI window for parameter settings is not linked to the AC-Win 
language settings. Hence it is only available in English.
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TAPI Dialing Function Settings
Generally, the third-party application’s phone numbers are saved in a specific 
format. For this reason, many applications currently support the ITU-T 
(International Telecommunication Union) E.164 numbering plan.

Example: 00 49 (89) 722-4711

SN = Subscriber Number

NDC = National Destination Code

CC = Country Code

IP = International Prefix

The TAPI dial setting parameters provide conformity between the phone number 
format in the third-party application and that used in the PABX.

Automatic Prefix Dialing of External Access Codes:

2. In the Outgoing Line Identifier field, enter the access code for an external 
number in such a way that the PABX recognizes it as a number that has been 
saved in a third-party application. 

3. In the Outgoing Line Number field, enter the external access code of the 
PABX.

By doing this, the access code entered in the Outgoing Line Number field will 
automatically be dialed when transferring the phone number to AC-Win.

Example: The phone number 089-4711815 is selected in a third-party 
application (e.g. a telephone book CD) and transferred to AC-Win. The 
number "0" is saved in the Outgoing Line Identifier field, i.e. AC-Win 
recognizes an external number for the PABX. The access code "9" is 
configured for an external line in the PABX. This access code must also be 
entered as an outgoing line number. AC-Win takes the number 9-089-
4711815 and sends it to the PABX.

All phone numbers saved in the third-party application that do not begin with 
"0" are interpreted by AC-Win as internal numbers. In this case, the Outgoing 
Line Number is not sent to the PABX.
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Setting up the Symbol for an International Prefix

4. In the International Prefix field, enter the international prefix access code 
(e.g. 00).

5. In the Prefix Symbol field, enter a symbol that is often used to indicate the 
international prefix, such as "+" (e.g. +49 89 722-4711 instead of 0049 89 
722-4711).

On TAPI dialing, AC-Win replaces the number sequence that is saved as the 
international prefix with the symbol saved in the Prefix Symbol field and 
transfers this to the PABX.

Filtering Your Own Country Code 

In the case of international phone numbers that are saved in the third-party 
application according to the E.164 numbering plan, one’s own local country 
code rarely needs to be transferred to the PABX.

The AC-Win TAPI dialing function automatically filters the local country code 
out of the phone number transferred from the third-party application and 
inserts a "0" before the national target code.

By default, the local country code is taken from the MS-Windows system 
settings (see System Settings -> Phone and Modem Options -> Edit -> 
Country/Region). By clearing the Use predefined local Country Code 
checkbox, you have the option to enter the local country code manually.
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Overview of objects
8  The AC-Win MQ objects 

AC-Win provides a number of predefined dialog boxes or objects. Objects are the 
"working windows" of AC-Win. Objects can be integrated in workspaces and 
saved with them. They can be changed and saved under a new name. Objects 
can also be saved as templates.

AC-Win provides a number of objects. The following chapter describes the 
predefined objects with configuration options.

8.1  Overview of objects

AC-Win provides the objects listed below. For more information about the 
individual objects, refer .

• "Alarms" 

• "Buttons" 

• "Call charges" 

• "Call control" 

• "Call journal" 

• "Name keys"

• "Notebook" 

• "Numpad" 

• "Redial" 
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8.2  Opening predefined objects

1. In the File menu, select New Object.

The New Object window appears.

2. Select the required object and click on OK.

You can now adapt the selected object to your individual requirements and 
save it under a new name.

8.3  Opening user-defined objects

1. Select Open Object from the File menu.

The file selection window appears.

2. Select the required object and click on OK.

You can modify the selected object and save it under the same name or a new 
name.

8.4  Saving objects

Modified objects can be saved under new names and in this way you can build 
up a library of objects which you can use when setting up workspaces. To save 
objects:

1. Select Save Object As from the File menu.

2. Enter the file type (template or document) you have chosen. Administrator or 
super user authorisation is required for saving templates. Saving an object as 
a template is useful if you want to use the current settings for other objects of 
the same type.

3. Enter the desired name and click on OK.

The standard directory defined under Application Settings is "Workspaces".

8.5  Closing objects

Previously opened objects can be removed from the current workspace by 
closing them. To close objects: 

1. Select the object which you wish to close.

2. Select Close Object from the File menu.
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8.6  Object settings

Specific settings can be defined for each object in the Object Settings window. To 
define object settings:

1. Insert the desired object in the workspace (see "Adding objects").

2. Mark the object.

3. Select Object Settings  from the Options menu or click with the right mouse 
button in the corresponding object window and select Object Settings.

4. Enter the required settings:

– Title: Enter the title displayed in the object header bar.

– Description: You can enter more information about the object here.

5. Complete your entries by clicking on OK. All settings are saved. To close the 
window without saving the changes you have made, click on Cancel.

8.7  Configuring objects

In addition to object settings which are the same for all AC-Win MQ objects, it is 
possible to define individual properties for certain objects. All of the AC-Win MQ 
predefined objects and their specific setting options are described below.

NOTE:  Using the individual objects is explained in the AC-Win MQ Operating 
Instructions.
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8.8  Call control

The Call Control window is the main object window in AC-Win MQ. All important 
call processing procedures are executed from this window.

NOTE:  Information on how to configure the Call Control can be found in the 
section Call control settings.
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8.9  Buttons

This object window shows the assignment of the buttons in AC-Win. In addition 
to defining the object settings, you can also define the layout and assignment of 
these buttons. You can save the changed object individually or with the entire 
workspace. An example of this window is shown below.

8.9.1  Button layout

To set the layout of the buttons:

1. Select the Buttons window.

2. Click with the right mouse button in the Buttons window and select Button 
layout.

3. Set the required button grid and size.

4. Complete your entries by clicking on OK.
The changes you have made take effect immediately. The new layout of the 
Buttons window appears (e.g. five lines, seven columns).
A31003-G4030-M101-2-76A9, 06/2020
AC-Win MQ SL V3, Administrator Manual 51

         



The AC-Win MQ objects

AC_WinMQ_ch8.fm

Buttons
8.9.2  Button order

To set the order of the buttons in the Buttons window:

1. Select the Buttons window.

2. Click with the right mouse button in the Buttons window and select Button 
order:

3. Select a function and click on the Up and Down buttons to change the order 
of the buttons.

4. Complete your entries by clicking on OK.
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Buttons
8.9.3  Button properties

To set the button properties:

1. Select the Buttons window.

2. Click with the right mouse button in the Buttons window and select Button 
properties.

The Button properties window appears showing the current settings.

3. You can now enter your settings:

– Button: You can assign a different/new function to the selected button 
here. (The button can be free or already have a function assigned to it.).

– Label: Enter the button label and its position or select the predefined 
settings.

4. Complete your entries by clicking on OK.

The changes you have made take effect immediately. The new layout of the 
Buttons window is displayed.
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8.10  Name keys

This object shows the name keys. In addition to defining the object settings, you 
can also define the layout and assignment of these buttons. You can save the 
changed object individually or with the entire workspace.

8.10.1  Name Key layout

To set the layout for a name key:

1. Select the Name Keys object. 

2. Click with the right mouse button in the Name Keys window and select Name 
Key layout from the pop-up menu.

3. Select the required key grid and size.

4. Complete your entries by clicking on OK.

The changes you have made take effect immediately. The new layout of the 
Name Keys window is displayed.
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8.10.2  Name Key order

To set the order of the name keys as they appear in the Name Keys window:

1. Select the Name Keys window.

2. Click with the right mouse button in the Name Keys window and select Name 
Key order:

3. Select a line and click on the Up and Down buttons to rearrange the order as 
required.

4. Complete your entries by clicking on OK.
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8.10.3  Name key properties

To set the name key properties:

1. Select the name key whose properties you wish to set in the Name Keys 
window. If the name keys are not assigned, the Name Key properties window 
opens immediately.

2. Click with the right mouse button in the Name Keys window and select Name 
Key properties.

3. Enter the label text and telephone number to be assigned to the name key(s).

4. If you mark the check box Make new call, a new connection is always set up 
when you click this name key. If this check box remains deactivated, a 
number of name keys can be linked, i. e. these predefined digits are added to 
an already dialled call number.

NOTE:  Using the individual objects is explained in the AC-Win MQ Operating 
Instructions.
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8.11  Call journal

This object records the calls which have been processed using AC-Win MQ. 

NOTE:  The settings for this object are made under Objects in the AC-Win 
Settings window (see Object settings).

In accordance with the settings made under AC-Win Settings, the current calls 
are displayed when you start AC-Win (basic setting).

• Click on Load File to display call data saved in the log file. Saving call data 
may take a little time. The call data is recorded in the log file, at the latest, 
when you quit AC-Win.

• Click on Show Current to display the current call data.
A31003-G4030-M101-2-76A9, 06/2020
AC-Win MQ SL V3, Administrator Manual 57

         



The AC-Win MQ objects

AC_WinMQ_ch8.fm

Numpad
8.12  Numpad

The Numpad object is used to dial numbers using the mouse. This object has no 
other settings.

8.13  Call charges

This object contains information about call charges.

NOTE:  The settings for this object are made under Objects in the AC-Win 
Settings window (see Object settings)
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8.14  Alarms

This object lists alarm causes. 

NOTE:  The settings for this object are made under Objects in the AC-Win 
Settings window (see Object settings).

8.15  Notebook

This object can be used to note and retrieve previously noted telephone numbers. 

NOTE:  The settings for this object are made under Objects in the AC-Win 
Settings window (see Object settings).
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Redial
8.16  Redial

Numbers can be stored and retrieved for redial in this object. 

NOTE:  The settings for this object are made under Objects in the AC-Win 
Settings window (see Object settings).
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