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Features of DS-Win V4

1 DS-Win V4

DS-Win V4 is an electronic telephone directory for the attendant console and office worksta-
tions. It consists of DS View for the application as well as GUI Designer and DS-Admin for cus-
tomization and modifications. It has been designed on the basis of the latest technical 
know-how and is extremely user-friendly. The wide range of features provided by DS-Admin al-
lows you to configure your telephone directory to suit your special requirements and thus opti-
mize it for your work.

1.1 Features of DS-Win V4

Application Areas

The DS-Win V4 electronic telephone directory can be integrated seamlessly in the PC atten-
dant console AC-Win IP V2 or BLF-Win V4 to form a complete system that fully satisfies de-
mands related to functionality, flexibility, and ease-of-use. No matter whether you are looking 
for the phone number of a subscriber, a particular key word, a specialist field or a sphere of 
responsibility, all you have to do is press a key and the DS-Win V4 system does the rest.
DS-Win V4 can, however, also be used at an office workstation. The integrated dialling aid al-
lows a call to be set up automatically from the connected telephone after the desired call part-
ner has been found.

DS-Win Characteristics

The DS-Win V4 electronic telephone directory is a directory service that can be customized for 
use on a PC and in a client/server configuration. The following functions are available:

● Telephone information system for attendant console and/or workstation with DS View func-
tions

● Configuration of the database and the user interface to one’s own requirements with 
DS-Win Designer

● Administration of all subscriber data including display of notes

● Distributed database, client/server technology

● Synchronization with host databases via LAN

DS-Win V4 is a 32-bit program, running with the Windows Vista® Enterprise (32-bit), 
Windows Vista® Business (32-bit), Windows 7 Enterprise (32-bit) and Windows 7 Ultimate 
(32-bit) operating systems.
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Features of DS-Win V4

Individually Configurable Database

The DS-Win V4 database provides you with tables in which you can record data such as em-
ployee names, room numbers, departments, eMail addresses, product catalogues, keyword 
lists, and much more. Apart from permanently set tables in which you can adapt the fields to 
suit your requirements you also have the option of adding new fields and even of creating new 
tables. This is particularly useful if you want to have access to information that is linked indirect-
ly to the telephone directory, such as hotel or restaurant addresses, notes, procedures, and so 
on.

In addition, when using a corresponding ODBC driver, you can also implement other databases 
such as Informix or MS SQL Server 2005, MS Access and MYSQL. Thus, existing databases, 
e.g., containing your personal data, can be used.

Individually Configurable User Interface

You can determine how your data will be displayed on the screen. For this purpose, DS-Win V4 
includes a design tool (see the DS-Win V4 Designer manual) that provides you with all resourc-
es you need to design the output of information on the screen in line with the requirements of 
your work.

Finding and Modifying Data

There are two basic search modes available: speed search and query.

● For a speed search, enter individual characters in a search field and move progressively 
closer to the subscriber or term you are looking for until the "correct" one is finally found. 

● In query mode, enter several search criteria, where necessary, and let the system search 
for all data records that correspond to these criteria.

You can move (navigate) in the dataset, rearrange the search result according to different cri-
teria, edit or delete records or add new ones.

Dial Functions

DS-Win does not only support the automatic telephone dialing equipment of the AC-Win PC 
attendant console, but also the optiPoint telephones through the USB interface. Thus, it can be 
used at an attendant console as well as at an ordinary workstation.

Printing Data

You can select different layouts for printing your data records or search results with the option 
of printing the entire dataset or individual records. DS-Win iReport von JasperSoft uses the 
software which can be used to create test pages.
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Administration Guide Concept

Import/Export

Large volumes of data can be imported and exported via a flexible interface. The DS-Win da-
tabase can be synchronized with host databases, e.g., with the central OpenScape 4000 Man-
ager database, either manually or automatically, according to a predefined timetable.

1.2 Administration Guide Concept

This manual describes examples of the above-mentioned functions from the administrator’s 
perspective. The guide shall:

● illustrate the relationship between individual functions,

● serve as a reference for administrators familiar with the product.

1.3 Product Names

The new product names are used in this administration guide, e.g., OpenScape 4000 Assistant 
(formerly: HiPath 4000 Assistant), OpenScape 4000 Manager (formerly: HiPath 4000 Manag-
er), OpenScape 4000 (formerly: HiPath 4000). If possible, these new product names are used. 
If the referred software user interfaces and books use the old names, the old product names 
are used.



DS-Win V4 Nur für den internen Gebrauch

 A31003-G6640-M100-3-76A9, 08/2014
1-4 DS-Win V4, Administration Guide

      

Product Names



ds-win_admin.c02.fm

A31003-G6640-M100-3-76A9, 08/2014
DS-Win V4, Administration Guide 2-1
       

Starting Administration

2 Starting Administration

Ways of Starting

There are two ways of starting the DS-Win Administration application with the standard dialog:

● Double-click the relevant dialog file.

● Start the "DS-Win Administration" window via the Windows Start menu.

Starting via the Windows Start menu 

Proceed as follows:

"DS-Win Administration" window

Step Action

1 Select Start -> Programs -> DS-Win V4 -> DS-Win Admin. The "DS-Win pass-
word" logon window opens.

2 Enter the user name and the password into the logon window. Then click OK. The 
"DS-Win Administration" window opens.

> The only user ID available by default for using the DS-Win Administration window is 
the "Administrator" user ID. This works initially without a password. We strongly rec-
ommend that you set a password for this user ID as soon as you log in for the first 
time. Once this is set, a login dialog pops up each time you open the DS-Win data 
view window. It is a good idea to set up additional user IDs with fewer privileges.
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The "DS-Win Administration" window is used for administering a DS-Win database. It offers the 
following functions:

● edit data

● import or export data

● create new databases

● edit table structures

● create new tables

● create layouts

● perform synchronizations with host databases

● administer users

● set countries

● change passwords

You can save changed database or language settings using File -> Save file. The administra-
tion window is started with these new values the next time it is opened.

The „Tables“ tab offers mapping tables. The „Print formats“ tab offers print formats.
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3 Data and Tables

Contents

You find the following topics in this chapter:

Section 3.1, “Table Structures and Indexes”

Section 3.2, “Data”

Section 3.3, “Databases”

Section 3.4, “Creating Layouts”
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Table Structures and Indexes

3.1 Table Structures and Indexes

Contents

You find the following topics in this section:

Section 3.1.1, “Designing Table Structures”

Section 3.1.2, “Creating New Tables”

Section 3.1.3, “Editing Indexes, Creating New Indexes and Deleting Unnecessary Indexes”

3.1.1 Designing Table Structures

If you have the appropriate access permissions, you can change the structure of the displayed 
table.

Prerequisite

The DS-Win administration was started. Refer to Chapter 2, "Starting Administration".

Example for the "Design table" Window

Procedure

Proceed as follows:

Step Action

1 In the "DS-Win Administration" window, select a table in the "Tables" tab.

2 Click Design. The "Design table" window opens.
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Table Structures and Indexes

The following properties are available depending on the "Column type" and "Format rules" 
fields:

3 You can enter or change the properties supported by the database. If existing tables 
are copied, all predefined mandatory fields complete with their properties are copied 
without relationships to other table fields.
All other user tables are designed without these presettings. You insert columns and 
fields in tables and define the attributes "Name", "Type" and, where applicable, "For-
mat rules" and "Comment" for each column.

Field properties Description

Fields Name of the database field

Field type Specifies the field type (counter, text, etc.)

Format rules Specifies the fields that the field comprises.
Syntax: Field1 + ’ ’ + Field2 ...
LastName + ’ ’ + FirstName

Comment Information about the field

Properties Description

Field length In the case of text fields

Default value Default value assigned to the field in the case of a new data record.

Input required Defines whether or not data is required in this field.

Indexed Use this property to allocate a simple index for a field.

Style Specifies the style of the field (only possible if field rules were spec-
ified for this field):
Lowercase: the field is toggled to lowercase.
Uppercase: the field is toggled to uppercase.
Normal: no field conversion is performed.

Umlaut mode (muted 
vowel)

Uppercase is possible in the case "Style":
Default: muted vowels are not converted.
German: muted vowels are converted: Ä -> AE

Type Specifies the table type

Vordefiniert Shows whether the table is predefined or customer-specific.

Step Action
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Table Structures and Indexes

The Following Rules Must be Observed

If properties of fields and tables are changed, certain changes will depend on the type of table, 
as described in the following rules:

● Fields can only be inserted, edited, or deleted in empty tables.

● Fields added by the user can be deleted in empty tables.

● Predefined fields can be deleted provided they are not used internally (e.g., "IntExtension" 
cannot be deleted).

● Fields can be inserted in any table.

● Names of fields inserted by the user can be changed.

● The length of predefined fields can be increased or reset to the default value. In all other 
text fields, it is possible to specify any length.

● Every table should have at least one primary key.

Creating a New Field

Proceed as follows to create a new field in an existing table:

> Inserting an index in a field significantly increases the search speed for finding val-
ues in this field.
Composite indexes are defined via the Index Editor.

7 Warning
The indexes "subscriber_@masterid", "subscriber_@subscriberid" in the subscriber 
table and "product_@subscriberid", "product_@product" in the crsubsprod table 
should not be deleted or modified!

Step Action

1 Select the row in which you want to insert the field. Result: The line is partially high-
lighted.

2 Click the Insert row button. Result: A blank row appears for your entries.

3 Assign the required field name and field type.

4 Define further attributes under "Field properties".

> Please note that the following types and field lengths are specific to the PostgreSql 
database. These can be different for MySql and MSSql servers!
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Field type Field length Default value Input required Indexed

BOOLEAN – possible possible possible

BYTEA – – possible –

BIGINT – possible possible possible

BIGSERIAL – – – possible

SMALLINT – possible possible possible

INTEGER – possible possible possible

SERIAL – – – possible

TEXT – possible possible possible

REAL – possible possible possible

DOUBLE PRECISION – possible possible possible

MONEY – possible possible possible

CHAR – possible possible possible

VARCHAR 1 - 10485760 possible possible possible

DATE – possible possible possible

TIME – possible possible possible

TIMESTAMP – possible possible possible

TIMESTAMP WITH TIME 
ZONE

– possible possible possible

TIME WITH TIME ZONE – possible possible possible

BIT 1 - 83886080 possible possible possible

BIT VARYING 1 - 83886080 possible possible possible

NUMERIC 1 - 1000*

* For numeric types the field length must be specified in the format E,S where E is the exactness and S the scaling. For 
example for the length 5.2, the values 10; 3.12; 24.4 or 678.24 can be saved in this field. The specified value 1-1000 applies 
to the precision.

possible possible possible
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3.1.2 Creating New Tables

You can also create new tables in your database. This is always advisable if a table structure 
that does not yet exist is needed. Examples of this are simple value lists or private telephone 
directories containing fewer columns than the "Subscriber" table. You can also delete tables 
that you have created yourself.

Proceed as follows to open a new table:

An existing table can be saved under a different name so that the new table adopts the structure 
of the original. However, data records will not be copied at the same time.

If you also want to transfer contents, export the data from the source table and re-import it into 
the destination table.

3.1.3 Editing Indexes, Creating New Indexes and Deleting 
Unnecessary Indexes

Indexes increase the search speed. Too many indexes reduce the data processing speed and 
increase the size of the database. It is therefore recommended that you create only as many 
indexes as you actually need.

Creating Indexes

Proceed as follows to create indexes:

Step Action

1 In the „DS-Win Administration” window, select the „Tables“ tab.

2 Click New. The „Design table“ window with a new empty table opens.

Step Action

1 In the "Design table" window, open the "Define field indexes" dialog by clicking the 
Indexes button.

2 Create a primary key in the first field of the table (It doesn’t necessarily have to be 
the first field but this is the standard procedure).

3 Insert a new row in the desired position with the Insert row button.

4 Enter a name for the new index under "Index name" (In the DS-Win V4 database, 
the index is named in the format <table name>_@<any name>).
You do not have to name the Primary key as it receives a default name.
If you change to the "Field name" column, the input field changes into a drop-down 
menu from which you can select the desired field name.
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You can create combined indexes by inserting several rows with field names for which you 
specify the same index name. A combined index is necessary in order to define a particular 
sorting sequence over several fields. 

Example: 
If an index contains the "LastName", "FirstName" and "Organization" fields in this order, the in-
dex is sorted first by last names, then first names, and finally by departments. A different sorting 
procedure results when the "Organization" field is set to the beginning of the sequence.

The combination boxes in the "Index properties" section can be used to specify whether the key 
is a "Primary key" and/or whether the field values have to be "Unique".

7 Warning
The "subscriber_@masterid", "subscriber_@subscriberid" indexes in the subscriber 
table and "product_@subscriberid", "product_@product" in the crsubsprod table 
must not be deleted or modified!
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3.2 Data

Contents

You find the following topics in this section:

Section 3.2.1, “Editing Data”

Section 3.2.2, “Importing and Exporting Data”

Section 3.2.3, “»MSysCountry« System Table”

Section 3.2.4, “»MSysMappingTable« Allocation Table”

Section 3.2.5, “»eMail« Data Field”

Section 3.2.6, “»LUserName« Data Field”

3.2.1 Editing Data

Prerequisite

The DS-Win administration was started. Refer to Chapter 2, "Starting Administration".

Example for the "Edit data" Window

Procedure

Proceed as follows to edit data in a table:

This window provides a simple means of changing, adding and deleting data records:

Step Action

1 In the "DS-Win Administration" window, select a table in the "Tables" tab.

2 Click Open. The "Edit data“ window opens.
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The "Modified By" and "Modified On" fields are filled automatically in all predefined tables; the 
"Sortname", "InvertedNumber", "SubscriberID", and "TieInvertedNumber" fields are additional-
ly filled in the case of "Subscriber" tables”.
If data records are deleted from the "Subscriber" and "Product" tables, the system also adjusts 
the "CRSubsProd" table (if a corresponding entry is present it will be deleted).

If you then

Mark text parts You can overwrite them.

Click "Delete record" You remove the marked data records.

Click "Insert record" You open a row for a new data record at the marked data 
record.

Click "Clear table" You can remove all data records, e.g., in order to edit the 
table structure.
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3.2.2 Importing and Exporting Data

Overview

You can import data from or export data to a text file of your choice. Before you can import or 
export data, you must create a data format specification.

When importing, you can choose between the following options:

● Updating an existing table

● Refilling a table (the old contents is deleted first)

Updating an existing table will only give a meaningful result if you have previously generated 
the table in question with data from the same source and have filled in the "SubscriberID" field. 
The fields over which the primary index (Primary key) is positioned will be taken as the key for 
the update. In the subscriber table this is the "SubscriberID" field.

The necessary file format settings are stored in a so-called "specification". This contains infor-
mation indicating which data sections of an import file are transferred to which fields of a table, 
or the order in which the contents of the table fields is written in the export file.

Prerequisite

The DS-Win administration was started. Refer to Chapter 2, "Starting Administration".

Procedure

Proceed as follows to import or export data:

Step Action

1 In the "DS-Win Administration" window, select Database -> Import data or 
Export data. The "Import data" or "Export data" window opens.

2 ● Enter in the "Import data" window:
– File name: Enter path and name of the file that has to be imported. Alterna-

tively, select a file via Browse.
– Specification: Select an applicable specification. If not yet defined: Refer to 

the paragraph "Create a Data Format Specification".
– Update mode: Select either Update data records or Fill table with new re-

cords.
● Enter in the "Export data" window:

– File name: Enter path and name of the file which has to be exported. Alter-
natively, select a file via Browse.

– Specification: Select an applicable specification. If not yet defined: Refer to 
the paragraph "Create a Data Format Specification".

4 Click Execute. The data will be imported or exported. A progress bar is displayed.
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Create a Data Format Specification

Proceed as follows to create a data format specification:

The following basic rules apply:

● Data is imported or exported via conventional text files that can be edited with any standard 
editor (e.g. NOTEPAD.EXE or WORDPAD.EXE) and saved in ASCII format.

Step Action

1 Select the "Database" menu.

2 Select the entry "Import data" or
"Export data".

3 Click Define. The "Import/Export settings" window opens.

7 The fields ModifiedOn and ModifiedBy must not be imported; otherwise, the import 
fails.

Step Action

4 Specify the relevant settings in the "Import/Export settings" window.

5 Click Specifications... to use an existing specification.
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● The standard character set for Windows (ANSI) or the PC-8 character set is used.

● When data is imported, a record is created for each row; when data is exported, each 
record is written in a new row. If there are any memo fields, these must have a text sepa-
rator (e.g.: ").

● The individual fields are separated by field separators. During data import, the file can also 
be structured to be compatible with the columns, i.e. in each row, a field begins at a specific 
character position (fixed format).

● File format "Fixed format"
Field lengths are predefined for "Fixed format". Thus, field delimiters are not required. Note 
that the field length and the order in the field name table must correspond with the field 
length and the order in the import file.

● File format "Text separators"
It is not necessary for the import file to fill all database fields. The field name table offers 
the option of omitting those fields that you do not want to import. For this purpose, delete 
the corresponding line in the table. 
In this table, you can also specify whether a particular field is to be skipped when importing 
data although it contains data in the source file.

● Field names in the first row
This property is only supported for the option "Text separators". 
Activate this check box if the import file in the first row contains the field names including 
the field delimiters. The order of the field names must correspond to the order of the fields. 
The field name table is not considered.
If you do not activate the check box "Field names in the first row", the system expects data 
that correspond the field order as listed in the field name table.

● Text can also be separated from numerical values by defining an appropriate text separator 
character.

● Fields of the type "Counter", "OLE", "Binary" are neither imported nor exported.

● An export action always exports all fields with the exception of the ones listed above.

● Dummy fields can be specified for importing; these enable the import specification to be 
matched to the ASCII file to be imported.

● When importing data you can specify default values instead of importing the field value.

● Only the field "SubscriberID" should be imported in the case of subscriber tables,

– if there are cross-references from this entry to other tables 
(e. g. to CRSubsProd) or

– if you click the option "Update data records" in the "Update mode" area of the 
"Import data" window.
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Accordingly, the following entries are required in the "Import/Export settings" window:

Save your settings as format specification, preferably with a meaningful name.

Now, you can carry out an import or export procedure with the options selected here at any time 
by specifying this name in the "Specification" field in the "Import data" or "Export data" dia-
log.

Examples of Data Formats

File type Set "Windows (ANSI)" (standard character set) or "OS/2 (PC-8)" (dif-
ferent character allocation).

Text separator Select the character for separating text from numbers (optional).

Field delimiter Select the character for separating the individual contents of fields in 
a data record.

Table Select the table into which data is to be imported or from which it is to 
be exported.

File format Set "Fixed format" and then change the table with the field names, 
data types and lengths according to your file structure. With "Skip" you 
can also specify whether the field is to be imported or exported.

Import log file Enter the path name of a file in which any errors occurring during im-
port can be logged. If the procedure is unsuccessful, you can subse-
quently view the file with a standard editor (NOTEPAD.EXE or WORD-
PAD.EXE) and correct the invalid lines in your import file accordingly.

Example 1: Text separator " (quotation marks), field delimiter is ";" (semi -colon), file format 
set to "Text separators", "Subscriber" table, only the fields „FirstName”, "Last-
Name", "Organization", "IntExtension", "FaxExtension" and "Text1" are taken into 
account in the "Field Name Table"; all other fields are deleted. No field names in 
the first line:
"Miller";"Martin";"PW NE 244";2230;2156;"Department Manag-
er"
"Kelly";"Ida";"RI AC";4216;4230;"Secretary"
"Lynch";"Ralph";"KR FS 1 R";3255;3105;"Developer"

Example 2: Text separator "none", field delimiter is ; (semi-colon), file format set to "text sep-
arator", "field names in the first line", 
FirstName;LastName;IntExtension;FaxExtension;Organiza-
tion;Text1
Martin;Miller;2230;2156;PW NE 244;Department Manager
Ida;Kelly;4216;4230;RI AC;Secretary
Ralph;Lynch;3255;3105;KR FS 1 R;Developer
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Example 3: Text separator "none", file format set to "Fixed format", "Subscriber" table, only the 
fields "FirstName" with length 10, "LastName" with length 20, "Organization" with 
length 10, "IntExtension" with length 5, "FaxExtension" with length 5 and "Text1" 
with length 20 are taken into account in the "Field name table"; all other fields are 
deleted:
Martin Miller PW.NE 244 2230 2156 Department 

Manager

Ida Kelly RI.AC 4216 4230 Secretary

Ralph Lynch KR.FS.1.R 3255 3105 Developer
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3.2.3 »MSysCountry« System Table

Utilization

The "MSysCountry" system table is required for transferring data from the electronic telephone 
directory (ETD) or the predecessor version, DS-Win V2. In these products, a country code is 
used instead of the country ID. The "MSysCountry" table contains the rules for translation from 
country code to country IDs that are applied when transferring data from these products.

Changing Entries

When you open "MSysCountry" in the "Tables" tab for the first time, it already contains a num-
ber of frequently used entries. You have the option of adding additional country codes under 
"country" and additional country IDs under "countryid" or of deleting entries that are no longer 
needed. Use the appropriate buttons for this. You can also delete the table except for the default 
entries and replace them by new entries if required.
.

3.2.4 »MSysMappingTable« Allocation Table

This table is not longer used.

3.2.5 »eMail« Data Field

The supplied DS-Win V4 test data contain a predefined field for the e-mail addresses.

Table: Subscriber

Field: eMail

You can make the entry in the same way as in the data editing options described above. The 
e-mail addresses are not validated.
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3.2.6 »LUserName« Data Field

DS-Win V4 allows Lotus Notes to be used for presence management. To do this, you need to 
add a new field to the database:

Table: Subscriber

Field: LUserName

For information about adding a data field, see Section 3.1.1, “Designing Table Structures”.

3.3 Databases

Contents

You find the following topics in this section:

Section 3.3.1, “Creating a Database”

Section 3.3.2, “Opening a Database”

3.3.1 Creating a Database

You have two options:

● You create a new database which you save as physical unit.

● You create a link to other databases.

Proceed as follows to create a new database:

Step Action

1 In the "Database" menu of the DS-Win Administration window, select the entry 
"Create database...".

2 Select a database from the "Database server" drop-down list.

3 Enter the name or IP address of the computer where the database server is run-
ning. Enter the port number.

4 Enter the user name and the associated password. Existing databases are dis-
played. The predefined port number for a PostgreSql server is 5432. Each data-
base server uses a different port umber. The port numbers can be specified as 
you wish during the installation of the database server.

5 Click the Connect button. Existing databases are displayed.
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7 In the "Create database" dialog, click New. In the "Database name" field, enter a 
corresponding name without special characters and click Save. The new data-
base is created and appears in the list.

8 Select the new database from the list and click "Schemas...“. A dialog for sche-
mas appears.

9 Click New and assign a name, e.g. "company_schema", in the "Schema name" 
field. Then click Save. The new schema is created and is added to the list. Close 
the dialog.

10 Close the "Create database" dialog.

Step Action
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3.3.2 Opening a Database

To open an existing database, select "Open database..." in the "Database" menu of the DS-Win 
Administration window. The "Open new DB schema" dialog appears.

The following database configuration files are implemented:

● hibernate.MySql.cfg.xml

● hibernate.PostgreSql.cfg.xml

● hibernate_Informix.xml

● hibernate_Oracle.xml

● hibernate_SqlServer.xml

3.3.2.1 Adding a New Database

If your database schema is not listed yet, a further configuration file must be created. To do this, 
click New. The following dialog opens:

In the "Database" list, select, e.g., PostGreSQL or swap the following wildcards:

Enter a user name, e.g., "postgres", and the corresponding password. Use the Test connec-
tion button to check whether the database is available.   The confirmation "The connection is 
ok" should appear. The dialog should look like this:

> Important: To open an existing database, you must first close the automatically 
opened database via "Database" -> "Close database". The "Close database" menu 
item then changes to "Open database".

Wildcard Example

<hostname> IP address 192.168.1.26 or db server

<dbname> unify

<schemaname> concern_schema
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Click Save. Enter a name for the configuration file in the following dialog:

You get a confirmation that the configuration file was created.

3.3.2.2 Opening a Database

If a configuration file has already been created for a database, mark the required database con-
figuration in the list, e.g., "Unify.xml", and click "Open" and enter the user and the assigned 
password.

The desired database is displayed. 
You can change and delete entries in the database and subsequently save or discard these 
changes.
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3.4 Creating Layouts

Click New in the "Print formats" tab of the "DS-Win Administration" window".

The supplied "iReport" application of JasperSoft Corp. opens. Information on installing the ap-
plication, notes on connecting to databases, and layout preparation can be found in the docu-
mentation of the "iReport" application (with the CD supplied).

> Before you create a layout, make sure that a standard printer is installed at your PC. 
Otherwise, you will not be able to display a preview or print.
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4 Synchronization with OpenScape 4000 Assistant/
Manager 

Overview

If you already use the OpenScape 4000 Manager for administering your OpenScape/HiPath 
4000 network, you can import the subscriber data stored there, or parts thereof, into DS-Win 
and synchronize them later.

A user login with XIE access must be defined in the OpenScape 4000 Manager. The definition 
of this user login is described in A31003-G6640-S100-3-**20 DS-Win V4 service manual, sec-
tion 4.2 "Defining a user login for the Import/Export API (XIE) in the OpenScape 4000 Assistant/
Manager".

DS-Win V4 uses the "Export Table Client" application for the synchronization of data between 
DS-Win and the OpenScape 4000 Assistant/Manager.

Synchronization via LAN with ISDN Connection 

DS-Win V4 enables synchronization with databases, via ISDN lines too. Remote DS-Win 
equipment can therefore also be synchronized without LAN link. An ISDN PC card is required 
for this function. After configuration of the card using the software supplied, you can run the 
synchronization process as in the LAN.

Contents

You find the following topics in this chapter:

Section 4.1, “General Description of the Data Exchange”

Section 4.2, “Creating a Synchronization Specification”

Section 4.4, “Performing Synchronization”

Section 4.5, “Creating Time Schedule for Synchronization”

Section 4.6, “«Export Table Client» Application”
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4.1 General Description of the Data Exchange

The data exchange between the two databases is generally performed in the following steps:

1. Export the data records from the OpenScape 4000 Manager database to response files.

2. Convert the response files into import files.

3. Import the data contained in the import files into the DS-Win database.

Initial Synchronization

The initial synchronization fills the data into the "Subscriber" table to generate the basic data-
base. The data record key of the OpenScape 4000 Manager database is included in the sub-
scriber table.

Update Synchronization

In the case of subsequent, updating synchronization processes ("delta synchronization"), the 
system creates two import files from the response file:

● First file:
This file contains the new and altered records that have been added or edited since the last 
synchronization process or the initial generation. DS-Win imports this data, identifying 
each of these records from the data record key sent with it and updating it accordingly.

● Second file:
This file contains the data record keys of the records deleted from the OpenScape 4000 
Manager database in the same period. DS-Win reads the data record keys and deletes the 
associated records from the local database so that synchronism is re-established between 
the two databases on the server and locally on the DS-Win PC after both procedures.

Synchronization Spezifications

The DS-Win settings for synchronization are saved in specifications in the same way as the im-
port/export procedures.
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4.2 Creating a Synchronization Specification 

Contents

You find the following topics in this section:

Section 4.2.1, “Synchronization Settings”

Section 4.2.2, “Field Mapping”

4.2.1 Synchronization Settings

4.2.1.1 «Synchronization settings» Window

Overview

This section describes the tabs in the "Synchronization settings" window.

OpenScape/HiPath 4000 Manager

Example of the "HiPath 4000 Manager" tab

Text files

The "Text files" tab is used to synchronize ASCII files. An import specification must be set up 
for this. You can select the existing import specification in the "Import specifications" drop-down 
box. You can thus reload the entire database from time to time or transfer modifications.

Deleted data records cannot be synchronized in this way.
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Request files

The "Request files" tab is used when synchronizing data to host computers.

4.2.1.2 Enter Synchronization Settings

Prerequisite

The DS-Win administration was started. Refer to Chapter 2, "Starting Administration".

Procedure

Proceed as follows:

Step Action

1 Select in the "DS-Win Administration" window: Database -> Synchronization. The 
"Synchronization" window opens.

2 Click Define in the "Synchronization" window. The "Synchronization settings" win-
dow opens and the "HiPath 4000 Manager" tab is displayed.

3 "HiPath 4000 Manager" tab -> "Local settings" area: Enter the following settings 
in this area:

1. Table: Select the table name. The Subscriber table is used for subscriber 
synchronization.

2. Target path: Enter a destination directory for the exchange file.

3. File name: Enter the file name for the exchange file. The DSWin2.req name 
is normally used. The file name must terminate with .req. You can select a file 
name of your choice when synchronizing.

4. Import log file: Enter the name for the import log file. Any import errors are 
logged in this file.
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4 "HiPath 4000 Manager" tab -> "Host settings" area: Enter the following settings 
in this area:

1. Address: Enter the IP address of the OpenScape 4000 Manager server in the 
IPv4 format.

2. Login: Enter the user login for the OpenScape 4000 Manager server.

3. Password: Enter the password for the OpenScape 4000 Manager server.

4. ODF name: Enter the name of the object description file for the XIE-API inter-
face (ODF: Object Description File).

Object description file approved for DS-Win (refer to 
A31003-G6640-S100-3-**20 DS-Win V4, Service manual, section 4.2 "Crea-
ting DS-Win subscribers in the OpenScape 4000 Assistant/Manager"):
– PERSDAT: to synchronize subscriber data
– PERS: to synchronize subscriber data. Created from PERSDAT.
– DISPLAY_NAME: for the subscriber’s display name

Description of the object description files: refer to A31003-H3460-S100-*-**20 
"HiPath 4000 Manager V6, Import/Export- and API Interface".

5. Source path: Change the default setting of the source path if another name 
than iefiles was entered for the Request and Response files.

6. Timeout: Time at which DS-Win checks if the Response file is available. In-
crease the default value of 5 minutes in the case of large volumes of data.

5 "HiPath 4000 Manager" tab -> "Filter settings" area: Enter the following settings 
in this area:

1. Update period:
– For the initial synchronization: Select none.
– For the update synchronization: Select a time span. Only data records that 

were created, modified, or deleted within this period of time are synchro-
nized.

2. Filter: Limit the data record volume if required: The command is specified in 
SQL syntax.
Example: company matches "XY*" and org1 = "PN".
Only data records that start with the "XY" value in the company field and con-
tain the "PN" value in the org1 field are returned. The "Filter" field is limited to 
128 characters.

Step Action
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Further Processing

Refer to Section 4.2.2, “Field Mapping”.

4.2.2 Field Mapping

Overview

The fields of DS-Win View musst fit to the OpenScape 4000 Assistant/Managers output fields. 
However, the field names differ.

4.2.2.1 «Field Mapping» Window

Overview

This section describes the options of field mapping in the "Field Mapping" window.

Comments to the Table

For subscriber synchronization, the MSysMappingTable is offered by default (refer to 
"DS-Win Administration" window -> "Tables" tab.

The names of the fields in the "Host name" column are provided by the OpenScape 4000 Man-
ager. These fields are the source fields. The field names in the "DSWin name" column are for 
the DS-Win database. These fields are the destination fields.

6 Save specification:

1. Click Save as on the "HiPath 4000 Manager" tab. The "Save specification" win-
dow opens.

2. Enter a specification name, e.g. DS-Win-Sync, and click OK. The window is 
closed and the specification is saved.

Note: Spaces cannot be used in the specification’s name because the "Task 
Scheduler" windows application would take them for an attribute.

Step Action
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The default assignment of OpenScape 4000 Manager to the subscriber table of DS-Win is as 
follows:

● If multiple consecutive fields are mapped to the same field, the contents of the source fields 
is written to the target field, separated by spaces.
Example: If org1 contains the value KR, org2 the value EC and org3 the value 326, the "or-
ganization" field is filled with the value KR EC 326.

● You can also map a source field to multiple target fields.
Default values are set in quotation marks. In this case, nothing is transferred from the 
OpenScape 4000 Manager. A default value can be specified for any database field.

Host name DSWin name Remarks

building building

christianname firstname

name lastname

salutation salutation

company company

country intcountry The field is converted first with the aid of the 
MSysCountry table.

ext_areacode intareacode

ext_netcode intnetcode

extension intextension

faxnumber faxextension

unique_key masterid The value of this field is used to identify the data record 
when the update synchronization is performed.

location address

longname room

text1 text1

text2 text2

text3 text3

title title

org1 organization After the assignment, the "organization" field contains 
the contents of <org1> <org2> <org3> divided by 
space characters.

org2 organization

org3 organization
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● If there are customer-specific fields created in the database of the OpenScape 4000 Ma-
nager and corresponding fields also exist in the DS-Win database: Enlarge the table by ad-
ding these pairs of fields so that synchronization can also be carried out between these 
fields.

● In the event of synchronization from multiple host computers (e.g. different sites), tie dialing 
may occur within the sites but not between the sites. The domain and tienum fields must 
be specified in the "Field Mapping" window to ensure correct dialing.

Add Fields/Rows

If you want to add fields from OpenScape 4000 Manager to the table of the "Field Mapping" 
window, you must know the position of these fields in OpenScape 4000 Manager and at which 
position and with which information they shall be displayed.

1. Select the row in the "Field Mapping" window which is on the position of the planned new 
row and click Insert row. A new row is added.

2. Click the table cell to be named by the field name. A drop-down list with field names opens.

3. Select the required field name. The field name is added to the table cell.

Delete Fields/Rows

1. Select the row to delete in the "Field Mapping" window.

2. Click Delete row. The row is deleted.

Change the Assignment of the Fields

1. Select the row of which you want to change the field name in the "Field Mapping" window. 
A drop-down list with field names opens.

2. Select the required field name. The field name is added to the table cell.
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4.2.2.2 Adapting Field Mappings

Prerequisite

The "HiPath 4000 Manager" tab is open.

Procedure

Proceed as follows:

Further Processing

Refer to Section 4.3, “Positioning of the Fields in the OpenScape 4000 Manager”.

Step Action

1 Click Field Mapping on the "HiPath 4000 Manager" tab. The "Field Mapping" win-
dow opens.

2 In the "Field Mapping" window:

1. Check the assignment of the fields between the "Host-Name" and "DSWin-Na-
me" columns.

2. If customer-specific fields must be additionally synchronized to the default 
mapping: Change the assignment of the fields, add new rows or delete rows.

Further information can be found in „Section 4.2.2.1, “«Field Mapping» Window”“.
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4.3 Positioning of the Fields in the OpenScape 4000 Manager

If you search for additional information regarding the positioning of fields in OpenScape 4000 
Manager, or if you want to perform settings:

● A31003-H3460-M103-*-76A9, HiPath 4000 Manager V6, Configuration Management:
6.1.1 Subscriber und 11 Editing the Configuration Management User Interface

● A31003-H3460-M102-*-76A9, HiPath 4000 Assistant V6, Configuration Management:
7.1.1 Subscriber

Further Processing

Refer to Section 4.4, “Performing Synchronization”.
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4.4 Performing Synchronization

Prerequisite

The synchronization settings are performed; refer to Section 4.2, “Creating a Synchronization 
Specification”.

Example of the "Synchronization" Window

Procedure

Proceed as follows:

Step Action

1 Go back to the "Synchronization" window.

If this window is already closed:

1. Start DS-Win Administration.

2. Select Database -> Synchronization. The "Synchronization" window 
opens.

2 Set in the "Synchronization" window:
● "Specification": Select the created specification.
● "Update mode": Select the required option.

– "Update data records": This option is required for an update synchroniza-
tion.

– "Fill table with new records": This option is required for an initial synchro-
nization.

3 Click Execute. The synchronization is performed. Status messages are displayed 
in the lower section of the "Synchronization" window. In addition, a status bar is dis-
played.
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4.5 Creating Time Schedule for Synchronization 

Overview

The synchronization with host computers can be performed time-scheduled in Microsoft Win-
dows Vista and Windows 7. For this purpose, you define time schedules to set synchronization 
intervals.

A time schedule defines dates of future synchronization processes. In contrast, a past period 
with changes of the data to be considered is defined in the "Synchronization" window.

Starting DS-Win Administration

Refer to Chapter 2, "Starting Administration".

Procedure

Proceed as follows:

> The "Task Scheduler" which is described here is a Windows application. In this sec-
tion, only those settings are described which are absolutely required for the time 
schedule. If you need more or different settings, you will find more information in the 
online help of the application.

Step Action
1 In the "DS-Win Administration" window: Select Database -> Synchronization. The 

"Synchronization" window opens.
2 Select the already defined specification in the "Synchronization" window under 

Specification (refer to Section 4.2, “Creating a Synchronization Specification”).
3 Click Schedule in the "Synchronization" window. The "Task Scheduler" window 

opens.

Note: You can also open the "Task Scheduler" window in Windows via Start -> 
Control Panel -> Administrative Tools -> Task Scheduler.

4 Click Create Task in the "Task Scheduler" window. The "Create Task" window 
opens. The "General" tab is displayed.

5 "General" tab:

1. In the "General" tab -> "Name" input field, enter a name for the new task resp. 
specification. Use the name of a previously defined specification; refer to 
Section 4.2, “Creating a Synchronization Specification”.

Note: The name of the specification must not include space characters becau-
se the Task Scheduler would read it like an attribute.

2. Select the Run whether user is logged on or not option.

3. Mark the Run with highest privileges check box.
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6 "Triggers" tab:

1. Click the Triggers tab. "Triggers" tab opens.

2. Click New. The "New Trigger" window opens.

3. In the "New Trigger" window:

a) Define the conditons and settings which must be used for the new task.

b) Confirm with OK.

The definitions are stored and are displayed in the "Triggers" tab.
7 "Actions" tab:

1. Click the Actions tab. The "Actions" tab opens.

2. Click New. The "New Action" window opens.

3. Define in the "New Action" window:

a) "Action": Start a program.

b) "Program/script": javaw.exe (Via Browse, e.g., "C:\Program Files 
(x86)\Java\jre7\bin\javaw.exe")

c) "Add arguments (optional)":
-jar dswautosync.jar <specification_name> <0 or 1>

<specification_name>: Name of the task resp. specification which 
shall be used to synchronize the data (displayed in the "Synchronization" 
window under "Specification")

<0 or 1>: 0 – "Update data records", 1 – "Fill table with new records" (dis-
played in the "Synchronization" window under "Update mode")

d) "Start in (optional)": Folder to which DS-Win was installed, e.g., c:\dswin

e) Confirm with OK.

The settings are saved and displayed in the "Actions" tab.
8 Click OK in the "Create Task" window. The new task is stored and added to the Task 

Scheduler Library.

Step Action
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4.6 «Export Table Client» Application

Overview

DS-Win V4 uses the "Export Table Client" application for the synchronization of data between 
DS-Win and the OpenScape 4000 Assistant/Manager.

The "Export Table Client" application can be directly started in Windows.

Procedure

Proceed as follows to start the "Export Table Client" application:

Further Information

Further information to „Import/Export API (XIE)“ can be found in: A31003-H3460-S100-*-**20, 
HiPath 4000 Manager V6, Import/Export Interface (XIE) API.

Step Action

1 Start the "Export Table Client" application via Start -> All Programs -> ... The "XIE 
Authentication dialog" window opens.

2 In the "XIE Authentication dialog" window:

1. Enter the server and user data:
– "Server": Enter the IP address for the OpenScape 4000 Manager Server 

in the IPv4 format.
– "Username": Enter a login name that includes XIE access permissions for 

OpenScape 4000 Manager Server.
– "Password": Enter the password for the login name.

Refer to A31003-G6640-S100-3-**20 DS-Win V4 Service Manual.

2. Confirm with OK. The "API Import/Export Client" window opens.
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5 Synchronization with HiPath User Management

Overview

The DS-Win Integration consists of the following features:

● Import of user data from an existing DS-Win.

● Import of address data from an existing DS-Win.

● Download of user and address data from HiPath User Management into an existing 
DS-Win database.

● Download of user and address data from HiPath User Management into a new DS-Win da-
tabase.

This chapter describes the required configurations in DS-Win and DirXmetahub for the syn-
chronization with HiPath User Management.

Contents

You find the following topics in this chapter:

Section 5.1, “Synchronization Scenarios with DS-Win”

Section 5.2, “Configuring DS-Win”

Section 5.3, “Configuring DirXmetahub for the DS-Win Integration”
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5.1 Synchronization Scenarios with DS-Win

Contents

The supported scenarios are described in the following sections:

Section 5.1.1, “Initializing of HiPath User Management with Data of DS-Win”

Section 5.1.2, “Expanding the HiPath User Management Database to Include DS-Win Data”

Section 5.1.3, “Synchronizing the DS-Win Data With HiPath User Management Data”

5.1.1 Initializing of HiPath User Management with Data of DS-Win

Overview

HiPath User Management is initialized with data of DS-Win in this scenario.

Procedure

Proceed as follows:

Step Action

1 Exporting of the DS-Win database as csv file by DS-Win:

1. Start the "DS-Win Administration".

2. Export the user table.

3. Export the address table.

Refer to Section 5.2.5, “Exporting DS-Win Data as CSV Files”.

2 Importing the csv files into HiPath User Management by DirXmetahub:

1. Start the "DirXmetahub" service.

2. Start the "Import-from-DSWin-Subscriber" metahub workflow.

3. Start the "Import-from-DSWin-Addresses" metahub workflow.

Note: To configure Metahub workflows: refer to Section 5.3.3, “Configuring the 
Workflow for Importing DS-Win Subscriber Data” and Section 5.3.4, “Configuring 
the Workflow for Importing DS-Win Address Data”.
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Further Processing

Synchronize the DS-Win data with the HiPath User Management data (refer to Section 5.1.3, 
“Synchronizing the DS-Win Data With HiPath User Management Data”).

3 Integrating the imported users (and addresses) by HiPath User Management:

1. Start HiPath User Management.

2. Select Tools -> Imported Users -> Match&Merge Imported Users. The 
"Match&Merge Imported Users" dialog opens.

3. Use Search to display the imported subscribers in the upper list. The imported 
users have the "Not Matched" status after the import.

4. Merge the imported users via Merge All Users -> Create new UM Users for 
all Users with status ’Unidentified’ and ’Not Matched’ status as new users. 
All imported users are created as new users in HiPath User Management.

A configuration request is generated for each of the imported users’ telephone 
numbers (see Resource icon in "Configuration Requests" column). This is mar-
ked as "primary" if there is a primary telephone number in the DS-Win data. In 
this case, a resource resulting from this is also marked as "primary".

5. Use Search to display the imported subscribers in the upper list. The imported 
users now have the "Matched" status.

6. Resolve the created configuration requests via Tools -> Resolve Configurati-
on Requests. If the resource can be found that fits to the telephone or fax num-
ber, this resource is assigned to the user, and the configuration request is dele-
ted.

If no resource could be found for a telephone or fax number, the configuration 
request cannot be resolved.

Step Action
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5.1.2 Expanding the HiPath User Management Database to Include 
DS-Win Data

Overview

In contrast to the case described in Abschnitt 5.1.1, HiPath User Management already has us-
ers in this scenario. In this case, you must perform the same steps as you did when initializing 
HiPath User Management with data from DS-Win. There is only a difference when incorporat-
ing the imported users into HiPath User Management.

A new user cannot be created in every case in HiPath User Management. Normally, in this sce-
nario the imported users are already assigned to existing users.

Procedure

Proceed as follows:

Step Action

1 Exporting of the DS-Win database as csv file by DS-Win:

1. Start the "DS-Win Administration".

2. Export the user table.

3. Export the address table.

Refer to Section 5.2.5, “Exporting DS-Win Data as CSV Files”.

2 Importing the csv files into HiPath User Management by DirXmetahub:

1. Start the "DirXmetahub" service.

2. Start the "Import-from-DSWin-Subscriber" metahub workflow.

3. Start the "Import-from-DSWin-Addresses" metahub workflow.

Note: To configure Metahub workflows: refer to Section 5.3.3, “Configuring the 
Workflow for Importing DS-Win Subscriber Data” and Section 5.3.4, “Configuring 
the Workflow for Importing DS-Win Address Data”.



ds-win_admin.c05.fm

A31003-G6640-M100-3-76A9, 08/2014
DS-Win V4, Administration Guide 5-5
       

Nur für den internen Gebrauch Synchronization with HiPath User Management
Synchronization Scenarios with DS-Win

Further Processing

Synchronize the DS-Win data with the HiPath User Management data (refer to Section 5.1.3, 
“Synchronizing the DS-Win Data With HiPath User Management Data”).

3 Assigning the imported users to the already existing users in the HiPath User Man-
agement:

1. Start HiPath User Management.

2. Select Tools -> Imported Users -> Configure Match&Merge Rules, and set 
the assignment with first name and last name.

A script can also be implemented if there are additional parameters that support 
unique assignment.

3. Automatically assigning all imported users to the existing users based on the set 
rules:

a) Select Tools -> Imported Users -> Match&Merge Imported Users.

b) Select Merge All Users and Match and Merge all Users predefined 
Rules options.

4. Refresh the imported users list by a new search. The users may have the follo-
wing states:
– Unidentified

This status indicates that the imported user could not be assigned. These 
users can either be created as new users or assigned manually to an exis-
ting user with "Match Users". In the case of manual assignment to an exis-
ting user, the user would adopt the status Conflicting if there are impor-
ted attributes that are defined for the respective user but that do not match.

– No Conflicting
Users with this status could be assigned. There are no conflict attributes.

– Conflicting
Users with this status could also be assigned, but there are conflict attribu-
tes that are marked with a red frame. The "Resolve Conflict" dialog will be 
used to decide whether the imported attributes should be accepted or the 
existing attributes should be retained.

5. Manually assign the users based on their status.

4 To merge all imported users, click Merge All Users. You can also specify which us-
ers shall be merged in which status and which form of conflict handling. For instance, 
it is possible to transfer imported attributes for all users with conflicts.

Step Action
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5.1.3 Synchronizing the DS-Win Data With HiPath User Management 
Data

Overview

In this scenario, data is incorporated into DS-Win from User Management. If the DS-Win data-
base is empty at this point in time, all users and addresses are created as new in DS-Win.

If users exist that were already incorporated from DS-Win and if these were changed in the 
meantime, this change will be adopted in DS-Win using this synchronization procedure. Any 
users or addresses that are not yet known will be created as new users or addresses in DS-Win 
in the process.

Procedure

Proceed as follows:

> The attribute names in the first column must not contain the name of the table. Thus, 
the name of the table has to be removed. As an example, "City" instead of "Subscrib-
er.City" can be used.

Step Action

1 Start the "Download_To_DSWin" metahub workflow.

Note: To configure the Metahub workflow: refer to Section 5.3.5, “Configuring the 
Workflow for Download to DS-Win”.
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5.2 Configuring DS-Win

Contents

You find the following topics in this section:

● Section 5.2.1, “Expanding the DS-Win Database”

● Section 5.2.2, “Creating the Export Specification for the «Subscriber» Table”

● Section 5.2.3, “Creating the Export Specification for the «Address» Table”

● Section 5.2.4, “Filling-In Customer-Specific Fields in DS-Win”

● Section 5.2.5, “Exporting DS-Win Data as CSV Files”

● Section 5.2.6, “Configuring the ODBC Data Source”
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5.2.1 Expanding the DS-Win Database

Overview

This section describes the expansions in the DS-Win database that are required for integration 
with HiPath User Management.

You can only make changes to the table definition in DS-Win for empty tables. Therefore, you 
will first need to export the data, empty the table, change the definition and then reimport the 
data.

Procedure

Proceed as follows:

> If you are using an empty DS-Win database as a basis, it will not be necessary to 
export and import the user data. Remember to back up the database first.

Step Action

1 Start the "DS-Win Administration" application. The main view of the application 
opens.

2 Create a database specification called ExportSubscriber4DBUpdate (refer to 
Section 5.2.2, “Creating the Export Specification for the «Subscriber» Table”).

3 Exporting the "Subscriber" table:

1. Click Database -> Export Data.

2. Select the specification called ExportSubscriber4DBUpdate.

3. Select a file name.

4. Click Run.

5. Verify that the exported file contains the correct data.

4 Empty the "Subscriber" table:

1. Select the "Subscriber" table and click Open.

2. Open the Edit Data: Subscriber dialog.

3. Click Empty Table and confirm the advisory messages.

4. Leave the dialog by Close.

5 In the main view of the "DS-Win Administration" application, make sure that the 
"Subscriber" table is still selected and click Draft.
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Further Processing

Refer to Section 5.2.2, “Creating the Export Specification for the «Subscriber» Table”.

6 In the Edit Table Structure: Subscriber dialog:

1. Scroll down through the fields in table view until you reach the IntNetcode field 
and change the "Field Length" property from 16 to 30.

2. Scroll down through the fields in table view until you reach the AltNetcode field 
and change the "Field Length" property from 16 to 30.

3. Scroll down through the fields in table view until you reach the MobNetcode 
field and change the "Field Length" property from 16 to 30.

4. Scroll down through the fields in table view until you reach the FaxNetcode field 
and change the "Field Length" property from 16 to 30.

5. At the end of the table, add a new field umuid with the "Field Type" Text and 
the "Field Length" 50.

6. Click Save and close the dialog.

7 Reimporting the exported data again:

1. Select the Database -> Import Data menu item.

2. Select the specification named ExportSubscriber4DBUpdate.

3. Select the file name of the exported file.

4. Click Run.

Step Action
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5.2.2 Creating the Export Specification for the «Subscriber» Table

Overview

The export specification is used to import the "Subscriber" table.

Procedure

Proceed as follows:

Further Processing

Refer to Section 5.2.3, “Creating the Export Specification for the «Address» Table”.

Step Action

1 Start the "DS-Win Administration" application. The main view of the application 
opens.

2 Select the Database -> Export Data menu item. The „Export Data“ dialog opens.

3 Click Define. The "Import/Export settings“ dialog opens.

4 Defining the settings for the export specification:

1. Select the Subscriber item in the "Table" drop-down list.

2. Enter a file name into the "Import Log File" input field (e.g. ExportSubscri-
berError.txt), which will be used in the event of an error to write an error file.

3. Click Save As and enter the specification name in the following dialog. Confirm 
with OK.

5 Click Close twice to return to the main view of the application.
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5.2.3 Creating the Export Specification for the «Address» Table

Overview

To import data from the address table, you will need to create an appropriate export specifica-
tion as you did for the subscriber table.

Procedure

Proceed as follows:

Further Processing

Refer to Section 5.2.4, “Filling-In Customer-Specific Fields in DS-Win”.

Step Action

1 Start the "DS-Win Administration" application. The main view of the application 
opens.

2 Select the Database -> Export Data menu item. The "Export Data" dialog opens.

3 Click Define. The "Import/Export settings" dialog opens.

4 Defining the settings for the export specification:

1. Select the Address item in the "Table" drop-down list.

2. Enter a file name into the "Import Log File" input field (e.g. ExportAddress-
Error.txt), which will be used in the event of an error to write an error file.

3. Click Save As and enter the specification name in the following dialog. Confirm 
with OK.

5 Click Close twice to return to the main view of the application.

> If other fields that deviate from the default configuration occur in the "Address" table, 
you will also need to delete the relevant lines when creating the export specification.
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5.2.4 Filling-In Customer-Specific Fields in DS-Win

Additional fields in the DS-Win database that deviate from the standard DS-Win configuration 
(so-called customer-specific fields) are not filled with the import files provided by default by 
HiPath User Management (also refer to the advisory notes in Section 5.2.2 and Section 5.2.3).

If the fields still need to be filled in, this can only be done by making the appropriate changes 
to the DirX-Metahub workflow available on the HiPath User Management data server.

5.2.5 Exporting DS-Win Data as CSV Files

Overview

The data must be available in CSV format (with the separator « ; ») for import into HiPath User 
Management.

The subscriber and address tables have to be exported separately from DS-Win. If you are us-
ing an empty DS-Win database as a basis, you can skip this step.

Exporting the Subscriber Table

Proceed as follows:

Step Action

1 Open the "DS-Win Administration" application.

2 Create a database specification named "ExportSubscriber4HPMUM" (refer to 
Section 5.2.2, “Creating the Export Specification for the «Subscriber» Table”).

3 Exporting the subscriber table:

1. Select Database -> Export Data.

2. Select the ExportSubscriber4HPMUM specification.

3. Enter a file name.

4. Click Run.
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Exporting the Address Table

Proceed as follows:

Further Processing

Refer to Section 5.2.6, “Configuring the ODBC Data Source”.

5.2.6 Configuring the ODBC Data Source

Overview

For synchronization, DirXmetahub requires access to the DS-Win V4 data source. This access 
is achieved by ODBC via the database used in DS-Win V4. This section describes the admin-
istration of the ODBC entry.

Procedure

Proceed as follows:

Step Action

1 If necessary, open the "DS-Win Administration" application.

2 Create a database specification named "ExportSubscriber4HPMUM". (refer to 
Section 5.2.2, “Creating the Export Specification for the «Subscriber» Table”).

3 Exporting the address table:

1. Select Database -> Export Data.

2. Select the ExportAddress4HPMUM specification.

3. Enter a file name.

4. Click Run.

Step Action

1 Click Settings -> Control Panel -> Administration Tools in the Windows Start 
menu and start the ODBC Data Source Administrator. The "ODBC Data Source Ad-
ministrator" opens.

2 Select the System DSN tab and click Add.

3 Select the database from the list (e.g., PostgreSQL Unicode) and click Configure. 
The "PostgreSQL Unicode ODBC Driver (psqlODBC) Setup" dialog opens.
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4 Performing the following database settings in the "PostgreSQL Unicode ODBC Driv-
er (psqlODBC) Setup" dialog:

1. Enter the DSWin data source into the "Data Source" input field; and enter the 
settings defined in the database configuration for the "Database", "Server", 
"User Name" and "Password" input fields.

2. Click Test to check if the database settings are correct.

3. Select the disable setting in the "SSL Mode" field, and enter the database 
portnumber into the "Port" field.

4. Click Save to save the settings.

5 Set the advanced options to configure the data source in the "PostgreSQL Unicode 
ODBC Driver (psqlODBC) Setup" dialog:

1. Click Datasource to open the advanced options for database configuration. The 
"Advanced Options (DSWin) 1/2" dialog opens.

2. Click Page 2. The second page of the "Advanced Options (DSWin) 2/2" dialog 
opens.

● Mark the LF <-> CR/LF conversion and Updatable Cursors check boxes.

● Select the default option in the "Int8 As" area, and the 7.4+ option in the 
"Protocol" area.

● Enter the database name into the "Connect Settings" input field.

6 Click OK to close the "Advanced Options (DSWin) 1/2" dialog.

7 Click Save to close the "PostgreSQL Unicode ODBC Driver (psqlODBC) Setup" di-
alog.

8 Click OK to close the "ODBC Data Source Administrator" dialog. The ODBC config-
uration is completed.

Step Action
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5.3 Configuring DirXmetahub for the DS-Win Integration

Overview

This section describes the configurations of DirXmetahub that are required for setting up a syn-
chronization with DS-Win.

Contents

You find the following topics in this section:

Section 5.3.1, “Creating a New Scenario”

Section 5.3.2, “Configuring the Connected Directories”

Section 5.3.3, “Configuring the Workflow for Importing DS-Win Subscriber Data”

Section 5.3.4, “Configuring the Workflow for Importing DS-Win Address Data”

Section 5.3.5, “Configuring the Workflow for Download to DS-Win”

7 Backup the existing configuration before you start the configuration.

7 To prevent customizations from being lost when the software is updated, you must 
make a copy of all objects before performing the customizations. Customizations 
must be performed on the copy.
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5.3.1 Creating a New Scenario

Create a new scenario in the "Global View" (unless you have already done so for another syn-
chronization) and assign an appropriate name to it.

5.3.2 Configuring the Connected Directories

Overview

You will need to create the relevant "connected directories" for access from the various data 
sources.

Procedure

Proceed as follows to configure the connected directories:

Step Action

1 Switch to the scenario which you created.

2 Creating a new connected directory:

1. Right-click in the scenario. The context menu opens.

2. Select New Connected Directory in the context menu, and create a new con-
nected directory based on the relevant template:
– Connected Directories for Accessing Subscriber and Address Files:

S-Win-Subscriber resp. DS-Win-Addresses
– Connected Directory for Accessing the HiPath User Management Directory:

Hipath UM
– Connected Directory for ODBC access to the DS-Win database:

DS-Win

3 Configuring a new connected directory:

1. Right-click the new connected directory. The context menu opens.

2. Select Configure in the context menu. The configuration dialog opens.

4 Configure the relevant connected directory as described in the following paragraphs:
● Connected Directories for Accessing Subscriber and Address Files
● Connected Directory for Accessing the HiPath User Management Directory
● Connected Directory for ODBC access to the DS-Win database
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Connected Directories for Accessing Subscriber and Address Files

These connected directories are used to access the subscriber and address data which were 
exported from DS-Win. Perform the following settings:

● General Information:

– Name and Description

● Attribute Configuration: Here you can enter additional attributes. This is required if you 
have extended your DS-Win database to include additional fields. Make sure that a ";" is 
normally entered as a suffix and that "\012" must be entered in the last field of the csv file.

● File Parameter: Name of the file

Connected Directory for Accessing the HiPath User Management Directory

This connected directory is used to access the HiPath User Management directory. Perform the 
following settings:

● General Information:

– Name and Description

All other settings are retained.

Connected Directory for ODBC access to the DS-Win database

This directory is used to access the DS-Win database. Perform the following settings:

● General Information:

– Name and Description

– DSN !Where is: DSN: Data Source Name. Enter the name of the ODBC data source 
(refer also to Section 5.2.6, “Configuring the ODBC Data Source”).

● Attribute Configuration: Here you can configure additional attributes if you expanded the 
DS-Win database definition. You must always use the following structure in the Name co-
lumn: <table name>.<field name>.

● Bind Profile: Enter a user with the associated password. This user must have the relevant 
write permissions for the DS-Win database.
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5.3.3 Configuring the Workflow for Importing DS-Win Subscriber Data

Overview

This metahub workflow is used to import subscriber data from a CSV file exported by DS-Win. 
The workflow will be configured based on the "Import-from-DSWin-Subscriber" template.

If the imported file is not located on the local computer, you will need to run the workflow under 
an account, which has the appropriate network authorizations. To do this, follow the configura-
tion instructions for accessing the DirXmetahub Service on network resources; refer to Service 
Manual HiPath User Management V3, P31003-H2730-S100-*-**20).

Procedure

Proceed as follows to configure the workflow:

"Import-from-DSWin-Subscriber" Template

You find here a description of the settings which are included in the "Import-from-DSWin-Sub-
scriber" template, and notes to set it:

● General Information:
You can select a suitable name and a corresponding description for the workflow.

● Source Selected Attributes:
You can add or delete attributes that are to be read out of the csv file. The SubscriberID 
attribute must not be deleted under any circumstances as it is used as a key attribute for 
synchronization.

It is important that the sequence of attributes exactly matches the sequence in the CSV file 
(and thus matches the sequence in the export definition of DS-Win; refer to Section 5.2.5, 
“Exporting DS-Win Data as CSV Files”).

● Target Selected Attributes:
You can add or delete attributes that are to be written to the HiPath User Management di-
rectory. The selected attributes are shown in the column on the right. The ApplLocali-
tyId attribute is mandatory for synchronization; therefore it must not be deleted under any 
circumstances.

Step Action

1 Open the "Import-from-DSWin-Subscriber" template. A configuration steps list 
opens (description of the configuration steps, refer to «"Import-from-DSWin-Sub-
scriber" Template» section).

2 Configure the template.
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● Attribute Mapping for Subscriber Data:
You can adjust the assignment of the fields from the CSV file to the relevant fields in the 
HiPath User Management directory to your requirements. The assignment of the Sub-
scriberID to the ApplUserId must never be changed or deleted as these are the key 
attributes for synchronization. Nor shall the assignment of Address to ApplLocalityID 
shall be changed.

By assigning a telephone number in the PrimeryPhoneNumber field, HiPath User Ma-
nagement is instructed to set the associated resource as the primary resource.

● Import Properties:
No modifications shall be made here.

● Import Tracing:
You can specify the settings for tracing the import of locality data to the DS-Win database 
here.

5.3.4 Configuring the Workflow for Importing DS-Win Address Data

Overview

This metahub workflow is used to import address data from a csv file exported by DS-Win into 
HiPath User Management. The workflow adds the attributes stored in the address table to the 
previously imported subscribers.

The workflow is configured based on the "Import-from-DSWin-Addresses" template.

Procedure

Proceed as follows to configure the workflow:

Template „Import-from-DSWin-Addresses“

In this section, you find a description of the settings which are included in the "Im-
port-from-DSWin-Addresses" template, and notes to configure it:

● General Information:
You can select a suitable name and an appropriate description for the workflow.

Step Action

1 Open the "Import-from-DSWin-Addresses" template. A configuration steps list 
opens (description of the configuration steps, refer to «Template „Im-
port-from-DSWin-Addresses“» section).

2 Configure the template.
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● Source Selected Attributes:
You can add or delete attributes that are to be read out of the csv file. The Address attri-
bute must not be deleted under any circumstances as it is used as a key attribute for syn-
chronization and is also required when searching for a user associated with an address.

It is important that the sequence of the selected attributes exactly matches the sequence 
in the CSV file (and thus matches the sequence in the export definition of DS-Win; refer to 
Section 5.2.5, “Exporting DS-Win Data as CSV Files”).

● Target Selected Attributes:
You can add or delete attributes that are to be written to the HiPath User Management di-
rectory. The selected attributes are shown in the column on the right. The ApplLocali-
tyId attribute is mandatory for synchronization; therefore it must not be deleted under any 
circumstances.

● Attribute Mapping for Locality:
You can adjust the assignment of the fields from the CSV file to the relevant fields in the 
HiPath User Management directory to your requirements. The assignment of the address 
to ApplLocalityID must never be changed or deleted as these are the key attributes for 
synchronization.

● Import Properties:
No modifications shall be made here.

● Import Tracing:
You can specify the settings for tracing the import of the locality data into the DS-Win da-
tabase.
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5.3.5 Configuring the Workflow for Download to DS-Win

Overview

This workflow is used for synchronizing user and locality data from HiPath User Management 
with the DS-Win database. The workflow will be configured based on the 
"Download_to_DSWin" template.

Procedure

Proceed as follows to configure the workflow:

"Download_to_DSWin" Template

In this section, you find a description of the settings which are contained in the 
"Download_to_DSWin" template, and how they have to be set:

● General Information:
You can select a suitable name and a corresponding description for the workflow.

● DirXmetahub Server:
Do not change the settings (main as DirXmetahub Server).

● Source Selected Attributes For Locality:
You can add or delete attributes that are to be read from the HiPath User Management di-
rectory locality tree. The applLocalityId and cdsSyncAllowed attributes must not be 
deleted under any circumstances.

Step Action

1 Open the "Download_to_DSWin" template. A configuration steps list 
opens (description of the configuration steps, refer to paragraph 
«"Download_to_DSWin" Template»).

2 Configure the template that it contains the following steps:

1. Exporting the locality data from the HiPath User Management directory.

2. Importing the locality data to the address table of the DS-Win database.

3. Exporting the subscriber IDs stored in the DS-Win database (key attributes for 
accessing the subscriber table).

4. Exporting user data from the HiPath User Management directory and finding 
entries to be deleted in DS-Win with the aid of previously read subscriber IDs.

5. Importing user data to the DS-Win subscriber table.
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● Export Properties For Locality:
With the exception of the "Filter" field, the settings must not be changed. You can exclude 
specific locality objects from the synchronization with DS-Win by setting an appropriate fil-
ter (LDAP notation).

● Target Selected Attributes For Locality:
You can add or delete attributes that are to be written to the DS-Win database. The selec-
ted attributes are shown in the column on the right. The Delete-In-ODBC attribute cont-
rols whether or not an entry is to be deleted from the DS-Win database and must not be 
deleted under any circumstances. The Address attribute must not be deleted because it 
acts as a key field for accessing the address table.

● Attribute Mapping for Locality:
You can adjust the assignment of the User Management locality attributes to the relevant 
fields in the DS-Win database to your own requirements. The assignment of the applLo-
calityId to Address must not be changed or deleted under any circumstances because 
this would cancel the assignment of entries.

● Import Properties for Locality:
You can specify how the data is to be written to the DS-Win database. The Table, Select 
By, Create IF Absent, Insert Only, Relationships, Always Follow Refe-
rences, Modify Anyway and Change Type fields shall not be changed.

In the Modify field, you can enter the other fields that are to be written to the DS-Win da-
tabase.

● Export Tracing For Locality:
You can specify the settings for tracing the export of the locality data from the HiPath User 
Management directory.

● Import Tracing For Locality:
You can specify the settings for tracing the import of the locality data into the DS-Win da-
tabase.

● Delta Handling:
To perform a full download, you just have to unmark the "delta handling" checkbox. For a 
delta workflow, you have to mark this checkbox and set Delta Type to File and Chan-
ges Since to Recent. You also have to set the operational properties for a delta synchro-
nization.

● DS-Win Export Tracing for Users:
You can specify the settings for tracing the export of the subscriber IDs from the DS-Win 
database.

● Source Selected Attributes For Users:
You can add or delete attributes that are to be read from the HiPath User Management di-
rectory user tree. The applLocalityId, applUserId and cdsSyncAllowed attributes 
must not be deleted under any circumstances.
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● Export Properties For Users:
The settings must not be changed except for the Filter field. You can exclude specific 
users from the synchronization with DS-Win by setting an appropriate filter (LDAP notati-
on).

● Target Selected Attributes For Users:
You can add or delete attributes that are to be written to the DS-Win database. The selec-
ted attributes are shown in the column on the right. The Delete-In-ODBC attribute cont-
rols whether or not an entry is to be deleted from the DS-Win database and must not be 
deleted under any circumstances.
The Subscriber.Address field is required for correctly linking the subscriber to the 
address table. In the same way, the Subscriber.SubscriberID attribute must not be 
deleted because it acts as a key field for accessing the subscriber table.

● Attribute Mapping for Users:
You can adjust the assignment of the User Management locality attributes to the relevant 
fields in the DS-Win database to your own requirements. The assignment of the applU-
serId to SubscriberID must not be changed or deleted under any circumstances be-
cause this would cancel the assignment of entries. If locality data is also to be synchroni-
zed, the assignment of the applLocalityId to Subscriber.Address must not be 
changed.

● DS-Win Import Properties for Users:
You can specify how the data is to be written to the DS-Win database. The Table, Select 
By, Create IF Absent, Insert Only, Relationships, Always Follow Refe-
rences, Modify Anyway and Change Type fields shall not be changed.

In the Modify field, you can enter the other fields that are to be written to the DS-Win da-
tabase.

● Operation for Users:
You can set whether all users or only those users that were modified since completion of 
the last workflow are to be processed.

Disable the "Delta Synchronization" checkbox for a complete synchronization.

Set this checkbox for a delta synchronization. In addition, you must set Delta type to 
Date and Changes since to recent. In the case of a delta synchronization, both new 
and modified users are adopted accordingly in the DS-Win database. Deleted users are 
not removed from the DS-Win database.

● Export Tracing For Users:
You can specify the settings for tracing the export of the locality data from the HiPath User 
Management directory.

● Import Tracing For Users:
You can specify the settings for tracing the import of the locality data into the DS-Win da-
tabase.
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6 Synchronization By Export/Import of a Text File

Overview

The synchronization of the DS-Win database with the database of a communication system 
can be also performed by exporting the data from the database, manually changing the export-
ed file, and the following import of the changed file.

Contents

You find the following topics in this chapter:

Section 6.1, “General Description of the Data Transfer”

Section 6.2, “Creating Synchronization Specification”

Section 6.3, “Exporting Data”

Section 6.4, “Editing Data”

Section 6.5, “Importing Data”

6.1 General Description of the Data Transfer

A database was created as an example during the installation of DS-Win V4 (refer to 
A31003-G6640-S100-3-20, DS-Win V4 Service Manual -> 3.3.1  "Creating a PostgreSQL Ex-
ample Database From the Installation Data" and 3.3.2  "Creating Example Database Via Exist-
ing Database Server"). This database is still empty and can be manually filled via an XML editor 
like Notepad++, and then imported by initial synchronization into DS-Win V4.

You usually synchronize the subscriber data.
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6.2 Creating Synchronization Specification

A synchronization specification which is used to create an editable file is required for the export 
and the import of the database data.

Example for the "Import/Export settings" window

Prerequisite

The DS-Win Administration was started. Refer to Chapter 2, "Starting Administration".

Procedure

Proceed as follows:

Step Action

1 Select in the "DS-Win Administration" window: Database -> Export data. The "Ex-
port data" window opens.

2 Click Define in the "Export data" window. The "Import/Export settings" window 
opens.

3 In the "Import/Export settings" window, the settings must be done in this manner 
that the exported file can be edited. Refer to 3a - 3d.

3a The following settings are recommended:
● "File type": Windows (ANSII)
● "Text separator": "
● "Field delimiter": ;
● "Table": Subscriber (for the subscriber synchronization)
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Further Processing

Refer to Section 6.3, “Exporting Data”.

3b ● "File format" area:

– Select Field separators

– Activate Field names in first line

3c ● In the table: Define whether certain entries can be ignored or must be filled by 
data. This depends on which data of the communication system’s database 
shall be used to fill the DS-Win database.

3d ● "Import log file": Define the name of the error file.

4 Click Save as. The "Save specification" window opens.

5 Enter the name of the specification in the "Save specification" window, e.g., 
Text_Import-Export, then click OK. The specification is saved, and the "Im-
port/Export settings" window opens again.

6 Click Cancel in the "Import/Export settings" window. This window is closed; and the 
"DS-Win Administration" window remains open.

Step Action
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6.3 Exporting Data

Prerequisites

● A synchronization specification for the data export was created, refer to Section 6.2, “Cre-
ating Synchronization Specification”.

● The DS-Win Administration was started, refer to Chapter 2, "Starting Administration".

Procedure

Proceed as follows:

Step Action

1 In the "DS-Win Administration" window: Select Database -> Export data. The "Ex-
port data" window opens.

2 Perform the following settings in the "Export data" window:

1. To fill the "File name" field:

a) Click Browse. The "Open" window opens.

b) Select a directory in the "Open" window into which you want to save the 
file to be exported, enter a file name, and click Open.
The "Export data" window opens again.

2. In the "Specification" drop-down list, select the created specification which 
shall be used for the synchronization by text file (refer to Section 6.2, “Creating 
Synchronization Specification”).

3 Click Execute in the "Export data" window. The DS-Win database data are export-
ed into the defined text file.

4 Open the exported text file with an editor, e.g., Notepad++, and check if this text file 
is similar to the text file example which is described in the following part of this sec-
tion.
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Example for an Exported Text File

The content of the exported text file is similar to the following example if you have performed 
your settings as described above (refer to Section 6.2, “Creating Synchronization Specifica-
tion”):

The content of this file depends on the content of the DS-Win database and your settings.

6.4 Editing Data

Forward the exported text file to the person who edits the data, e.g., the administrator of the 
customer.

If you have performed your settings as described above (refer to Section 6.2, “Creating Syn-
chronization Specification”), pay attention to the following points to edit the data:

● The names of the fields are in the first line of the exported text file.

● The fields are divided by semicolon (;). These delimiters must not be changed.

● You must only edit between the two " " characters which are used to delimit the text, e.g., 
for the field "firstname": "" -> "Mario".
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6.5 Importing Data

Prerequisites

● You have got back the text file, and it was correctly edited.

● The DS-Win Administration is started, refer to Chapter 2, "Starting Administration".

Procedure

Proceed as follows:

Step Action

1 Open the edited text file in an editor, e.g. Notepad++, and check if the data are cor-
rect (refer to the description in Section 6.4, “Editing Data”).

2 Select Database -> Import data in the "DS-Win Administration" window. The "Im-
port data" window opens.

3 Perform the following settings in the "Import data" window:

1. To fill the "File name" field:

a) Click Browse. The "Open" window opens.

b) Select the directory in the "Open" window into which you have saved the 
file to be imported, select the file, and click Open.
The "Import data" window is displayed again.

2. In the "Specification" drop-down list, select the created specification which 
shall be used for the synchronization by text file (refer to Section 6.2, “Creating 
Synchronization Specification”).

3. Select Fill table with new records to perform the initial synchronization.

4 Click Execute in the "Import data" window. The data from the text file are imported 
into the DS-Win database. A progress bar is displayed and then a message apears 
which indicates the correct import.

5 If you have synchronized the subscriber data: Open DS-View. Check if the imported 
subscriber data are displayed in this application.
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7 Setting Up Presence Management

Overview

In order to provision DS-Win V4 with Presence functionality, DS-Win V4 must work together 
with a mail server. DS-Win V4 can be used with Lotus Domino, Outlook 2003, WebDAV, 
Exchange 2007, and Exchange 2010. Depending on which mail server DS-Win V4 is working 
with, different settings are needed.

DS-Win V4 can either be installed on the same server where the mail server is installed or on 
a different server. If DS-Win V4 and the mail server are installed on different servers, DS-Win 
V4 must be able to access the mail server, i.e., both servers must be in the same network.

For subscribers whose presence information is to be visible, the database table and the respec-
tive columns containing the e-mail information must be specified on the Presence Management 
tab in the settings of DS-Win V4.

Contents

You find the following topics in this chapter:

● Section 7.1, “Setting Up Exchange 2007/2010 Servers and DS-Win V4”

● Section 7.2, “Setting up Lotus Domino Server 8.5 and DS-Win V4”
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7.1 Setting Up Exchange 2007/2010 Servers and DS-Win V4

Overview

The following sections describe the configuration of DS-Win V4 for Presence Management 
when it works with the Exchange Servers 2007 and 2010

Contents

This section contains the following topics:

Section 7.1.1, “Installing the Exchange Servers 2007/2010”

Section 7.1.2, “Configuring DS-Win V4”

7.1.1 Installing the Exchange Servers 2007/2010

Installation

Proceed as follows:

Exchange Server 2010

For Exchange Server 2010, the configuration is similar but not identical with the configuration 
of Exchange Server 2007. Via Exchange Web Services API (EWS), client applications commu-
nicate with the Exchange Server. The EWS provides access to most of the same data that is 
available by Microsoft Office Outlook.

The following settings are required for Presence Management in DS-Win:

● enable on Exchange Server:

– Client Access role

– Autodiscover Service

– Availability Service

● and configure the DS-Win client

Testing the Exchange Server 2010 settings:
Because Outlook Web Access (OWA) also needs these services, configure OWA and test it. If 
OWA is enabled and works, DS-Win should also work.

Step Action

1 Install Exchange Server 2007 or 2010 on a suitable Windows server:
● Exchange 2007: e.g., Windows Server 2003, Windows Server 2008
● Exchange 2010: e.g., Windows Server 2008
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7.1.2 Configuring DS-Win V4

In order to configure DS-Win V4 to work with an Exchange Server, proceed as follows:

Step Action

1 Open Start -> Programs -> DS-Win V4 -> DS-Win and log in as administrator.

2 Open the Options -> Application Settings -> Presence Management tab.

3 Enable the Use Presence Management check box on the Presence Manage-
ment tab.

4 Enable one of the Exchange 2007 or Exchange 2010 radio buttons in the "Pres-
ence Management type" area.

5 Enter the database table and the database column containing the e-mail informa-
tion of the subscribers:

1. In the "Data source" field, enter the name of the database table, 
e.g., Subscriber.

2. In the "Account field", enter the database column, e.g., email.

6 In the "Server Settings" area, fill in the authentication information of the Windows 
server on which the Exchange Server is installed:

1. Enter the login name of the Windows Server (e.g., Administrator) in the 
"User ID" field.

2. Enter the password of the Windows Server in the "Password" field.

3. Enter the IP address of the Windows Server, (e.g., 192.168.1.74) in the Ex-
change server" field. If DS-Win V4 and the Exchange Server are installed on 
the same server, then 127.0.0.1 must be entered as the IP address.

4. Enter the domain name of the Windows Server, e.g., exc2007.com in the 
"Domain" field (can be determined via Computer -> [right mouse click] Prop-
erties -> <Computer Name> -> Domain).

7 Click OK. Your entries are saved.
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7.2 Setting up Lotus Domino Server 8.5 and DS-Win V4

Overview

The following paragraphs describe the installation of Lotus Domino Server 8.5 and the config-
uration of DS-Win V4 for Presence management.

Contents

This section contains the following topics:

Section 7.2.1, “Installing Lotus Domino Server 8.5”

Section 7.2.2, “Configuring Lotus Domino Server 8.5”

Section 7.2.3, “Configuring DS-Win V4”

7.2.1 Installing Lotus Domino Server 8.5

Proceed as follows:

Further Processing

Refer to Section 7.2.2, “Configuring Lotus Domino Server 8.5”.

7.2.2 Configuring Lotus Domino Server 8.5

The SMTP Server must be configured on the Lotus Domino Server 8.5. To do this, proceed as 
follows:

Step Action

1 Install Lotus Domino Server 8.5 on a suitable Windows server, e.g., Windows 2003 
Server. After the standard installation, some additional settings are required on the 
Domino Server.

Step Action

1 Edit the notes.ini file:

1. Open the notes.ini file on the Windows Server (e.g., under C:\Program 
Files\IBM\Lotus\Domino\notes.ini for an English operating system).

2. Add the line ServerTasks=SMTP to the notes.ini file.

3. Save and close the file.
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2 Open the Services window with Start -> Run -> services.msc -> OK and stop 
the Domino Server.

3 Load SMTP:

1. Open the Domino console by opening the scontroller.exe file (e.g.,  
C:\Program Files\IBM\Lotus\Domino\scontroller.exe for an Eng-
lish operating system.

2. Enter the Load smtp command in the "Domino Command" field.

3. Click Send.

4. Close the Domino console.

4 Start the Domino Server in the Services window.

5 Configure the Domino Server:

1. Open the Internet Explorer and enter http://<IP address of Domino 
server>/names.nsf in the address bar (e.g., http://192.168.1.78/
names.nsf).

2. Enter the user name and password for the Domino Server (assigned on instal-
lation of the Domino server). The user interface of the names.nsf file is dis-
played ("Domino Directory/Add Person" window).

3. Select Configuration -> Servers -> All Server Documents in the "Domino Di-
rectory" pane on the left. The "Domino Directory/Add Server, Web, Search" 
window with the list of servers is displayed.

4. Enable the check box of the server you want to configure. A window with the 
"Domino Directory", "Edit Server", "Create Web" and "Cancel" headers ap-
pears with tabs such as "Basics", "Security", "Ports", etc.

5. On the Basics tab, set the SMTP listener task entry to Enabled.

6 Configure Lotus Notes:

1. Open Lotus Notes with Start -> Programs -> Lotus Applications -> 
Lotus Notes 8.5.

2. Configure a meeting with the Lotus calendar.

7 Open the Services window with Start -> Run -> services.msc -> OK and stop 
the Domino Server.

Step Action
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Further Processing

Refer to Section 7.2.3, “Configuring DS-Win V4”.

7.2.3 Configuring DS-Win V4

In order to configure DS-Win V4 to work with Lotus Domino Server  8.5, proceed as follows:

8 Validate the task scheduler on the Domino server database:

1. Open the Domino console by opening the scontroller.exe file (e.g., from  
C:\Program Files\IBM\Lotus\Domino\scontroller.exe for an Eng-
lish operating system).

2. Enter the command tell sched validate in the "Domino Command" field 
and click Send. All users and all scheduled items in the database are validated.

3. Enter the command tell sched validate <user name>/<domain> in 
the "Domino Command" field and click Send. All scheduled items for the spec-
ified user are validated in the database.

9 Start the DIIOP server:

1. Enter the Load DIIOP command in the "Domino Command" field.

2. Click Send. The DIIOP server is initiated.

Step Action
1 Open Start -> Programs -> DS-Win V4 -> DS-Win and log in as an administrator.

2 Open the Options -> Application Settings -> Presence Management tab.

3 Enable the Use Presence Management check box on the Presence Manage-
ment tab.

4 Enable the Lotus radio button in the "Presence Management type" area.

5 Enter the database table and column containing the e-mail information of the sub-
scribers:

1. In the "Data source" field, enter the name of the database table, e.g., Sub-
scriber.

2. In the "Account field", enter the database column, e.g., email.

Step Action
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6 Enter the Lotus Domino Server 8.5 authentication information in the "Lotus Server 
Settings" area:

1. In the "User ID <Name>/<Organization>" field, enter the user name of the 
e-mail address to be used by DS-Win V4 for sending e-mails.

2. Enter the password of the user entered in the preceding step in the "Password" 
field.

3. Enter the IP address and port of the Domino Server, (e.g., 
192.168.1.78:63148) in the "Domino IIOP Server <IP number>:<Port>" 
field. If the Domino Server was installed with the default settings, the port is 
63148.

7 Click on the OK button. Your entries are saved.

Step Action



Setting Up Presence Management Nur für den internen Gebrauch

 A31003-G6640-M100-3-76A9, 08/2014
7-8 DS-Win V4, Administration Guide

      

Setting up Lotus Domino Server 8.5 and DS-Win V4



ds-win_admin.c07.fm

A31003-G6640-M100-3-76A9, 08/2014
DS-Win V4, Administration Guide 8-1
       

Nur für den internen Gebrauch Setting up the E-mail Feature

8 Setting up the E-mail Feature

Overview

In order to use the e-mail feature, DS-Win V4 must work together with an e-mail server. For 
DS-Win V4, "Exchange 2007 Server" and "Lotus Domino Server 8.5" can be used. The config-
uration of DS-Win V4 is independent of the e-mail server being used.

Contents

This chapter contains the following topics:

Section 8.1, “Setting up Exchange 2007 Server”

Section 8.2, “Setting up Lotus Domino Server 8.5”

Section 8.3, “Configuring DS-Win V4”
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8.1 Setting up Exchange 2007 Server

Overview

The following steps describe how to set up the e-mail feature for Exchange Server 2007.

Contents

You find the following topics in this section:

Section 8.1.1, “Start the Management Console”

Section 8.1.2, “Add a «Send Connector»”

Section 8.1.3, “Add the «Receive Connector»”

8.1.1 Start the Management Console

To open the Management Console of the Exchange Server 2007, proceed as follows:

Further Processing

Refer to Section 8.1.2, “Add a «Send Connector»”.

8.1.2 Add a «Send Connector»

To add a "Send Connector", proceed as follows:

Step Action

1 Start the Management Console of Exchange Server 2007 via Start -> Program 
Files -> Microsoft Exchange Server 2007 -> Exchange Management Console.

Step Action

1 Open the Organization Configuration -> Hub Transport -> Send Connectors 
tab in the menu tree on the left.

2 Create a new "Send Connector" via the menu item New Send Connector (in the 
right window pane). A "New SMTP Send Connector" input window appears.

3 Enter a connector name in the "Name" input field and select die option Internet in 
the Select the intended use for... list box. Click Next.



ds-win_admin.c07.fm

A31003-G6640-M100-3-76A9, 08/2014
DS-Win V4, Administration Guide 8-3
       

Nur für den internen Gebrauch Setting up the E-mail Feature
Setting up Exchange 2007 Server

Further Processing

Refer to Section 8.1.3, “Add the «Receive Connector»”.

8.1.3 Add the «Receive Connector»

To add the "Receive Connector", proceed as follows:

4 Set the address options:

1. Open the New SMTP Send Connector -> Address Space -> Add -> "SMTP 
Address Space" input window.

2. Make the following entries: Type: SMTP; Address: *; enable the Include all 
subdomains check box, and Cost: 1.

3. Click OK. The settings are saved.

5 Enable New SMTP Send Connector -> Network settings -> Use domain name 
system (DNS) "MX" records to route mail automatically. Click Next.

6 Define the server to be used: 

1. Open New SMTP Send Connector -> Network settings -> Source Server.

2. Mark the displayed server. Alternatively, if no server is displayed, click Add and 
mark the predefined server.

3. Click Next. The end configuration of the "Send Connector" is displayed.

4. Click New. The "Send Connector" is created.

Step Action

1 Open Server Configuration -> Hub Transport in the menu tree on the left.

2 Create a new "Receive Connector" via the New Receive Connector menu item (in 
the right window pane). A "New SMTP Receive Connector" input window appears.

3 Enter a connector name in the "Name" input field and select the Internet option 
in the Select the intended use for... list box. Click Next.

Step Action



Setting up the E-mail Feature Nur für den internen Gebrauch

 A31003-G6640-M100-3-76A9, 08/2014
8-4 DS-Win V4, Administration Guide

      

Setting up Exchange 2007 Server

4 Define the network settings:

1. Open the New SMTP Receive Connector -> Introduction -> Local Network 
settings --> "Local Network settings" input window.

2. Mark the local network settings displayed.

3. Click Next. The end configuration of the "Receive Connector" is displayed.

5 Click New. The "Receive Connector" is created.

Step Action
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8.2 Setting up Lotus Domino Server 8.5

Overview

The following steps describe how to set up the e-mail feature for Lotus Domino Server 8.5.

Contents

You find the following topics in this section:

Section 8.2.1, “Install Lotus Domino Server”

Section 8.2.2, “Configure the SMTP Server on the Domino Server”

8.2.1 Install Lotus Domino Server

To install the Lotus Domino Server, proceed as follows:

Further Processing

Refer to Section 8.2.2, “Configure the SMTP Server on the Domino Server”.

8.2.2 Configure the SMTP Server on the Domino Server

To configure the SMTP Server on the Domino Server, proceed as follows:

Step Action

1 Install Lotus Domino Server 8.5 on a suitable Windows server, (e.g., Windows 
Server 2003. After the standard installation, some additional settings are required 
on the Domino Server.

Step Action

1 Edit the notes.ini file:

1. Open the notes.ini file on the Windows Server (e.g., under C:\Program 
Files\IBM\Lotus\Domino\notes.ini for an English operating system).

2. Add the line ServerTasks=SMTP to the notes.ini file.

3. Save and close the file.

2 Open the Services window with Start -> Run -> services.msc -> OK and stop 
the Domino Server.
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3 Load SMTP:

1. Open the Domino console by double-clicking the scontroller.exe file (e.g., 
from C:\Program Files\IBM\Lotus\Domino\scontroller.exe for an 
English operating system).

2. Enter the Load smtp command in the "Domino Command" field.

3. Click Send.

4. Close the Domino console.

4 Start the Domino Server in the Services window.

5 Configure the Domino Server:

1. Open Internet Explorer and enter http://<IP address of Domino 
server>/names.nsf in the address bar (e.g., http://192.168.1.78/
names.nsf)

2. Enter the user name and password for the Domino Server (assigned on install-
ing the Domino server). The user interface of the names.nsf file is displayed 
("Domino Directory/Add Person" window).

3. Select Configuration -> Servers -> All Server Documents in the "Domino Di-
rectory" pane on the left. The "Domino Directory/Add Server, Web, Search" 
window with the list of servers is displayed.

4. Enable the check box of the server you want to configure. A window with the 
headers "Domino Directory", "Edit Server", "Create Web" and "Cancel" ap-
pears with tabs such as "Basics", "Security", Ports", etc.

5. On the Basics tab, set the SMTP listener task entry to Enabled.

Step Action



ds-win_admin.c07.fm

A31003-G6640-M100-3-76A9, 08/2014
DS-Win V4, Administration Guide 8-7
       

Nur für den internen Gebrauch Setting up the E-mail Feature
Configuring DS-Win V4

8.3 Configuring DS-Win V4

In order to configure DS-Win V4 to work with Exchange Server 2007/Lotus Domino Server 8.5, 
proceed as follows:

Step Action

1 Start DS-Win V4 and log in as an administrator.

2 Open the Options -> Application Settings -> eMail Settings tab.

3 Enable the radio button SMTP Server in the "eMail Type" area.

4 Optional: Enable the Subject and Message check boxes in the "Defaults" area. 
These input areas are automatically displayed in an e-mail popup window when a 
user creates an e-mail using DS-Win V4.

5 Enter Sender data:

1. In the "Sender" input field, enter the sender in the following format:

● For Exchange Server 2007: <Name>@<Domain_Name>, 
(e.g., Administrator@exc2007.com).

● For Lotus Domino Server 8.5: <Name>/<Domain_Name>, 
(e.g., Administrator/Unify).

2. Optional: In the "BCC" field, enter any recipient to whom a blind copy of each 
e-mail should be sent.

6 In the "SMTP Server" area, enter the authentication information of the server on 
which the E-mail server is installed:

1. Enter the IP address of the server on which the e-mail server is installed (e.g., 
192.168.1.78) in the "Hostname" input field. 

2. Enter the port number used by the e-mail server in the "Port" field. The default 
is 25.

3. Enter the user name of the server on which the e-mail server is installed (e.g., 
Administrator) in the "UserID" input field.

4. Enter the password of the server on which the e-mail server is installed in the 
"Password" field.

5. In the "Timeout (ms)" field, enter the timeout in milliseconds that determines 
the expiration period for an e-mail. The default is 6000. If an e-mail cannot be 
sent within this time period, it is deleted.

7 Enable the DSWin E-Mail User Interface radio button to have an e-mail popup win-
dow displayed when a user wants to create an e-mail.
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8 Enter the database table and database column containing the e-mail information of 
the subscribers:

1. In the "Data source" field, enter the name of the database table, e.g., Sub-
scriber.

2. In the "eMail field", enter the column of the database table, e.g., email.
Make sure that the e-mail addresses of the subscribers you have selected on the 
View tab are contained in the specified database table.

9 Click OK. Your entries are saved.

Step Action
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9 Administering Users

Overview

The complexity of the system and the need to protect the data contained in the database call 
for security measures to ensure that the software cannot be damaged by incorrect operation or 
improper use.

DS-Win has a graded access concept at user level so that it is only necessary to enable the 
functionality actually needed in each case. An extended access permission comprises the 
more restricted access permissions.

Contents

You find the following topics in this chapter:

Section 9.1, “Different Access Rights”

Section 9.2, “Viewing and Assigning Access Rights, Adding New Users”

9.1 Different Access Rights

Example for the «User administration» window

User Data

In the "User administration" window, for every user the user name, the full name, the depart-
ment, the phone number, and additional information are displayed.
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Access Permissions

You can define for every user the following access permissions in the "Access rights" area:

● Edit data
The user is allowed to add data records to any tables and to import, export, synchronize, 
print, and delete data.

● Design dialogs
This access permission allows the user to design Data view dialogs or to modify existing 
objects.

● Design database structure
This access permission allows the user to create databases and to modify table structures 
or to create new tables, in other words, to insert new fields and to edit or delete existing 
fields, and to edit the MSysMappingTable and MSysCountry tables.

● Edit user profiles
The user can enter new users and delete existing ones as well as issue access rights. This 
access right reveals all DS-Win functions.

Without special access permissions, the user can only open the DS-Win Data view and exam-
ine data records there or repair the database.

9.2 Viewing and Assigning Access Rights, Adding New Users

Starting DS-Win Administration

Refer to Chapter 2, "Starting Administration".

Procedure

Proceed as follows:

Step Action

1 In the "DS-Win Administration" window: Select Options -> User administration. 
The "User administration" window opens. The table shows the users already entered.

2 You have the following options in the "User administration" window:
● Viewing access rights
● Assigning access rights
● Adding new users
Proceed as described in the following steps.

2a Viewing access rights:
Mark the user whose access permissions you want to see. You can see what func-
tions are permissible from the check boxes marked in the "Access rights" option 
group.
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Further Processing

If you enter the user name and the password of the new user in the "DS View" application, you 
can check if the user was created and which access permissions were assigned. If no access 
permissions were assigned, the user cannot perform changes.

2b Assigning access rights:

1. Mark the user whose access permissions you want to change. You can see what 
functions are permissible from the check boxes marked in the "Access rights" op-
tion group.

2. Mark or unmark the required check boxes.

3. Click Save. The new settings are saved, and the "New password" window opens.

4. Enter a new password for the user and click OK.

2c Adding a new user:

1. Click New user. The "User administration" window opens.

2. Enter the user data and assign the access rights. Refer also to Section 9.1, “Dif-
ferent Access Rights”.

3. Click Save. The new settings are saved, and the "New password" window opens.

4. Enter a new password and click OK. The new user is created.

Step Action
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9.3 Changing the Password

You can change user passwords. You must have the access right “Edit user profiles".

To do this, proceed as follows:

The new password is saved and must be used the next time you log on.

Step Action

1 In the “User administration" dialog, select the user whose password you wish to 
modify from the list of users.

2 Click the "Password..." button in the "User administration" dialog. 
The "New password" dialog opens.

3 Enter the old password.

4 Enter a new password.

5 Enter the new password a second time to confirm it.

6 Click OK.
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