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Important Notices
About This Book

1 Important Notices

1.1 About This Book

This manual provides overview and programming information for
application development working with the OpenScape Voice V4 and
later released product.

1.1.1 Prerequisite Knowledge

Users should have completed the appropriate technical and product
training for developing applications working with the OpenScape Voice
V4 and later releases.

These manual is intended for use by application developers working
with the OpenScape Voice V4 and later release product.

1.1.2 How to Use This Book

Use this manual to complete application development programming
tasks desired for the OpenScape Voice V4 and later releases.

1.1.3 Special Notices

If applicable, potentially dangerous situations are noted throughout
this guide. The three alert methods are defined below:

DANGER A danger notice calls attention to conditions that, if not avoided,
will result in death or serious injury.

WARNIN A warning notice calls attention to conditions that, if not avoided,
G could result in death or serious injury.

Caution A caution notice calls attention to conditions that, if not avoided,
may damage or destroy hardware or software.

1.2 Documentation Feedback

When you call or write, be sure to include the following information.
This will help identify which document you are having problems with.
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Important Notices
Documentation Feedback

* Title: OpenScape Voice V11, Application Developers Manual, Programming
Guide

* Order Number: A31003-H80A0-R100-01-7620

1.2.1 For U.S. only

To report a problem with this document, call your next level of support:
e Customers should call the Unify Customer Support Center.

¢ Unify GmbH & Co KG employees should call the Interactive
Customer Engagement Team (i-CET) or use the Document
Feedback form that you can access from the front page of the HTML
version of this document.

1.2.2 Countries other than U.S.

Please provide feedback on this document as follows:
e Submit a trouble ticket to ICTS, or

¢ Use the Document Feedback form that you can access from the
front page of the HTML version of this document.
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The Application Developers Manual

2 The Application Developers Manual

The OpenScape Voice V11 Application Developers Manual is subdivided into the
following sections.

*  Web Services SDK Programming Overview
* Link Failure Management
* Business Group Management

e Subscriber Self-Care

A31003-H80A0-R100-01-7620, 02/2022
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About the OpenScape Voice Web Services SDKs

Architecture

3 About the OpenScape Voice Web Services SDKs

The OpenScape Voice Web Services SDK Programming Overview
provides application development programming information that is
common to all SDKs, as well as an overview of each SDK.

3.1 Architecture

Bild 1 shows the generic architecture of the Unify Web Services SDKs.

Customer
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Web Services %‘?
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| Web Server
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SOAP/XML
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Applications

 OpenScape :
. Voice
: Real Time :
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Figure 1

Web Services SDK General Architecture

Each SDK exposes a Web Service Interface. This interface comes from
the OpenScape Voice system Real Time Servers.

Customers then build applications that access these Unify provided
Web Services. Using the functionality of the Web Services, customers
build custom applications to accomplish various tasks.

Because these SDKs are provided as Web Services, they are accessible

by Web Servers and custom applications that reside outside the

firewall. While this deployment is the most likely scenario, there is no
reason the applications and Web Server could not reside within the
firewall as well.

There may be numerous customer applications and numerous Web

Servers.
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About the OpenScape Voice Web Services SDKs
Architecture

For the various SDKs, the Unify SDK Servers host both the Web Service
Interface and the Web Service Execution layer.

Attention: For most customers, the SDK Server referenced in this
guide will be the OpenScape Voice system. Talk to your Unify
representative for details.

. H
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. | Firewall L 8
2 i
2| =
CUELDHTEI gl & Web Service Request > SOAP
Applications ol € Web Service Response
2| m
= P HTTP
0
r
t Web Service
Interface
SDK Server
Figure 2 Communication Between Applications and SDK Servers via

Web Services

Communications between the applications and the SDK Servers are via
Web Services. These web services communicate via SOAP/XML over
HTTP using the HTTP port of the SDK Server that is hosting the Web
Service Interface implementation.

When an HTTP POST message is received, the SOAP envelope is
extracted from the HTTP message. Next the XML data is extracted form
the SOAP envelope. At this point the XML message is interpreted by the
Web Service Execution layer and the appropriate actions are taken.

The result of executing the request (the response) follows the reverse
path back to the application. It is given to the Web Service Interface
layer to be packaged into XML, stuffed into a SOAP envelope, and then
transported back in an HTTP response message.

Once a customer is ready to develop an application, the SDK WSDL files
can be run through any number of industry-standard tools to create
proxy files in the desired target language; for example, C++ or Java.
Unify recommended environments include the SourceForge gSOAP and
Apache Axis environments, but any tool that uses WSDL files can be
tried.

A31003-H80A0-R100-01-7620, 02/2022
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About the OpenScape Voice Web Services SDKs
SDK Package Contents

Once a set of files has been created in the target language, the
programmer uses knowledge obtained from this SDK document and
sample applications to create his own custom applications. IMS
resources such as forums and newsgroups can be used to get answers
to specific questions and/or see answers to common problems.

The final result is a working, custom-built application that uses the
specified SDK.

3.2 SDK Package Contents

A Web Services SDK is made up of a set of components and tools that
the customer uses to create custom applications. Typically, an SDK will
consist of:

e The WSDL file
* An ADG, which includes sample code

* The interface specification, provided in Interface Manual: Volume 3,
SOAP/XML Subscriber Interface Provisioning.

3.3 Applications Development

The target applications development environments for the Link Failure
Management SDK are any environments that support C++ or Java
applications. Two good tools for generating header and source files
from WSDL are SourceForge gSOAP and Apache Axis. It should be
noted, however, that environmental and tool differences do arise, and
each different environment may require some unique solutions. There
are no requirements as to which Web Server is used.

3.3.1 SourceForge gSOAP

gSOAP is an open source SOAP toolkit that facilitates Web Services
development in a C/C++ environment. Within this environment is a
tool called wsdl2h which will take a WSDL file as input and create the
C/C++ header and code files needed to call the Web Services defined
by that WSDL file.

Detailed information on SourceForge gSOAP can be found at: http://
gsoap?2.sourceforge.net/.

A31003-H80A0-R100-01-7620, 02/2022
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About the OpenScape Voice Web Services SDKs
Technical Implementation Notes

3.3.2 Apache Axis

Axis is the Apache implementation that supports the SOAP standard as
defined by W3C. Within this environment is a tool called wsdl2java
which will take a WSDL file as input and create the java code needed
to call the Web Services defined by that WSDL file.

Detailed information on Apache Axis can be found at: http://
ws.apache.org/axis/.

3.4 Technical Implementation Notes

12

The following sections describe the technical implementation common
to all SDKs.

3.4.1 Discovery of Web Services

There is no explicit discovery mechanism for Web Services SDKs. Web
Services SDKs are accessed by using the IP address of the SDK Server
that hosts the SOAP server and the HTTP port.

3.4.2 Web Service Request/Response

A Web Service request/response consists of an SOAP/XML-encoded
request and response that is transported by HTTP, within the HTTP
POST and HTTP 200 OK messages. Each protocol identified as follows:
HTTP is in plain text, SOAP is underlined, and XML is in italics.

3.4.3 Request-Response Operation

All Unify SDKs currently support only a request-response paradigm. In
this paradigm, a request is made and a response specific to that
request is returned. The basic flow of the request-response model is as
follows, with key components highlighted in bold:

1. The Customer-Built Application makes a Web Service request.

2. The Web Service request is processed by the Web Server and the
proper SOAP/XML request is sent through the Firewall to the Web
Service Interface on the correct Unify SDK Server via an HTTP
POST message.

A31003-H80A0-R100-01-7620, 02/2022
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About the OpenScape Voice Web Services SDKs
Technical Implementation Notes

3. The Web Service Interface receives the request, parses the
SOAP/XML content, and passes it to the Web Service Execution
layer for execution.

4. The Web Service Execution layer executes the request,
formulates the response, and gives it to the Web Service
Interface layer for encoding and packaging.

5. The Web Service Interface layer encodes a SOAP/XML message
and sends it back through the Firewall to the Web Server via an
HTTP 200 OK message.

6. The Web Server forwards the response to the Customer-Built
Application, which can then continue its processing.

Customer

Bluiltl E
Application E
0
2 Firewall
== 1. Request X .
2. Response X
Gren st b e s ———————
[}
8
3. Request Y e
g
4, Response Y P
@
[ LN ] 0
[}
2

<n>. RequestZ

»
L

<n+1>. Response Z

SDK

— . Server |

Figure 3 Request-Response Operation

Responses are not correlated to requests with any type of request ID,
and as such an application must wait for a response before sending the
next request. In other words, on a single thread of the application, no
more than one single request can be outstanding at one time.

The Unify Web Services SDKs do not support any kind of monitoring or
subscribe-notify paradigm where asynchronous event flow is required.

If a response is not returned within a certain timeframe, the HTTP
request will time out and an error will be returned to the application.

A31003-H80A0-R100-01-7620, 02/2022
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About the OpenScape Voice Web Services SDKs
Technical Implementation Notes
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3.4.4 Security

The Unify Web Services SDKs do not provide any general mechanisms
for security common to all SDKs. Authentication, authorization, and
other security mechanisms will be provided on a per-SDK basis as
deemed necessary. Refer to the specific SDK documentation for details.

3.4.5 Sessions

With respect to the application context, the Unify Web Services SDKs
are sessionless.

3.4.6 Server Restart

There will be no specific indication to the application of a server restart.
The only indication an application might see is the timeout of a current
request.

3.4.7 Application Restart

The Unify SDK Servers will have no indication of an application restart.

3.4.8 Heartbeat Mechanisms

The Unify SDKs do not support any common heartbeat messages.

3.4.9 Error Handling

Responses may return specific errors relating to a specific request.
There is no overall general error message scheme amongst all SDKs.
For specific errors, refer to the supporting documentation of each SDK.

Under certain conditions, a Web Service request may time out. This
general condition may indicate failure in the network, failure on the
server, etc. It does not point to one specific failure.

SOAP and XML processing errors may also be returned. They indicate
badly formed SOAP or XML messages, which typically indicate a
customer application problem.

A31003-H80A0-R100-01-7620, 02/2022
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Description of Web Services SDKs

4 Description of Web Services SDKs

This chapter describes the set of SDKs that are currently provided and
supported by Unify for the OpenScape Voice environment.

Siemens Web
Services SDKs
— Firewall
_ .
[
Customer E [ Link Failure Management
Built 7))
Applicati L=] : i
pplications =
2 % CSTA
— : SOAR/XML i OpenScape |
o Voice .
i RealTime !
Server |
Provisioning SDKs:
Business Group Mgmt
Subscriber Self Care Mgmt
Figure 4 Current Set of Unify WS SDKs for OpenScape Voice

There are several SDKs provided by the OpenScape Voice system Real
Time Server. Bild 4 shows which SDKs are exposed by which components.

Taken together, these SDKs make up the Web Services SDKs supported
by Unify for the OpenScape Voice system.
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Description of Web Services SDKs
Link Failure Management SDK on the OpenScape Voice

4.1 Link Failure Management SDK on the OpenScape Voice

The following SDK is provided by the OpenScape Voice system real time
server to facilitate the management of link failures.

| Firewall
=
By
Wl E Ry (e ] A
Applications g OpenScape
: - Voice |

Figure 5 OpenScape Voice Link Failure SDK

With the Web Service for Link Failure Management, a Network
Management Service (NMS) application can inform the OpenScape
Voice system that an access link is down and instead a backup link will
be used, or vice versa. With this information, an NMS application can
always use the appropriate link capacity for its call admission
calculations.
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Description of Web Services SDKs
SDKs for Provisioning

4.2 SDKs for Provisioning

The following set of SDKs will be provided by the OpenScape Voice
system Real Time Server to facilitate Subscriber and Business Group

management.

_ Firewall
.
g
Customer [ iness
Built 0 . 'hSIfC :
i | Subscriber Self Care | : ;
Applications ﬁ  OpenScape
2 2 Nojee
Figure 6 OpenScape Voice Provisioning SDKs

This is a set of layered SDKs. The outside layer is the Business Groups
SDK, which adds its own functionality and contains the Subscriber Self

Care SDK.
This set of SDKs supports the following functionality:

* Business Group Management
This SDK provides functions associated with managing business

groups, BGLs, and numbering plans.

* Subscriber Self Care
This SDK provides functions associated with subscriber self care

(SSC).
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Description of Web Services SDKs
SDKs for Provisioning

A31003-H80A0-R100-01-7620, 02/2022
18 OpenScape Voice V11, Application Developers Manual, Programming Guide



Generating a Java client Proxy and a Sample Application
Eclipse IDE configuration

5 Generating a Java client Proxy and a Sample
Application
The following example demonstrates how to create a Java client proxy

and a sample application using the Axis2 runtime environment based
on Unify’s WSDL file (OpenScape_Voice.wsdl).

Prerequisites:

» Eclipse IDE for Java EE Developers
https://www.eclipse.org/downloads/

Note: eclipse-jee-kepler-SR2-win32-x86_64.zip was used for
this guide.

* Apache Axis2 v1.6.2
http://ws.apache.org/axis2/download.cgi

* Axis2 Eclipse Codegen Plugin
http://axis.apache.org/axis2/java/core/tools/eclipse/wsdl2java-plugin.html

Download and install Code Generator Wizard for Eclipse Plug-
in,

Note: v1.6.2 was used for this guide.

and follow the instructions that make use of the dropins directory.
http://axis.apache.org/axis2/java/core/tools/eclipse/plugin-installation.html

* Download Apache Tomcat
https://tomcat.apache.org/

Note: Tomcat 6.0 was used for this guide.

and extract it on a local folder.

5.1 Eclipse IDE configuration

Configure Eclipse to support Apache Tomcat Server and Apache
Axis2, and verify that Axis2 Eclipse Codegen Plugin has been
installed successfully:

A31003-H80A0-R100-01-7620, 02/2022
OpenScape Voice V11, Application Developers Manual, Programming Guide 19


https://www.eclipse.org/downloads/
http://ws.apache.org/axis2/download.cgi
http://ws.apache.org/axis2/download.cgi
http://axis.apache.org/axis2/java/core/tools/eclipse/plugin-installation.html
http://axis.apache.org/axis2/java/core/tools/eclipse/plugin-installation.html
https://tomcat.apache.org/
https://tomcat.apache.org/
http://axis.apache.org/axis2/java/core/tools/eclipse/wsdl2java-plugin.html

Generating a Java client Proxy and a Sample Application
Eclipse IDE configuration

1. Start the Eclipse WTP workbench.

2. Navigate to Window > Preferences > Server > Runtime
Environment and click Add...

A31003-H80A0-R100-01-7620, 02/2022
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Generating a Java client Proxy and a Sample Application
Eclipse IDE configuration

3. Inthe New Server Runtime Environment window select your
runtime environment under the Apache category and mark the
Create new local server checkbox.

New Server Runtime Environment
Define a new server runtime environment

Download additicnal server adapters

Select the type of runtime environment:

type filter text

»

4 (= Apache
E Apache Tomecatv3.2
E Apache Tomeat w4
B Apache Tomcat vdl
B Apache Tomcat v5.0
B Apache Tomcat 5.5
[ Apache Tomeat v6.0
[ Apache Tomeat w7
» = Basic —
» (= JBoss -
Apache Tomcat v6.0 supports J2EE1.2, 1.3, 1.4, and Java EE 5 and 6 Web modules.

m

[¥] Create a new local server

@ < Back Next » ] [ Finish ] ’ Cancel

Click Next >

4. Fill in your Tomcat installation directory on the next screen and click
Finish.

A31003-H80A0-R100-01-7620, 02/2022
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Generating a Java client Proxy and a Sample Application

Eclipse IDE configuration

-
@] New Server Runtime Enviror
=

Tomcat Server
Specify the installation directory

MName:

|&pache Tomcat v6.0
Tomcat installation directory:

Disetup\apache-tomeat\apache-tomcat-6.0.39

JRE:

apache-torncat-6.0.37 | Download and Install...

Browse...

Workbench default JRE

|| Installed JREs...

® s>

Cancel

[ Finsh ||

A31003-H80A0-R100-01-7620, 02/2022
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Generating a Java client Proxy and a Sample Application
Eclipse IDE configuration

5. Apache Tomcat v6.0 is now listed under Server Runtime
Environments:

Plug-in Development

Remote Systems
Run/Debug
Server
Audio
Launching |
Overlays

E Preferences l . — — || [E] | 22 |
type filter text Server Runtime Environments (=l aeie |
pGenenl = Add, remove, or edit server runtime environments,
r Ant
> Data Management Server runtime environments:
Raeln Mame Type Add...
i Install/Update
> Java E Apache Tomeat vi.0 Apache Tomeat vi.0 tdit.. |
1 JavaEE fl
1 Java Persistence Remove
1 JavaScript
 Mylyn - fl
[
b
3
4

Profilers

Runtime Environme—
» Team
Terminal
Validation -
T

@ o J[ canca ]

k S 'J

Click OK.

6. Navigate to Window > Preferences > Web Services > Axis2
Preferences. Select the Axis2 Runtime tab and point to the
correct Axis2 runtime location.

e S T, - =

type filter text Axis2 Preferences SR I S
> Java -
> Java EE Axis2 Runtime |Ax|52 PrE‘felencﬂ|

> Java Persistence
> JavaScript Axis2 runtime location:  Di\setuphaxis2\axis2-1.6.2
> Maven

Iylyn

Plug-in Development
Remote Systems
Run/Debug

Server

Axis2 runtime loaded successfully

> Team
Terminal
Validation
> Web
4 Web Services
Axis Emnitter
i Prefrences |
CXF 2x Preferences
Popup Dialog Select|
Project Topelogy
Resource Managem
Scenario Defaults

Server and Runtime
Test Facility Default|
Wizard Validation

WSDL Files -

4 n E

@ [ o J[ cana |

l Restore Defau\ts] l Apply l

Click OK.
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Generating a Java client Proxy and a Sample Application

Java client proxy creation

7. To verify that Axis2 Eclipse Codegen Plugin has been

5.2 Java client proxy creation

successfully installed go to File > New > Other... and make sure
that under the Axis2 Wizards category, Axis2 Code Generator
is listed.

To create a Java client proxy from a WSDL file (OpenScape-

Voice.wsdl) do the following:
1.
2.

24

Create a Dynamic Web project

Navigate to File > New > Other...

Under the Web category, select Dynamic Web Project and click
Next >.

e - -

| Select a wizard

—

Wizards:
type filter text

[» [ Remote System Explorer
[ (&= Server
[ = 5QL Development
i (= Tasks
i = User Assistance
4 (= Web
|5 CSSFile

> Filter

&% HTML File
[37 ISP File
|4 JSP Tag

.‘_:3 Dynamic Web Project |

m
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Generating a Java client Proxy and a Sample Application
Java client proxy creation

3. Inthe New Dynamic Web Project screen:
a) Type in the Project name (i.e. Axis2WSClient)

b) Make sure that Apache Tomcat wv6.0 isthe selected Target
runtime.

c) Click on Modify...

d) Selectthe Axis2 Web Services project facet and click OK.

L ™
s wEEe

Dynamic Web Project 7

Create a standalone Dynamic Web project or add it to a new or existing | 0
Enterprise Application. -

Project name: | Axis2W5Client

Project location
Use default location

Location: | DAECLIPSEVAxis2WSClient Browse...

Target runtirme

[Apache Tomcat via.0 v] | Mew Runtime... |

Dynamic web module version

o 2

Configuration

[Default Configuration for Apache Toemcat v6.0 - | [ Madify... |

A good starting point for working with Apache Tomcat v8.0 runtime. Additional facets
can later be installed to add new functionality to the project.
EAR membership

Add project to an EAR

EAR project name: | EAR New Project...

Working sets

[7] Add project to working sets

Wirarking sets r Select...

@ <Back | Net¢> |[ Finsh ][ Cancel

e) Click on Finish.

A dynamic web project is created in the workbench.

A31003-H80A0-R100-01-7620, 02/2022
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Generating a Java client Proxy and a Sample Application
Java client proxy creation

4. To create a Java client stub, the Axis2 Eclipse Codegen Plugin
(wsdl2java) will be used. Go to File > New > Other... > Axis2
Wizards > Axis2 Code Generator.

EEE
I iiiiiiiiiii —— S BBFEE—_—_—,E—_E _—S—E—,————_—_—_—_—_—_—€——

Select a wizard —

Wizards:
type filter text

I = General
4 = Axis? Wizards
(& 2 Code Gensrator
i+ = Connection Profiles
b = CVS
[+ = Database Web Services
[» [= Eclipse Modeling Framework
» = EJB
b 2= Git
I = Java
I = Java EE

[> [= Java Emitter Templates

Click Next >.

5. On the next screen select Generate Java source code from a
WSDL file and click Next >.

6. Click on Browse... and point to the location where Unify’s WSDL file
(OpenScape-Voice.wsdl) is stored.

Click Next >.

A31003-H80A0-R100-01-7620, 02/2022
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Generating a Java client Proxy and a Sample Application
Java client proxy creation

7. On the next screen use the default values

 Axis2 Codegen Wizard ._

)
Options
Set the options for the code generator. If you wish to edit the codegen options, Select custom option
| from Codegen Qption drep down list,

Codegen opticn ’defaul‘k V]
OQutput language :ja\ra -

Service Mame [openscape_voice = ]
Port Name [openscape_voice V]
Databinding Mame jadb =
Custom package name | openscape voice |

[] Generate test case

[V] Generate client side code

(@ Generate both sync and async Generate sync style only Generate async style only

[[] Generate server side code

["] Generate a default servicesaxml ["] Generate an Interface for Skeleton

[ ] Generate Both with all classes for every elements on Shemas

Mamespace to package mappings

Mamespace
http://schemasxmlscap.org/seap/envelope/
http://schemas.xmlsoap.org/wsdl/
urn:openscape-voice

urn:openscape-voice

Custom package name

orgxmlscap.schemas.soap.envel..

m

orgxmlscap.schemaswsdl
openscape_voice
openscape_voice

hittps/fwrwew.w3.org/ 2001/ XMLSchema org.w3.www,_2001 xmlschema

Advance Options |

@ <Back | Nea> ]| Fnsh | Cancal |

and click Next >.
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8. Inthe Axis2 Codegen Wizard screen:

a) Select Browse and select a project on current eclipse
workspace and click on Browse... Then point to the
Axis2WSClient directory.

b) Mark the Add Axis2 libraries to the codegen result project
checkbox and click on the Browse... button.

c) Point to the directory where the downloaded Axis?2 libraries are
stored and then click on the Check Libs... button to verify that
the operation completed successfully.

i N

Output

Set the output location for the generated code

Select one of below to save the codegen output either on eclipse workspace project or
on file systern and then browse to enter the output path

@ Browse and select a project on current eclipse workspace

() Browse and select location on local file system

Outputpath  DAECLIPSE\Axis2WSClient

[7] Add the Axis2 codegen jars to the codegen resulted project

[¥] Add Axis2 libraries to the codegen result project

AdsHome  DAsetup\ais?\axis2-16.2
Check Libs...| Axis libs loaded successfully !

[] Create a jar file of codegen result project and add to resulted project lib folder (Default : CodegenResults.jar)

Jar File Name

Finish | |

9. All client stub and library files are now generated and stored under
the
../Axis2WSClient\src\openscape_voice and
../Ax1s2WSClient\1lib directories respectively.

10. Press F5 to refresh the project.
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11. Navigate to File > New > Other... > Class to create your main
function.

& New =)

Select a wizard p—
[

Create a Java class

Wizards:
type filter text

| @ Class| -
€& Interface
@ lava Project
& Java Project from Existing Ant Buildfile
E{Dﬁ Plug-in Project

I+ = General

I (= Axis2 Wizards

I+ [= Connection Profiles

&= CVS

[+ [= Database Web Services

[» [ Eclipse Modeling Framework

> = BB -

m

@ < Back Next > Finish

Click Next >.

12. Set the name of the class to Axis2WSClient and mark the public
static_void main(Strings[] args) checkbox.

ﬂ New Java C{ags E S| |

Java Class
Create a new Java class. @

Source folder: Axis2W5Client/src
Package: openscape_voice

[“] Enclosing type: Browse...
Mame: BAxis2WSClient
Modifiers: @ public () default private protected
[T abstract [ final static
Superclass: Jjava.lang.Object
Interfaces: Add
Remove

Which method stubs would you like to create?
public static void main(String[] args)
|| Constructors from superclass
Inherited abstract methods
Do you want to add comments? (Configure templates and default value here)

|:| Generate comments

@ Nec> | [_Fnsn ][ cancel
Click Finish.
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13

package openscape_voice;

import java.rmi.RemoteException;
import org.apache.axis2.AxisFault;

public class Axis2WSClient{
{public static void main(String

try {
Openscape_voiceStub osv

. You are now ready to use the main java stub

(Openscape_voiceStub. java) to create your client. The
example below demonstrates how to retrieve the number of
subscribers belonging to a specific Business Group
(BG_TestCallGenerator).

[1 args) {

= new Openscape_voiceStub ("http://10.7.182.10:8767") ;

GetSubscriberlListRequest getSublListReq = new GetSubscriberListRequest();

BGName bgName = new BGName () ;
bgName . setBGName ( "BG_TestCallGenerator") ;
getSubListReq. setBGName (bgName) ;

GetSubscriberList GetSubscriberListEntryInfo = new GetSubscriberList () ;
GetSubscriberListEntryInfo.setGetSubListReq(getSubListReq) ;

HigGLOBALHEADER globalHeader = new HigGLOBALHEADER () ;
globalHeader.setOperatorId("Axis2WSClient") ;
HiQHEADER higHEADER = new HigHEADER() ;

higHEADER. setHigHEADER (globalHeader) ;

GetSubscriberListResult

result = new GetSubscriberListResult() ;

GetSubscriberListData listData = new GetSubscriberListData() ;

result.setGetSubscriberListData (listData) ;

try {

result = osv.getSubscriberList (GetSubscriberListEntryInfo, higHEADER) ;

int noOfSubs = result.getTotalSubsFound() ;
System.out.println("\nBG Name: " + bgName) ;
System.out.println("\nNumber of Subscribers: " + noOfSubs + "\n");

GetSubscriberListEntry[] listEntries = new GetSubscriberListEntry[noOfSubs];
listData = result.getGetSubscriberListDatal() ;
listEntries = listData.getGetSubscriberListEntry () ;

for(int 1=0; i<noOfSubs; i++)

System.out.println(listEntries[i].getServicelId());

} catch (RemoteException e) {
// TODO Auto-generated catch block

e.printStackTrace() ;
}
} catch (AxisFault e) {

// TODO Auto-generated catch block

e.printStackTrace() ;

30
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14. Select Run > Run As > Java Application.

Check the output on the console.

T &l Console 22 :
<terminated> Axis2WSClient [Java Application] C:\Program Files\Java\jre7\bin\javaw.exe (Aprl, 2014, 8:46:17 PM)

BG Name: BG_TestCallGenerator
Number of Subscribers: 2

9999999391
9999999392
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6 Generating a Service Reference and a Sample
Application

The following example demonstrates how to consume a WebService
using a WSDL file in C#.

Prerequisites:

¢ Visual Studio 2010 Professional installed

6.1 Creating a Visual C# project
To create a Visual C# project to consume the provided WSDL file
(OpenScape Voice.wsdl), follow the procedure below:

1. Open Visual Studio.

Select File > New > Project... > Console Application

| New Project _ = : .:

|.NET Framework 4 ~ | Sort by: | Default Search Installed Tem O |
Installed Templates i |
E ‘Windows Forms Application  Visual C# o TypenVend G
4 Visual C# - A project for creating a command-line
Windows et WP A i application
Web - pplication Visual C#
Office
Cloud \=ch Console Application Visual C#
Reporting
SharePoint ;ﬁ ASP.NET Web Application Visual C# =
Silverlight
Test J'E Class Library Visual C#
WCF
Workflow E Silverlight Application Visual C#
Other Languages ¥
g:::;:;:lm Aypes é:fr. Silverlight Class Library VisualC# | |
Iesthiakets @ WCF Service Application Visual C#

I Online Templates =
| =
@ Enable Windows Azure Toels  Visual C#

% ASP.NET Dynamic Data Entiti...Visual C#

‘Iﬁ% Excel 2010 Workbook Visual C# =
Name: W5Client
Location: D:PROJECTS VISUAL _STUDION - Browse... |
Solution name: WSClient /| Create directory for solution

V| Add to source control

Type in the name of your application (i.e. WSC1lient) and click OK.
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2. On the Solution Explorer panel, right click on the WSClient

34

project and select Add Service Reference...

| aa WSClient - Microsoft Visual Studio (Administraton

[ Fite Edit View Refactor Project Build Debug Team Data Tools Test Window Help
e SRS - NS '@'__ﬂ,‘leabug -|||_?;‘9|\tem
B aEEEZ 2008 a0 8

f| /¢ Solution Explorer ¥ EIEIETRSIPE Object Browser
= | & 2] ‘ L= ‘5':'% 8 W5Client.Program ~| @¥Main(string[] args)
; Solution "WSClient' (1 project) —lusing System;
a ,EWSCIient using System.Collections.Generic;
> [=d| Properties using System.linq;
> [ References | using System.Text;
4] Program.cs

Elnamespace WSClient

{

= class Program

=] static void Main(string[] args)
{
}

| }

1

100% =~ 4 m 3

& 0 Errors | I\ 0 Warnings | (i) 0 Messages

- = - -
D File Line Column Project

Q‘Z Solution Explorer || j SEER LTS

In the Add Service Reference screen:

a) Fill in the path to the WSDL file on the Address field, and press
Go.

openscape_voice service is now listed under the Services
area.

b) Change the Namespace to OSVServiceReference

Add Service Reference | ? &2 |

To see a list of available services on a specific server, enter a service URL and click Go. To browse for available
services, click Discover.

Address:

D\PROJECTS VISUAL STUDIOWSClienf\WSClienf\OpenScape-Voicewsd] = i

Services: Operations:

(&) #| openscape_voice

Select a service contract to view its operations.

1 servi Ee(s) found at address D\_IS ROJEE,TS_VISUAL__STUDIO\WSCI |ent\WSC li ént‘lOpen Sca pe-‘u’di cewsdl',

Mamespace:

ServiceReferencel

e

&
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c) Click OK.
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4. Addthe WSClient.0SVServiceReference namespace on your
program in order to use the service reference you created.

WSClient - Micosoft Visual Studio (Administator ] 5 o]
File Edit View Refactor Project Build Debug Team Data Tools Test Window Help |
- Sl d | % a9 -0 - E‘"IHDebug -| | 3 227214 || S L 2

iDabeREsE 20083 aE3d 56
/A Solution Explarer > 1 RIGNELRE S Object Browser - X
= g
7 ElSIalE 2 WSCliznt.Program - 5% Mainistring(] srgs) B -
E ; Solution "WSClient' (1 project) —using System; Ea e
d EWSCIIEM using System.Collections.Generic; . PSS
[=d| Properties using System.ling; B
. [&a References using System.Text;

3 using WSClient.0SVServiceReference;
4 | Service References

W OSVServiceReference

m

Elnamespace WSClient

|3 app.config {
#] Program.cs = class Program L5
i
E static void Main(string[] args)
{
}
}
}
W% = 4| m ] b

@ 0Errors | 1\ 0 Warnings | (i) 0 Messages

-

D. File - Line ” Column Project

C‘; Selution Explorer | P =t=ITs

Itemn(z) Saved Ln5

Ch 36 INS

5. You are now ready to use the service reference
(OSVServiceReference) to create a client. A code snippet is
provided below that demonstrates the retrieval of the number of
subscribers belonging to a specific Business Group
(BG_TestCallGenerator).
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using System;
using System.Collections.Generic;
using System.Ling;
using System.Text;
using WSClient.OSVServiceReference;
namespace WSClient
{
class Program
{
static void Main(string[] args)
{
System. ServiceModel .BasicHttpBinding binding = new System.ServiceModel.BasicHttpBinding () ;

System. ServiceModel . EndpointAddress address = new System.ServiceModel .EndpointAddress ("http://
10.7.182.10:8767") ;

openscape_voicePortTypeClient osv = new OSVServiceReference.openscape voicePortTypeClient (binding,
address) ;

higGLOBALHEADER higHEADER = new OSVServiceReference.higGLOBALHEADER () ;
higHEADER.OperatorId = Environment.UserName;

GetSubscriberListRequest getSubListReq = new GetSubscriberListRequest();
getSubListReq.BGName = "BG_TestCallGenerator";

GetSubscriberListEntry[] GetSubscriberListEntryInfo;

int TotalSubsFound = 0;

PaginatedInfo PageInfo;

ResultCodeStruct result;

GetSubscriberList getSubscriberList = new GetSubscriberList();
getSubscriberList.GetSubListReq = getSubListReq;

GetSubscriberListResult rc = osv.GetSubscriberList (higHEADER, getSubscriberList);
result = rc.Result;

PageInfo = rc.PaginatedInfo;

TotalSubsFound = rc.TotalSubsFound;

GetSubscriberListEntryInfo = rc.GetSubscriberListData;

Console.Write("\nBG Name: " + getSubListReq.BGName + "\n");

Console.Write("\nNumber of Subscribers: " + TotalSubsFound + "\n\n");
foreach (GetSubscriberListEntry item in GetSubscriberListEntryInfo)
{

Console.Write(item.ServiceId + "\n");

6. Press F5 to run your project. Check the output on the console.

i filey//D:/PROJECTS_VISUAL STUDIO/WSClient/WSClient/bin/Debug/WSClient.EXE o e e S

BG Mame: BG_TestCallGenerator

Humber of Subscribers: 2
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7 Examples

This chapter contains concrete examples on how to use different
commands with SOAP. You always need a request and a result.

7.1 Change Subscriber name

1. Open the Openscape Voice V9 - SOAP Interface
Documentation

You need the UpdateSubscriberBGInfo2 command from SOAP
Click the Modules tab

Search for Subscriber (it is under LostServer)

Search for unsp__UpdateSubscriberBGinfo2

Click unsp__UpdateSubscriberBGinfo2

o o &~ w0 N

Click unsp__UpdateSubscriberBGInfoRequest

NOTE: To get the fields for the Business Group click
unsp__SubscriberBGinfo.

At the request, set the following fields:

Serviceld: The Service ID of the subscriber to be updated (which is
the name of your subscriber DN).

OperatorlD: It is just a name of an operator (always requested)

BGLineName of SubscriberBGInfo struct: Subscriber BG Line
Name corresponds to "Display Name" column/field on an Openscape
Voice Assistant.

An example of such a SOAP request is provided below:
Serviceld: 302106129100 - My subscriber DN
Operatorld: op - Just a string

BGLineName: test_1 - the new Display Name of my subscriber (+
30(210)6129100 was the initial Display Name)

<?xml version="1.0" encoding="UTF-8"?>
<SOAP-ENV:Envelope

xmlns:SOAP-ENV="http://schemas.xmlsoap.org/soap/envelope/"
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xmlns:SOAP-ENC="http://schemas.xmlsoap.org/soap/encoding/"
xmlns:xsi="http://www.w3.0rg/2001/XMLSchema-instance"
xmlns:xsd="http://www.w3.0rg/2001/XMLSchema"
xmlns:unsp="urn:siemens-hig8000">

<SOAP-ENV:Body encodingStyle="http://schemas.xmlsoap.org/

soap/encoding/">

<

<unsp:UpdateSubscriberBGInfo2>
<UpdateSubscriberBGInfoRequest>
<ServiceId>302106129100</ServiceId>
<OperatorId>op</OperatorId>
<SubscriberBGInfo xsi:type="unsp:SubscriberBGInfo">
<BGLineName>test 1</BGLineName>
</SubscriberBGInfo>
</UpdateSubscriberBGInfoRequest>
</unsp:UpdateSubscriberBGInfo2>
</SOAP-ENV:Body>

/SOAP-ENV:Envelope>

7.2 Change assigned Feature Profile

1.

Open the Openscape Voice V9 - SOAP Interface
Documentation

Click the Classes tab
Click unsp__UpdateSubscriberFeatureProfileRequest

Click unsp__FeatureProfileld to see all the other values

An example of such a SOAP request is provided below:

1.
2.

40

Serviceld: 302106129100 - My subscriber DN
Operatorld: op - Just a string

FeatureProfileName: fp_test2 - The Feature Profile Name (the
one you want to set)

BGName: BG_Test - The name of the Business Group to which the
Feature Profile is associated
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<?xml version="1.0" encoding="UTF-8"7?>
<SOAP-ENV:Envelope
xmlns:SOAP-ENV="http://schemas.xmlsoap.org/soap/envelope/"
xmlns: SOAP-ENC="http://schemas.xmlsoap.org/soap/encoding/"
xmlns:xsi="http://www.w3.0rg/2001/XMLSchema-instance"
xmlns:xsd="http://www.w3.0rg/2001/XMLSchema"
xmlns:unsp="urn:siemens-hig8000">
<SOAP-ENV : Body>
<unsp:UpdateSubscriberFeatureProfile2>
<UpdateSubscriberFeatureProfileReqg>
<ServiceId>302106129100</Serviceld>
<OperatorId>op</OperatorId>
<NewFeatureProfileId>
<FeatureProfileName>fp_test2</FeatureProfileName>
<BGName>BG_Test</BGName>
</NewFeatureProfileId>
</UpdateSubscriberFeatureProfileReqg>
</unsp:UpdateSubscriberFeatureProfile2>
</SOAP-ENV:Body>

</SOAP-ENV:Envelope>

7.3 Do Not Disturb

To add/remove a Feature on a subscriber you need to use the
UpdateSubscriberFeatures2 SOAP API.

1. Open the Openscape Voice V9 - SOAP Interface
Documentation

2. Click the Modules tab
3. Scroll down until you see Subscriber Features.

4. Click Subscriber Features (now you are at Classes)
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5. Scroll down to the end and click on
unsp__UpdateSubscriberFeatures2()

6. Click on unsp__UpdateSubscriberFeaturesRequest

7. You can click on unsp__ListOfFeatures to see the possible
features.

8. An example of such a SOAP request is provided below:

Serviceld: 302106129100 - My subscriber DN
Operatorld: op - Just a string
CfDND: Do Not Disturb feature

Subscribed: Standard Subscribed enumeration for the current action
(AddReplace to add the feature, Delete to remove the feature).

Enabled: Standard Enabled flag. Set to true/false to enable/disable
the feature.

To add (update) DND feature:

<?xml version="1.0" encoding="UTF-8"?><soapenv:Envelope
xmlns:soapenv="http://schemas.xmlsoap.org/soap/envelope/"
xmlns:xsd="http://www.w3.0rg/2001/XMLSchema"
xmlns:xsi="http://www.w3.0rg/2001/XMLSchema-instance">

<soapenv:Header>

<nsl:higHEADER soapenv:actor="http://
schemas.xmlsoap.org/soap/actor/next"
soapenv:mustUnderstand="0" xmlns:nsl="urn:siemens-hig8000">

<InterfaceWSDL>V9.00.52.01</InterfaceWSDL>
<OperatorId>uCtxId:10868</0OperatorId>
<ClientId>10.1.33.22</ClientId>
</nsl:higHEADER>
</soapenv:Header>
<soapenv:Body>

<UpdateSubscriberFeatures2 xmlns="urn:siemens-
hig8000">

<UpdateSubscriberFeaturesRequest xmlns="">
<ServiceId>302106129100</ServiceId>

<OperatorId>op</OperatorId>
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<ListOfFeatures>
<CfDND>
<Subscribed>AddReplace</Subscribed>
<Enabled>false</Enabled>
</Cf£DND>
</ListOfFeatures>
</UpdateSubscriberFeaturesRequest>
</UpdateSubscriberFeatures2>
</soapenv:Body>

</soapenv:Envelope>

In this example DND feature was added to the 302106129100
subscriber and the feature is disabled. Set Enabled=true to add the
feature and enable it.

To enable/disable the feature, use the same API call by setting the
Enabled flag to true/false respectively. You can also add/update more
than one features per a single SOAP API call by setting more than one
features in <ListOfFeatures> tag.

To remove the DND feature from a subscriber:

<?xml version="1.0" encoding="UTF-8"?><soapenv:Envelope
xmlns:soapenv="http://schemas.xmlsoap.org/soap/envelope/"
xmlns:xsd="http://www.w3.0rg/2001/XMLSchema"
xmlns:xsi="http://www.w3.0rg/2001/XMLSchema-instance">

<soapenv:Header>

<nsl:higHEADER soapenv:actor="http://
schemas.xmlsoap.org/soap/actor/next"
soapenv:mustUnderstand="0" xmlns:nsl="urn:siemens-hig8000">

<InterfaceWSDL>V9.00.52.01l</InterfaceWSDL>

<OperatorId>uCtxId:10868</OperatorId>

<ClientId>10.1.33.22</ClientId>
</nsl:higHEADER>

</soapenv:Header>
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<soapenv:Body>

<UpdateSubscriberFeatures2 xmlns="urn:siemens-
hig8000">

<UpdateSubscriberFeaturesRequest xmlns="">
<ServiceId>302106129100</Serviceld>
<OperatorId>op</OperatorId>
<ListOfFeatures>
<CfDND>
<Subscribed>Delete</Subscribed>
<Enabled>false</Enabled>
</CE£DND>
</ListOfFeatures>
</UpdateSubscriberFeaturesRequest>
</UpdateSubscriberFeatures2>
</soapenv:Body>

</soapenv:Envelope>

IMPORTANT: Use the same logic for any other feature.
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